Results 1 to 10 of 10

Thread: I killed my fglrx driver and now only get 640x480 - Help!

  1. #1
    Join Date
    Dec 2008
    Posts
    6

    Default [SOLVED]I killed my fglrx driver and now only get 640x480 - Help!

    I'm new to Linux and have been trying to get a Mythbuntu box working for about a month now. Backend records fine, but the frontend is useless because I can't get the graphics driver working properly for playback. My system:

    Case : Antec Veris Fusion Black 430 (with the LCD, not VFD)
    Mobo : ASUS M3A78-EM (ATI Radeon HD3200 / 780G chipset)
    CPUs : AMD Athlon X2 4850e 2.5GHz
    RAM : GSKILL 2GB (2*1GB of DDR2 1066)
    HDD : WD6400AACS 640GB, SATA
    DVD : ASUS DRW-2014L1T, SATA
    Tuner: HDHomerun ATSC (both inputs from a DB2 antenna)
    TV : Samsung LN-S4095D 40" 1080p LCD HDTV (tried VGA and HDMI)
    LAN: DLink WDA-1320 (running on Atheros restricted driver)
    OS : Mythbuntu 8.04.1 64-bit (minimal changes to xorg.conf).

    The best I've ever had it working was with the "stock" fglrx setup that results from installing from the CD and then letting Ubuntu update itself from the repository. Fglrxinfo showed:

    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 3200 Graphics
    OpenGL version string: 2.1.7412 Release

    There were only two remaining problems with that setup -

    * Color space was inverted. Skin tones were shades of blue and blue was orange. I read stuff on forums about recompiling MythTV with a hack to get round this, but the information was outdated so I didn't try it.

    * Slight tearing of video on 1080i recordings, usually about 1/3 the way up the screen.

    In an attempt to fix the above, I tried to update my system to use the Catalyst 8.11 software from the AMD/ATI website. (I wanted the latest driver and the GUI config controls.) I followed ATI's instructions (http://wiki.cchtml.com/index.php/Ubu...allation_Guide) to the letter, but upon reboot I got a black screen when Linux tries to start the graphical environment. After ~30s I got an illegible, low-res dialog box that by trial and error allowed me to configure the display for 640x480 and that's as good as I can get now.

    I've tried messing with the restricted drivers manager GUI, but that seemed to uninstall the driver. I then tried reinstalling, using the cchtml instructions from the point: $ sudo dpkg -i xorg-driver-fglrx... - still no good. Can't get better than 640x480. GUI shows that the ATI driver is not installed and not in use. However, Fglrx is still there at least in part, because flgrxinfo reports this:

    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)

    Looks to me like the system is using the wrong driver. I tried removing the GLX driver like it said in the install instructions:

    sudo apt-get remove xserver-xgl

    but Ubuntu tells me that there is no such driver installed. When I look in the xorg.conf file, it looks like it's invoking XGL and is setup for 640x480:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Boardname	"vesa"
    	Busid		"PCI:1:5:0"
    	Driver		"vesa"
    	Screen	0
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    	Vendorname	"Plug 'n' Play"
    	Modelname	"Plug 'n' Play"
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Configured Video Device"
    	Monitor		"Configured Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	640	480
    		Modes		"640x480@60"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"v4l"
    EndSection
    Section "ServerFlags"
    EndSection
    I then tried doing an aticonfig --initial with my original xorg.conf in the /etc/X11 directory:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    EndSection
    
    Section "Monitor"
    	Identifier   "Configured Monitor"
    EndSection
    
    Section "Device"
    	Identifier  "Configured Video Device"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "TexturedVideo" "on"
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "Configured Video Device"
    	Monitor    "Configured Monitor"
    	DefaultDepth     24
    EndSection
    ...but then the whole process repeats again - black screen on reboot and illegible dialog to change to 640x480. I've tried the GUI Xorg config tool from the Mythbuntu menu but the only resolution it will settle on is 640x480.

    About 2 weeks ago, I did almost the same thing - tried to install Catalyst 8.11 by simply running the downloaded .run file from the command line, but it all screwed up and I ended up with the 640x480 mess. That time I was using the "linux_cat811-inst.pdf" instructions from the ATI driver download page, and the fancy GUI installer with the penguin was unusable because the selection buttons were off the bottom of the 640x480 screen!

    I ended up wiping the hard disk and reinstalling Mythbuntu, which got me to the previous "best ever", but still not usable state. I don't want to wipe the HDD and start again, and I'm sure that if I knew enough about how Linux drivers work and where they're stored, I could resurrect the system and even get the Catalyst Control Center working to boot. Last week I was going to give up on ATI and buy a PCIe nVIDIA card, but I suspect I'd be in (nearly) the same boat - trying to install and configure a set of imperfect drivers that won't render 1080i content properly.

    I thereby throw myself upon the mercy of you Linux graphics gurus to pull me out of the mire...

    Oh, and can anyone tell me with any degree of authority - is it possible to get watchable 1080i playback with my hardware?

    SOLUTION - Used Kano's script to reinstall the fglrx driver and ATI Catalyst app (see URL in thread). Inverted color space problem was due to Mythfrontend "Hue" setting defaulted to 0%. See http://ubuntuforums.org/showthread.php?t=825217 for fix. Still can't run the frontend unless in a window and slight video tearing still present, but it's watchable now.
    Last edited by ElGeraldo; 12-08-2008 at 09:21 AM. Reason: Found solutions to problem

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,464

    Default

    AFAIK the fglrx driver included with Ubuntu 8.10 is an early release which supports 8.10 but the version you download from amd.com does not support 8.10.

    I don't know enough about the restricted driver manager to say what the best way to back out of this is -- the installer can handle a fair amount of cleanup work but don't know if it can deal with this situation.

    Personally I would start over with a fresh OS install but that's mostly because I never have time to tinker these days

  3. #3
    Join Date
    Jul 2008
    Posts
    833

    Default

    I would:
    1) Disable the driver in the Prop-Dev Manager
    2) Delete the xorg.conf ... it's recreated if required
    3) Uninstall the problematic driver and reinstall the correct one
    4) Re-enable the driver in the Prop-Dev Manager

    Of course with rebooting between 2-3 and 3-4 just to be sure. Hope this helps

  4. #4
    Join Date
    Dec 2008
    Posts
    6

    Default A reinstall would work, but...

    Quote Originally Posted by bridgman
    AFAIK the fglrx driver included with Ubuntu 8.10 is an early release which supports 8.10 but the version you download from amd.com does not support 8.10.
    I've got Ubuntu (or derivate thereof) 8.04; not 8.10. Are you saying that Catalyst 8.11 will not work with Ubuntu 8.04? I thought it was down to the version of X that you are running, which the ATI site says is compatible for a number of revisions. I was under the impression that I was obliterating the existing fglrx and instead using the one that comes with Catalyst 8.11. Or have I misunderstood? This is all fairly overwhelming to someone that's been using Windoze for 15 years.

    I followed the instructions on the cchtml site that showed how to "blacklist" the existing fglrx driver so that it wouldn't use the one from the repository and instead use the one from the Catalyst install. (Or at least that's what I thought I was doing).

    Personally I would start over with a fresh OS install
    Wiping the partition and starting from scratch would definitely work, and it only takes about an hour to get everything up and running again. But... (and it's a bit BUT), I'd still be left with an unusable Mythfrontend. All the colors on playback are shown as their complimentary colors.

    Somebody must have this (ATI HD3200 + Mythbuntu 8.04 @ 1080i) working properly. I just need to find the magic formula...

  5. #5
    Join Date
    Dec 2008
    Posts
    6

    Default

    Quote Originally Posted by Dragonlord View Post
    I would:
    1) Disable the driver in the Prop-Dev Manager
    2) Delete the xorg.conf ... it's recreated if required
    3) Uninstall the problematic driver and reinstall the correct one
    4) Re-enable the driver in the Prop-Dev Manager
    No's 1,2 and 4 I can do. No3 is where my Linux inexperience lets me down. I don't know how to completely remove an unwanted driver, because I don't know where it lives, nor what makes reference to it. I'm used to clicking on a button that says "uninstall..." and everything happening of its own accord. Could you enlighten me further?

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,464

    Default

    Quote Originally Posted by ElGeraldo View Post
    I've got Ubuntu (or derivate thereof) 8.04; not 8.10. Are you saying that Catalyst 8.11 will not work with Ubuntu 8.04? I thought it was down to the version of X that you are running, which the ATI site says is compatible for a number of revisions. I was under the impression that I was obliterating the existing fglrx and instead using the one that comes with Catalyst 8.11.
    D'oh !! For some reason I read 8.10 not 8.04. Sorry about that...

    Yeah, 8.11 should be fine with Ubuntu 8.04. There were some glitches recently with the Ubuntu package build scripts, which might be hitting you. Kano had a script which was helping a bunch of people; not sure if it is applicable for you.

  7. #7
    Join Date
    Jul 2008
    Posts
    833

    Default

    Quote Originally Posted by ElGeraldo View Post
    No's 1,2 and 4 I can do. No3 is where my Linux inexperience lets me down. I don't know how to completely remove an unwanted driver, because I don't know where it lives, nor what makes reference to it. I'm used to clicking on a button that says "uninstall..." and everything happening of its own accord. Could you enlighten me further?
    Which installer you use?

  8. #8
    Join Date
    Dec 2008
    Posts
    6

    Default Installer?

    Quote Originally Posted by Dragonlord
    Which installer you use?
    I bain't never used no installer on Ubuntu other than the Synaptic package manager. I tried to install the ATI Catalyst 8.11 software from the command line, as per the instructions on the cchtml site (URL above). The magical "uninstall" button I was referring to was my prior experience with Windoze.

    Next time I get spare time of an evening, I'm going to try running Kano's monster install script. I have nothing to lose at this stage.

  9. #9
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    Best do:

    rm /etc/X11/xorg.conf*
    dpkg-reconfigure xserver-xorg

    that creates a basic xorg.conf

    then run my script

    http://kanotix.com/files/install-fglrx-debian.sh

  10. #10
    Join Date
    Dec 2008
    Posts
    6

    Default Fixed - or back to where I was last week, at least

    Quote Originally Posted by Kano View Post
    Best do:

    rm /etc/X11/xorg.conf*
    dpkg-reconfigure xserver-xorg

    that creates a basic xorg.conf
    I deleted the xorg.conf and replaced it with the simple one I had from last week which was working. (I could try reconfiguring X-server but I don't think it will fix the remaining problems)
    I ran your script, and in short it fixed it! Thanks!

    And now the long explanation - I Left it chuntering away for about 20mins and when I came back, the PC had rebooted and was running Mythfrontend - all screwed up, with blocks of pixels wrapped round the ends of the screen, kind of like an elongated checkerboard pattern. Looks like the sync is not happening at the right places.

    I Exited Mythfrontend and the Ubuntu desktop was OK. 1920x1080 desktop is back but the fonts were so small I couldn't read them. I Unchecked the box in the xfce desktop settings that says something like "Use system fonts" and it's all back to normal.

    But... The only way I can get Mythfrontend to be readable is to start it from the command line with -geometry 1920x1019 (or similar). That runs Mythfrontend in a window with the Ubuntu task bar visible at the top. And... The colors are still messed up - pink is cyan, blue is orange, etc.

    I was hoping that the latest fglrx would fix this, but alas not. If I can't figure this out within the next couple of days I think I will have to cut my losses and buy an nVIDIA PCIe card in the hope that their drivers don't have exactly the same problems. I was hoping to ditch my cable company by the end of the year and go over to broadcast TV. The misses won't buy in if Gregory House's face is pale blue.

    *** Found the solution - see bottom of original post ***
    Last edited by ElGeraldo; 12-10-2008 at 09:32 AM. Reason: Found solutions to problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •