Results 1 to 5 of 5

Thread: Non-Interlaced 1080p madness using Geforce 8200 + HDMI audio

  1. #1
    Join Date
    Jul 2006
    Posts
    20

    Default Non-Interlaced 1080p madness using Geforce 8200 + HDMI audio

    Hi,

    (I posted this on nvnews: http://www.nvnews.net/vbulletin/show....php?p=1860104 and am reposting it here for more coverage)

    This problem has manifested itself with all the 17x.xx drivers I have tried, and I finally decided to ask for help with it.

    On Windows, My onboard Geforce 8200 nicely outputs 1080p at both 24 and 50 Hz with audio. IT JUST WORKS LIKE IT'S MEANT TO.

    On Linux, auto configuration only gets me 1080i video modes, no matter what I do. logverbose 6 tells me that the non-interlaced 1080p modelines are added to the mode pool, but neither nvidia-settings nor xrandr can actually activate them.

    Question 1) How do I get the drivers to use 1080p modes instead of 1080i modes without using silly modelines? This should just work.

    Question 2) When I use some custom mode-lines using the output from logverbose 6 to configure non-interlaced 1080p modes (which works), I lose HDMI audio. This is the second problem I need help with.

    HELP!

    Thanks in advance

    p.s. My Xorg.conf (the important bits):

    Code:
    ...
    Section "Monitor"
            Identifier "HDTV"
            Option "DPMS"
            Option "DPI"  "100 x 100"
    
            # Custom mode-lines, if I use them
            #Modeline "1920x1080@24" 74.160 1920 2558 2602 2750 1080 1084 1089 1125 +hsync +vsync
            #Modeline "1920x1080@50" 148.50 1920 2448 2492 2640 1080 1084 1089 1125 +hsync +vsync
            #Modeline "1920x1080@60" 148.35 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
    EndSection
    
    ...
    
    Section "Device"
            Identifier  "nvidia"
            Driver      "nvidia"
            VendorName  "nVidia Corporation"
    
            Option     "HWcursor" "on"
            Option     "NoAccel" "off"
            Option     "CursorShadow" "on"
            Option     "CursorShadowAlpha" "32"
            Option     "CursorShadowXOffset" "4"
            Option     "CursorShadowYOffset" "4"
            Option     "RenderAccel" "on"
            Option     "Coolbits" "1"
            Option     "AllowGLXWithComposite" "on"
            Option     "AddARGBGLXVisuals" "true"
            Option     "RandRRotation" "off"
            Option "ConnectedMonitor" "DFP-0"
    
            # When using custom modelines, this line is uncommented
            # Option "ModeValidation" "NoVesaModes; NoHorizSyncCheck; NoVertRefreshCheck,NoDFPNativeResolutionCheck"
    Just in case it's important, this is what the driver adds to its mode pool AFTER the interlaced modes

    Code:
    (II) NVIDIA(0):   Validating Mode "1920x1080":
    (II) NVIDIA(0):     1920 x 1080 @ 50 Hz
    (II) NVIDIA(0):     For use as DFP backend.
    (II) NVIDIA(0):     Mode Source: EDID
    (II) NVIDIA(0):       Pixel Clock      : 148.50 MHz
    (II) NVIDIA(0):       HRes, HSyncStart : 1920, 2448
    (II) NVIDIA(0):       HSyncEnd, HTotal : 2492, 2640
    (II) NVIDIA(0):       VRes, VSyncStart : 1080, 1084
    (II) NVIDIA(0):       VSyncEnd, VTotal : 1089, 1125
    (II) NVIDIA(0):       H/V Polarity     : +/+
    (II) NVIDIA(0):     Mode is valid.
    (II) NVIDIA(0):
    (II) NVIDIA(0):   Validating Mode "1920x1080":
    (II) NVIDIA(0):     1920 x 1080 @ 60 Hz
    (II) NVIDIA(0):     For use as DFP backend.
    (II) NVIDIA(0):     Mode Source: EDID
    (II) NVIDIA(0):       Pixel Clock      : 148.35 MHz
    (II) NVIDIA(0):       HRes, HSyncStart : 1920, 2008
    (II) NVIDIA(0):       HSyncEnd, HTotal : 2052, 2200
    (II) NVIDIA(0):       VRes, VSyncStart : 1080, 1084
    (II) NVIDIA(0):       VSyncEnd, VTotal : 1089, 1125
    (II) NVIDIA(0):       H/V Polarity     : +/+
    (II) NVIDIA(0):     Mode is valid.
    (II) NVIDIA(0):
    (II) NVIDIA(0):   Validating Mode "1920x1080":
    (II) NVIDIA(0):     1920 x 1080 @ 24 Hz
    (II) NVIDIA(0):     For use as DFP backend.
    (II) NVIDIA(0):     Mode Source: EDID
    (II) NVIDIA(0):       Pixel Clock      : 74.16 MHz
    (II) NVIDIA(0):       HRes, HSyncStart : 1920, 2558
    (II) NVIDIA(0):       HSyncEnd, HTotal : 2602, 2750
    (II) NVIDIA(0):       VRes, VSyncStart : 1080, 1084
    (II) NVIDIA(0):       VSyncEnd, VTotal : 1089, 1125
    (II) NVIDIA(0):       H/V Polarity     : +/+
    (II) NVIDIA(0):     Mode is valid.

  2. #2
    Join Date
    Jan 2009
    Posts
    1

    Default

    I had the same problem as you had, and I solved it with nvidia-settings. The settings were already on the correct resolution and on Auto refresh rate, so I thought the utility wouldn't help but it turned out that clicking on Apply and storing it in the X server config solved the problem.

  3. #3
    Join Date
    Jul 2006
    Posts
    20

    Default

    Quote Originally Posted by EZ9WQT View Post
    I had the same problem as you had, and I solved it with nvidia-settings. The settings were already on the correct resolution and on Auto refresh rate, so I thought the utility wouldn't help but it turned out that clicking on Apply and storing it in the X server config solved the problem.
    OOH - I've gotta try that straight away. Thanks for that, I'd given up hope!

  4. #4

    Default

    I also would be needing information on this. Would really appreciate your help. Thanks.

  5. #5
    Join Date
    Jul 2006
    Posts
    20

    Default

    Quote Originally Posted by EZ9WQT View Post
    I had the same problem as you had, and I solved it with nvidia-settings. The settings were already on the correct resolution and on Auto refresh rate, so I thought the utility wouldn't help but it turned out that clicking on Apply and storing it in the X server config solved the problem.
    Unfortunately, it did not work for me. Did you get it to work with HDMI audio?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •