Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: NVIDIA To Enhance Its X Render Support?

  1. #1
    Join Date
    Jan 2007
    Posts
    15,611

    Default NVIDIA To Enhance Its X Render Support?

    Phoronix: NVIDIA To Enhance Its X Render Support?

    While improved X Render support hasn't been specifically brought up by any users in our thread for What Do You Want From Linux GPU Drivers In 2010?, it looks like NVIDIA may be working on improving their X Render support in its binary graphics drivers. NVIDIA's X Render extension support is already quite good and fast after being revitalized in some driver updates last year, but recent work is signaling that they may be further polishing this support to help users with 2D acceleration. This afternoon two patches hit the xorg-devel list that were written by Robert Morell and reviewed by Aaron Plattner...

    http://www.phoronix.com/vr.php?view=NzkwMg

  2. #2
    Join Date
    Mar 2009
    Posts
    86

    Default

    No major X Render improvements have been spotted yet in the NVIDIA 195.xx beta drivers so perhaps this is all work building up for a major 200.xx series release.
    What about the render improvements mentioned in the 195.30 release notes?
    Quote Originally Posted by 195.30 release notes
    • Enabled GPU acceleration for many RENDER compositing operations that were previously processed in software, including conjoint and disjoint blending modes and component alpha blending.

  3. #3
    Join Date
    Jan 2009
    Posts
    141

    Default



    although, i get crappy 2d acceleration on my 9600. wobbly windows are terribly slow in gnome.

    but when i go into compiz settings and enable the desktop benchmark it shoots up to a constant silky smooth 60fps.
    i can't figure it out, does anyone know why it's like this?

    i've even tried disabling power management to no avail. i should probably ask somewhere else though...

  4. #4
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,153

    Default

    Try disabling vsync from nvidia-settings. If that doesn't help, disable vsync from compiz settings (if enabled).

  5. #5
    Join Date
    Aug 2007
    Posts
    437

    Default

    No you shouldn't disable v-sync

    Instead, you should try to disable "detect refresh rate" and manually set refresh rate to 120 in compiz settings. This way you get best of both worlds: tear-free and fast 3d compiz desktop.

    I've been using this hack for more than a year and it's been a very good experience.

  6. #6
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,153

    Default

    Forcing vsync on both nvidia-settings and compiz settings (note, forcing not merely enabling) is known to cause such issues.

    In any case, the 120Hz hack is evil and speaks more of a deficiency in compiz than anything else.

  7. #7
    Join Date
    Jan 2009
    Posts
    141

    Default

    i tried every combination of vsync options to no avail. the framerate appears to be at 15 to 20 fps. but when i turn on compiz benchmark it shoots up to 327 fps.

    edit: i tried the 120 hack, still only get around 15 fps. but when i turn on benchmark it shoots to 283 fps.
    Last edited by portets43; 01-21-2010 at 09:49 PM.

  8. #8
    Join Date
    Aug 2007
    Posts
    437

    Default

    Quote Originally Posted by BlackStar View Post
    Forcing vsync on both nvidia-settings and compiz settings (note, forcing not merely enabling) is known to cause such issues.

    In any case, the 120Hz hack is evil and speaks more of a deficiency in compiz than anything else.
    I am aware of what the 'hack' does to the compiz code. Compiz IMO is poorly written in regards to v-sync handling. The v-sync wait often jumps over an available Hz and went to wait for next. So enabling v-sync and allow it to auto detect refresh rate will often cap the screen update rate to half the actual refresh rate, say 30Hz, which is very jumpy. To workaround the v-sync wait deficiency, we try to let compiz pull v-sync signal twice as fast, this solves the under-syncing bug and gives you smooth update rate. There is nothing evil about it, compiz should in default pull twice as fast so we don't even need to manually specify the rate.

    For portets43: Have you tried to disable v-sync in nvidia driver, enable v-sync in compiz, DISABLE screen refresh rate detection and manually set to 120Hz? This combination works for me for a variety of nvidia cards: 8800GTS, 8800GTX, 9800GT, GTX-260+, even 7600GT and FX5700 gives smooth compiz desktop

  9. #9
    Join Date
    Jan 2009
    Posts
    141

    Default

    Quote Originally Posted by FunkyRider View Post
    For portets43: Have you tried to disable v-sync in nvidia driver, enable v-sync in compiz, DISABLE screen refresh rate detection and manually set to 120Hz? This combination works for me for a variety of nvidia cards: 8800GTS, 8800GTX, 9800GT, GTX-260+, even 7600GT and FX5700 gives smooth compiz desktop
    yes, just tried EXACTLY what you said. still choppy.

    i'm just disabling compiz until a later date.

  10. #10
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    199

    Default

    Don't try to run that test with ATI... you'll hurt your eyes :x

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •