Page 1 of 10 123 ... LastLast
Results 1 to 10 of 121

Thread: random X freeze with latest ati driver

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Posts
    29

    Default random X freeze with latest ati driver

    system: ubuntu 8.10
    ati driver (opensource): compiled from git (latest version)
    device: ati radeon mobility 9700

    xorg.conf

    Driver "ati"
    Option "RenderAccel" "true"
    Option "AccelMethod" "EXA"
    Option "DynamicClocks" "true"
    Option "EnablePageFlip" "true"
    Option "DMAForXv" "true"
    Option "AGPMode" "4"
    Option "ColorTiling" "true"
    Option "AccelDFS" "true"
    Option "EXAVSync" "true"

    when i see a video or i'm using firefox or in other situation, with and without compiz, X freeze, cpu run at 100% and i must force shutdown from power button. how can i fix this problem?

  2. #2
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    does removing the EXAVSync option help?

  3. #3
    Join Date
    Mar 2008
    Posts
    29

    Default

    no, same error....i added recently EXAVSync in my xorg.conf

  4. #4
    Join Date
    Dec 2006
    Posts
    112

    Default

    I've got the same problem. I am using the radeon driver (from the ubuntu repositories) since fglrx broke compatibility with my Mobility Radeon 9700 three months ago. But I had "MigrationHeuristics" set to "Greedy" all the time. After reading a bit in your blog, I updated to the latest snapshot (from launchpad.net/~tormodvolden), commented out the "MigrationHeuristics" setting and added EXAVSync to my xorg.conf.

    Soon,I experienced the first lockups. Mostly when scrolling in Firefox, but also in other situations. When it happens, I cannot switch to the console, ssh into my system from another computer or even use the Magic-SysRq-Keys.

    First, I disabled the EXAVSync settings, than I reverted back to radeon from ubuntu. Didn't help. Only re-inserting the "MigrationHeuristics" setting did. As I understand it, that effectivly disables any acceleration.

  5. #5
    Join Date
    Apr 2007
    Posts
    18

    Default

    Quote Originally Posted by agd5f View Post
    does removing the EXAVSync option help?
    With me it does help. My problem is, that after a while, on a random moment, everything freezes except for the mouse. Mouse is allowed to move slowly and jerky, while keyboard and the rest of gnome is completely frozen.
    No information in logs, however, so not sure how to file a bug report.
    I have an RV515 (Gigabyte X1300PRO).

  6. #6
    Join Date
    Dec 2006
    Posts
    112

    Default

    Quote Originally Posted by aljaz View Post
    With me it does help. My problem is, that after a while, on a random moment, everything freezes except for the mouse. Mouse is allowed to move slowly and jerky, while keyboard and the rest of gnome is completely frozen.
    I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.

  7. #7
    Join Date
    Apr 2007
    Posts
    18

    Default

    Quote Originally Posted by Stormking View Post
    I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.
    Hmmm. This happened on three different machines (one desktop and two HP laptops) so I don't think it's a cooling problem.

  8. #8
    Join Date
    Oct 2007
    Location
    Under the bridge
    Posts
    2,153

    Default

    I can confirm the exact same issue with a 9600Pro (Ubuntu 8.10 x86, vanilla "ati" driver and xorg settings.)

    I will test with fglrx and see if the issue persists.

  9. #9
    Join Date
    Aug 2007
    Location
    Poland
    Posts
    215

    Default

    Quote Originally Posted by Stormking View Post
    I had this problem some time ago, with the OSS driver *and* fglrx. The solution was to provide better cooling to the GPU.
    The same with my Radeon 9600 and my friends Radeon 9250 - after opening the computer I noticed the graphic card is very hot (no fan on card). With computer cover open I've noticed a lot better stability on the open source drivers. Both systems use Kubuntu 8.10 and the default xorg.conf.

  10. #10
    Join Date
    Mar 2008
    Posts
    29

    Default

    EDIT:
    with option migrationheuristic (greedy), freeze appears with gnome mplayer, with vlc no problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •