Page 11 of 13 FirstFirst ... 910111213 LastLast
Results 101 to 110 of 121

Thread: random X freeze with latest ati driver

  1. #101
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    Note that the Windows driver runs a series of diagnostics at startup and automatically downclocks the AGP bus and turns off other options like FastWrite as needed to obtain reliable operation. The marketing folks called it SmartGart : http://ati.amd.com/products/catalyst/SmartGart-FAQ.pdf

    If your system runs reliably with Windows that means it should be possible to run it reliably with Linux as well, but the Windows driver stack automatically steps down AGP settings as needed and you'll need to do that manually with Linux drivers. When you see one Linux driver run reliably and another not, that usually means the *defaults* for AGP settings are different between those drivers.
    Last edited by bridgman; 07-09-2009 at 09:43 AM.

  2. #102
    Join Date
    May 2008
    Posts
    343

    Default

    Quote Originally Posted by bridgman View Post
    Note that the Windows driver runs a series of diagnostics at startup and automatically downclocks the AGP bus and turns off other options like FastWrite as needed to obtain reliable operation.
    Thanks for the info. I always wondered how the Windows drivers got this right. I have even seen bug reports where some Windows utility tells the user it is using 4x but Linux would need 2x to be stable, so I guess the utility just didn't tell the actual, corrected rate but what was default or "wanted" rate.

    Exershio, please make sure you file a bug report if AGPMode fixes your issue, so that we can make a driver quirk for this hardware combination.

  3. #103
    Join Date
    Dec 2007
    Posts
    2,327

    Default

    Quote Originally Posted by tormod View Post
    Thanks for the info. I always wondered how the Windows drivers got this right. I have even seen bug reports where some Windows utility tells the user it is using 4x but Linux would need 2x to be stable, so I guess the utility just didn't tell the actual, corrected rate but what was default or "wanted" rate.
    I'm not sure what the windows utility shows, however there's more to it than just the agp mode. You can test AGP reads and writes separately and just use one or the other depending on which is stable. Also you can use combinations of AGP gart and the integrated gart for different things depending on what parts of AGP are stable. In addition, I'm sure there are tons of chipset specific AGP quirks.

  4. #104
    Join Date
    Sep 2006
    Posts
    209

    Default another for the list of affected people

    I too experience random hard lockups with -video-ati git sources since around April 2009. Reducing AGP rate didn't help. Interestingly
    it seems to only occur with GTK apps; quickly switching between tabs with lots of pictures in firefox or selecting various messages in rapid succession in claws-mail is sufficient to kill the system fairly quickly. I've never had a hang so far with only using KDE/Qt apps.

    System is a mobility9700/64MB and a intel 855PM chipset, and up-to-date
    git versions of more or less all X components.

  5. #105
    Join Date
    Jul 2009
    Posts
    7

    Default

    Quote Originally Posted by Exershio View Post
    Whenever I run a 3d intensive application, it'll render properly for a few seconds, then my screen goes black, my monitor loses signal, and my computer completely freezes. It takes no input from keyboard/mouse, audio starts stuttering and sounds like a buzzsaw, and I'm forced to shutdown with the power button.

    Whenever I'm playing a game that uses harware acceleration but is not very intensive (such as StepMania), the game runs fine for 3-5 minutes and then the same problem I stated previously occurs. Screen goes black, unresponsive, etc.

    Whenever I'm just running a simple KDE desktop without any desktop effects, I experience no problems. It's only when I'm running an OpenGL application does the problem happen.
    Same problem occurs here with new 9.6 catalyst driver.
    uname -a
    Linux 2.6.29-sabayon #1 SMP Thu Jun 11 13:33:04 UTC 2009 x86_64 AMD Phenom(tm) II X4 955 Processor AuthenticAMD GNU/Linux
    lspci on http://www.sabayonlinux.org/pastie/1249
    xorg.log on http://www.sabayonlinux.org/pastie/1247
    xorg.conf on http://www.sabayonlinux.org/pastie/1248

    Hope this is of use to the developers.
    I will be happy to give more information or test things.

  6. #106
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    Can you please move this to the proprietary driver section ?

    Please note that the 9.6 driver does not support 2.6.29 or higher kernels. There are some unofficial patches available; have you already applied those ?

  7. #107
    Join Date
    May 2009
    Posts
    9

    Default

    Well, I just got done installing Neverwinter Nights, and running the game on completely high settings (while it drags my frame rate down to 10 hehe) does NOT crash my computer at all anymore! This is with my AGPMode set to 1x.

    I don't see why it doesn't work with 4x. While my motherboard only supports up to AGP 4x, the Catalyst Control Center in Windows XP says my card is running at 4x, and there's no crashing there. Unless it just SAYS it's running at 4x and it's really running at 1x/2x?

    I'm not sure, but I'm really happy that I can finally run OpenGL applications without any problems Thank you to everyone that helped.

    As for filing a bug report on this issue, where should I do that?

    edit: I can now confirm that I do not experience the crash with AGP 2x as well. It seems to only crash when I have AGP at 4x.
    Last edited by Exershio; 07-09-2009 at 07:45 PM.

  8. #108
    Join Date
    Dec 2007
    Posts
    2,327

    Default

    Quote Originally Posted by Exershio View Post
    Well, I just got done installing Neverwinter Nights, and running the game on completely high settings (while it drags my frame rate down to 10 hehe) does NOT crash my computer at all anymore! This is with my AGPMode set to 1x.

    I don't see why it doesn't work with 4x. While my motherboard only supports up to AGP 4x, the Catalyst Control Center in Windows XP says my card is running at 4x, and there's no crashing there. Unless it just SAYS it's running at 4x and it's really running at 1x/2x?
    It's hard to say what the exact problem. The AGP chipset driver in windows may have some special workaround that the linux AGP chipset driver doesn't have, etc. In reality, AGP modes don't really have that much effect on performance. I doubt you could tell much difference for most things.

    Quote Originally Posted by Exershio View Post
    I'm not sure, but I'm really happy that I can finally run OpenGL applications without any problems Thank you to everyone that helped.

    As for filing a bug report on this issue, where should I do that?
    https://bugs.freedesktop.org

  9. #109
    Join Date
    Jul 2009
    Posts
    7

    Default

    Quote Originally Posted by bridgman View Post
    Can you please move this to the proprietary driver section ?

    Please note that the 9.6 driver does not support 2.6.29 or higher kernels. There are some unofficial patches available; have you already applied those ?
    I am aware of that, only the symptoms are so similar.
    That is the main reason i posted it here.

    As far as i know the patches are included in the distro by its developers.

  10. #110
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    Sure, but it's a *completely* different driver with absolutely no code in common, and screen black/unresponsive is a very generic problem. The chances of the two issues having a common root cause are (holds fingers together) pretty small. I wasn't aware that Sabayon was including patched fglrx drivers in its packages but I guess that's possible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •