Page 12 of 13 FirstFirst ... 210111213 LastLast
Results 111 to 120 of 121

Thread: random X freeze with latest ati driver

  1. #111
    Join Date
    Jul 2009
    Posts
    7

    Default

    Quote Originally Posted by agd5f View Post
    ...The AGP chipset driver in windows may have some special workaround that the linux AGP chipset driver doesn't have, etc. In reality, AGP modes don't really have that much effect on performance.
    https://bugs.freedesktop.org
    Yes of course, nevertheless it does have some influence.
    Referring to http://en.opensuse.org/ATI/Troublesh...#ATI_AGP_Cards
    Here it is stated "If fglrx is still not working, set the AGP aperture Size in the BIOS to the size of the physical card memory."
    I know this is not the AGP mode but the aperture size.
    Also i recall from the very early days of the nvidia linuxdriver ('t was in the riva tnt time) that AGP modes had considerable effect on driverperformance.

    @ Bridgman, i will get back to you later in the proprietary drivers section on hickups witg catalyst 9.6 in sabayonlinux.

    Kind regards.

  2. #112
    Join Date
    Jul 2007
    Location
    Stockholm, Sweden
    Posts
    49

    Default

    I just stumbled upon this bug _in a repeatable way_, after updating my old computer, switching from gnome to xfce4 and updating a lot of X-related packages.

    Now running (gentoo packages):
    x11-base/xorg-server-1.5.3-r6
    x11-base/xorg-x11-7.2
    x11-drivers/xf86-video-ati-6.12.1-r1
    x11-libs/gtk+-2.14.7-r2
    xfce-base/xfce4-4.6.1

    Default xorg.conf, no changes except setting Option "AccelMethod" "EXA".

    Graphics card is R420 JI [Radeon X800PRO].
    PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)

    I created a new account on the computer, and while setting up Thunderbird for the new user I "noticed" it always hung on the second page of the account wizard - where you enter your name and email address. (Same symptoms as before: dead keyboard, frozen screen except the mouse cursor moves around jerkily (a few Hz update frequency of the position), SysRq working, nothing in the logs... - the only dfference was this time it was repeatable.)

    So I tried different combinations of settings in xorg.conf to get rid of it, and -lo and behold- Option "AGPMode" "4" did the trick (I thought this was the default?). At least I do no longer get the hang repeatably; perhaps it will still hang sometimes. But this setting absolutely had some effect on this bug for me.

    I also tried "AGPFastWrite" "off", "GARTSize" "32", "MigrationHeuristics" "greedy", "AccelDFS" "false", "DynamicClocks" "on"/"off" with no effect (didn't test all combinations though).

    Unfortunately, I'm quite sure I tried setting the AGPMode option the last time I had the error, without effect. But perhaps it will give someone a clue.

  3. #113
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    Quote Originally Posted by bitnick View Post
    Now running (gentoo packages):
    x11-base/xorg-server-1.5.3-r6
    x11-base/xorg-x11-7.2
    x11-drivers/xf86-video-ati-6.12.1-r1
    x11-libs/gtk+-2.14.7-r2
    xfce-base/xfce4-4.6.1

    So I tried different combinations of settings in xorg.conf to get rid of it, and -lo and behold- Option "AGPMode" "4" did the trick (I thought this was the default?). At least I do no longer get the hang repeatably; perhaps it will still hang sometimes. But this setting absolutely had some effect on this bug for me.
    AGP is made of fail. The default in older versions of the xf86-video-ati driver was the lowest supported agp mode (1x or 4x), with newer versions we leave it at whatever mode the bios set up as that was more reliable overall. However, there are always a few combinations that work better with particular modes. Please file a bug (https://bugs.freedesktop.org) and attach your xorg log and I'll add a quirk to the driver for your card/agp bridge combination so it will work out of the box. Also, I would suggest trying xf86-video-ati from git master or the stable 6.12-branch as there have been a number of EXA related fixes since 6.12.1.

  4. #114
    Join Date
    Jul 2007
    Location
    Stockholm, Sweden
    Posts
    49

    Default

    Bug 22726 submitted.

  5. #115
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    Quote Originally Posted by bitnick View Post
    Bug 22726 submitted.
    Could you please attach your xorg log and the output of lspci -vn?

  6. #116
    Join Date
    Mar 2009
    Posts
    10

    Default

    Looks like my bug https://bugs.freedesktop.org/show_bug.cgi?id=20348 is very similar to the original poster's.

    In my case, Firefox or OpenOffice typically triggers it. Screen freezes up with the mouse moving jerkily a couple times a second with X using 100% cpu.

    Only that that "works" for me is to disable DRI. I was thinking of trying different AGP/PCI settings since then I might be able to retain some acceleration, but if the GPU is onboard, it should be PCI by default, right? The Xorg.log doesn't seem to indicate either way.

  7. #117
    Join Date
    May 2009
    Posts
    9

    Default

    Hmm, I think I figured this all out. In Windows XP, the ATI CCC always told me my card was running at AGP 4x, yet the memory freq was always 195mhz. Under Linux @ AGP 1x, my mem freq is 195mhz...

    When I changed it to 2x in Linux, all of a sudden my mem freq was 390mhz. I think the CCC in Windows was lying to me and was really running my card at 1x the entire time despite the fact it "said" it was running at 4x. So when I ran my card at 4x under Linux, it crashes. 1x and 2x do not crash however.

    Just figured I'd let you know about that if it's any help.

  8. #118
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    Quote Originally Posted by Exershio View Post
    Hmm, I think I figured this all out. In Windows XP, the ATI CCC always told me my card was running at AGP 4x, yet the memory freq was always 195mhz. Under Linux @ AGP 1x, my mem freq is 195mhz...

    When I changed it to 2x in Linux, all of a sudden my mem freq was 390mhz. I think the CCC in Windows was lying to me and was really running my card at 1x the entire time despite the fact it "said" it was running at 4x. So when I ran my card at 4x under Linux, it crashes. 1x and 2x do not crash however.

    Just figured I'd let you know about that if it's any help.
    what do you mean by memory frequency? AGP mode doesn't affect the mem clocks on the card.

  9. #119
    Join Date
    May 2009
    Posts
    9

    Default

    Quote Originally Posted by agd5f View Post
    what do you mean by memory frequency? AGP mode doesn't affect the mem clocks on the card.
    Are you sure about that? when I had AGP 1x set, my mem clock was 195mhz. When I bumped it up to 2x, it all of a sudden was reported as 390mhz (according to rovclock)

  10. #120
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    Quote Originally Posted by Exershio View Post
    Are you sure about that? when I had AGP 1x set, my mem clock was 195mhz. When I bumped it up to 2x, it all of a sudden was reported as 390mhz (according to rovclock)
    Yes, I'm sure. I wouldn't trust rovclock too much. Last time I looked at it it was pretty buggy. The actual default clocks are printed in your xorg log, e.g.,

    (II) RADEON(0): ref_freq: 2700, min_out_pll: 64800, max_out_pll: 120000, min_in_pll: 600, max_in_pll: 1600, xclk: 40000, sclk: 600.000000, mclk: 500.000000

    sclk is the engine clock and mclk is the memory clock.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •