Page 4 of 13 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 121

Thread: random X freeze with latest ati driver

  1. #31
    Join Date
    Dec 2007
    Posts
    2,321

    Default

    this patch should re-enable it:
    http://www.botchco.com/alex/xorg/wri...efresh_cp.diff

    Does that fix it for you on git master?

  2. #32
    Join Date
    Jan 2009
    Posts
    86

    Default

    Quote Originally Posted by agd5f View Post
    this patch should re-enable it:
    http://www.botchco.com/alex/xorg/wri...efresh_cp.diff

    Does that fix it for you on git master?
    No, Error still crops up with that one..

  3. #33
    Join Date
    Jan 2009
    Posts
    86

    Default

    Gah. Double post.
    Last edited by DuSTman; 02-19-2009 at 08:24 PM.

  4. #34
    Join Date
    Dec 2007
    Posts
    2,321

  5. #35
    Join Date
    Jan 2009
    Posts
    86

    Default

    No, that doesn't work either..

  6. #36
    Join Date
    Jan 2009
    Posts
    86

    Default

    As requested (on IRC) I did a further git bisect, this time with the first patch applied, which isolated this commit as introducing the issue.

  7. #37
    Join Date
    Feb 2009
    Location
    Portugal
    Posts
    5

    Default X freezes when using EXA

    My X also freezes randomly, Ctrl+Alt+Del, AltGr+Sys+Req not doing nothing. Sometimes the mouse still moves (but slowly) and the rest off the desktop is frozen, sometimes all the desktop gets frozen.All of this happens every time and not long after login.

    I'm using kde 4.2 with desktop effects enabled.
    The problem occurs with radeon and radeonhd when using EXA , I installed both from git today. When using XAA the desktop doesn't freeze.

    ATI Mobility Radeon x1600
    X.Org X Server 1.5.2
    openSUSE 11.1

  8. #38
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    How new is your drm code ? Are you running drm from the openSuSE kernel or did you build and install drm from git as well ?

  9. #39
    Join Date
    Nov 2006
    Posts
    72

    Default

    Quote Originally Posted by mitrol View Post
    My X also freezes randomly, Ctrl+Alt+Del, AltGr+Sys+Req not doing nothing. Sometimes the mouse still moves (but slowly) and the rest off the desktop is frozen, sometimes all the desktop gets frozen.All of this happens every time and not long after login.

    I'm using kde 4.2 with desktop effects enabled.
    The problem occurs with radeon and radeonhd when using EXA , I installed both from git today. When using XAA the desktop doesn't freeze.

    ATI Mobility Radeon x1600
    X.Org X Server 1.5.2
    openSUSE 11.1
    Seems the same lockup I've been having since R500 3D support was merged, back in May. Here's my bug report: http://bugs.freedesktop.org/show_bug.cgi?id=16198

  10. #40
    Join Date
    Feb 2009
    Location
    Portugal
    Posts
    5

    Default

    Today I build and installed drm from git and I had the same lockup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •