Page 5 of 13 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 121

Thread: random X freeze with latest ati driver

  1. #41
    Join Date
    Nov 2008
    Posts
    89

    Default

    I was getting random lockups on Debian with an X800GT using the xserver-xorg-ati-video_6.9.0 driver, back dating the driver to 6.6.3-2 from debian 4.0 completely cured the problem.
    Have not tried the latest version "If its not broken, don't fix it"

  2. #42
    Join Date
    Jan 2009
    Posts
    86

    Default

    I've tried reversing the change to the RADEON_SWITCH_TO_2D and RADEON_SWITCH_TO_3D calls in 6.11.0 and added the scissor register reset code back in. This time Xserver bricked about 1 second after starting. Way to go, me!

  3. #43
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    You might try an updated mesa. Looks like we weren't setting the number of pipes properly in mesa for r3xx-r4xx cards. I've fixed this in mesa master and the 7.4 branch.

  4. #44
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    does this patch help?

    http://www.botchco.com/alex/xorg/no_...gine_idle.diff

    It's against the r6xx-r7xx-support branch of the drm, but you should be able to apply it to other drms easily (just two lines to add).

  5. #45
    Join Date
    Jan 2009
    Posts
    86

    Default

    Sorry, no. Neither an updated mesa nor the libdrm improvement seemed to help.

  6. #46
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    Quote Originally Posted by DuSTman View Post
    Sorry, no. Neither an updated mesa nor the libdrm improvement seemed to help.
    Just to clarify, this isn't a change to libdrm, it's a change to the radeon drm kernel module. Make sure you build and install the kernel modules (cd linux-core; make drm.o radeon.ko; cp drm.ko radeon.ko /path/to/your/kernel/modules) rather than libdrm.

  7. #47
    Join Date
    Jan 2009
    Posts
    86

    Default

    Sorry about that - unfortunately the updated kernel modules don't seem to help either.

  8. #48
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    Several people have reported improved behavior using the drm-next branch of Dave's drm-2.6 tree.

    http://git.kernel.org/?p=linux/kerne....git;a=summary

  9. #49
    Join Date
    Jan 2009
    Posts
    86

    Default

    Again, no joy.

  10. #50
    Join Date
    Apr 2009
    Posts
    2

    Default

    Hi there
    I recently encountered this problem with Ubuntu jaunty beta release.

    System repeatingly freezes with Kwin Desktop Effects on after 10-30 Minutes mostly when opening new windows/sub-windows (ie "browse file").
    With Desktop effects off everything works absolutely fine, can run glexgears, vlc 720p movie and Goofge earth at the same time for hours...... .

    Besides that I have massive tearing issues with Kwin + Desktop Effects and google earth - any ideas?

    Bug is files under Ubuntu #351990 and 350766

    greetz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •