Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Intel GMA X3000

  1. #11

    Default

    I had sent off a message to some Intel contacts, and am hoping for their reply in time for this article -- to comment both on the features implemented/not-yet-implemented and any performance tuning.

    I have read the GMA 3000 white-paper when it was initially released as well as extensively investigating other areas of its architecture as well.

    I'll likely comment on Compiz and AIGLX in the article as well.

    I'm hoping to compare the GMA 3000 performance to the R300 open-source drivers with an ATI Radeon X300 and X800, and more if time permits.

  2. #12

    Default

    Here is just what Keith Packard had to say:

    As noted in the driver release announcement, this is just our first
    release of the code and there remain significant possible performance
    improvements that can be made. Some of them are low-level chip
    optimziations, while others are ongoing efforts to improve the Mesa
    project as well. Right now, there aren't any performance tuning
    parameters available for the driver.

  3. #13
    Join Date
    Jun 2006
    Location
    One day I'll reach Alaska, or die trying!
    Posts
    287

    Default

    Interesting. I'm really looking forward to a big performance boost compared to the GMA950, which couldn't even play UT2k4 with all the bells and whistles properly.

  4. #14

    Default

    I'm sorry, but it's either the benchmarks on the Intel chipset hasn't been posted or I just missed it... I'm not sure where it is, Michael.

    By the way, I also skimmed a bit on the whitepapers of the 965G/GMA x3000.

  5. #15

    Default

    Not posted yet, there was some problems with the motherboard (Q965) and both Fedora Rawhide and Ubuntu Edgy Eft Beta 1. The benchmarks will be out soon.

  6. #16
    Join Date
    Sep 2006
    Posts
    714

    Default

    I posted this in the motherboard forum also, but with the G965-based motherboard and Windows XP it performed very badly in 3d performance.

    http://www.reghardware.co.uk/2006/10...ro_pdsba_g965/

  7. #17
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by drag View Post
    I posted this in the motherboard forum also, but with the G965-based motherboard and Windows XP it performed very badly in 3d performance.

    http://www.reghardware.co.uk/2006/10...ro_pdsba_g965/
    I'd take ANY Windows site review with a grain of salt (A lot of them,
    actually- but not for the reasons you'd normally think...) because Intel
    has said that they've not got the full support in the drivers that are
    shipping for the motherboard and that a later driver would have full
    support of everything. No use of the T&L. No use of the independant
    rendering pipelines. It's being used as a GMA 950 with those drivers.

    Of course it's going to perform very badly. The GMA 950 performed
    VERY badly.

    What I want to know is if with everything turned on, is it lackluster
    or does it stink on ice. Nobody can tell anyone that just yet.

  8. #18

    Default

    We hope to have our initial results out next week after the official release of Fedora Core 6. Communicating with Intel's Linux driver team, there aren't any performance tuning options available at this time and there is still much work ahead.

  9. #19
    Join Date
    Sep 2006
    Posts
    714

    Default

    Found this:
    http://deadmoo.com/articles/2006/09/...eo-benchmarked

    The X3000 on a similar setup to the person's blog that is posted above posted compared favorably to a Nvidia 7300GS with UT2004 and beat ATI's propriatory drivers with the X550.

    So at least it seems now that Intel has gotten to low-end discrete video cards.

  10. #20
    Join Date
    Jun 2006
    Location
    Austria
    Posts
    115

    Default

    Quote Originally Posted by Michael View Post
    colo, how is the board running?
    My Intel DG965WH (I got two of them, actually) don't run at all, because of incompatibilities between the Board's BIOS and a certain charge of MDT/MCI DDR2-SDRAM. Neither Intel, nor MDT are willing to shell out information about when or if the BIOS-fix for the widely known issue will be implemented, whilst other manufacturers provided updates to the BIOS of their boards weeks ago already.

    I'm really, really pissed by now.

    If anyone of you posting here is in the position to get to this information, I'd be glad to have it - or rather more if one could provide me with a beta-BIOS of some sort to make my damn boxes running at last (all the hardware is lying around here for 4 weeks or so now, that really is frustrating - but I can't afford new components as of now), but that'd be too cool to come true, I guess.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •