Results 1 to 5 of 5

Thread: Forcing HDMI to be on?

Hybrid View

  1. #1
    Join Date
    Dec 2008
    Posts
    2

    Unhappy Forcing HDMI to be on?

    Hi all,
    I am running Ubuntu 8.10 with ATI fglrx version 8.54.3 on an ASUS motherboard with onboard ATI Radeon HD3200.

    My problem is that, depending on which TV I connect to with HDMI, either the motherboard or Ubuntu does not always "turn on" the HDMI connection. One one TV, I need to have the TV tuned to HDMI before turning the system on, else when I change to HDMI input the TV finds no signal. On the other TV, no matter what order in which I turn on the TV, the TV does not recognize that HDMI has output coming through it (however, other HDMI-based components output perfectly fine to this TV)

    Does anyone know:
    1.) Is this a problem with the motherboard or the operating system?
    2.) Based on the answer to #1, how can I solve it? Is there a way to "force" HDMI to be on at all times (since I know I will only connect with it)?

    Thanks in advance.

  2. #2
    Join Date
    Dec 2008
    Posts
    11

    Default

    Hello, my first post here. Try the following:

    0. Create a backup of your /etc/X11/xorg.conf

    1. When you have successfully booted, issue the following command.

    Code:
    aticonfig --query-connectortype=tmds2i
    It should say if the connection is present. If tmds2i does not work try tmds1 or tmds2 instead. You may have to try the command as super user (or sudo)

    2. When you know your connectortype issue the following command (as superuser), replace tmds2i if your result was different in step one:

    Code:
    aticonfig --force-monitor=tmds2i
    If you have trouble try removing (do a backup first!) the amdccle database. I run Ubuntu as well and it's located in /etc/ati/amdpcsdb for me. It will then load the default settings from the default database and add additional settings from xorg.conf.

    I get a different problem when I have done the above, I only get maximum 1024x768 as my resolution. But that may have to do with my HDMI-cord length. Will start a separate thread about it.

    Good luck!

  3. #3
    Join Date
    Dec 2008
    Posts
    2

    Default

    Yes, this worked on one TV I tested.
    However, I seem to suffer from the same problem that you are now; specifically, my screen's resolution has been reduced from 1280x720 to 720x480 with no option in ATI's CCC to increase it beyond this.
    Any other thoughts?

  4. #4
    Join Date
    Dec 2008
    Posts
    11

    Default

    Quote Originally Posted by jsdf View Post
    Yes, this worked on one TV I tested.
    However, I seem to suffer from the same problem that you are now; specifically, my screen's resolution has been reduced from 1280x720 to 720x480 with no option in ATI's CCC to increase it beyond this.
    Any other thoughts?
    I have started another thread about this problem in this forum. I just got back from a skiing weekend so I haven't tried the suggested solution yet. But you can view the thread here: http://phoronix.com/forums/showthread.php?p=56512

    Good luck and please post a reply to that other thread if you find a solution! I will post back as well if I find a solution.

  5. #5
    Join Date
    Dec 2008
    Posts
    11

    Default

    Ok, so I got a workaround for my problem. I think this will help you as well.

    Step 0. Backup everything.

    Step 1. Generate a custom modeline using gtf from the command prompt. The syntax is gtf WIDTH HEIGHT REFRESH. Eg. "gtf 1280 720 60". Copy the resulting modeline and add it in the monitor section of your xorg.conf file:

    My monitor section:
    Code:
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    # 1280x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 74.48 MHz	
    ModeLine     "1280x720_60.00" 74.5 1280 1336 1
    472 1664 720 721 724 746 -hsync +vsync
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    	Option	    "PreferredMode" "1280x720"
            
    EndSection
    Make a backup of this xorg.conf file.

    Step 2. Uninstall fglrx. You do this by executing /usr/share/ati/fglrx-uninstall.sh as superuser (sudo). This step might be unnecessary if you already have fglrx 8.11. You could remove the amdccle database instead. But it seems peope have problem with getting the modeline to actually stick so I suggest a clean reinstall of fglrx.

    Step 3. Reinstall fglrx. Please note that I'm using 8.11, for me 8.12 gives me segmentation faults whenever I try to use aticonfig. Make sure you replace the autogenerated xorg.conf with your previous xorg.conf that you backed up in step 1. It must contain the ForceMonitors and modeline entries.

    Step 4. Restart X / your computer. It should now have the correct resolution and use the HDMI output even when you TV is turned off during startup.

    If you still have problems you could try the following script (I don't need it). In fact, you could try this script before trying anything of the above. If it works, the stuff above should work as well:
    Code:
    aticonfig --set-dispattrib=tmds2i,positionX:0
    aticonfig --set-dispattrib=tmds2i,positionY:0
    aticonfig --set-dispattrib=tmds2i,sizeX:1280
    aticonfig --set-dispattrib=tmds2i,sizeY:720
    Replace the sizeX and sizeY values as appropriate.

    Good luck!
    Last edited by Magnusart; 01-04-2009 at 04:11 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •