Results 1 to 4 of 4

Thread: Anyone got sound over hdmi with 8.12?

  1. #1
    Join Date
    Jul 2008
    Posts
    50

    Default Anyone got sound over hdmi with 8.12?

    Got a 780g mobo, gentoo, alsa-lib-1.0.18, xorg-server-1.5.3, ati-drivers-8.561 (which is 8.12).
    Code:
     # aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC883 Analog [ALC883 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC883 Digital [ALC883 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    No problem getting sound out of 0:0, can't test 0:1, no sound over 1:3.
    That's the way I try to test it: alsamix -> unmute everything, startx (the image shows up on lcd tv), mplayer -ao alsa:device=hw=1.3 my.mp3.
    Nothing.

    Any suggestions would be highly appreciated. TIA.

  2. #2

    Default

    I have sound over HDMI with 8.11 and earlier. Are you sure the mp3 you are attempting to play is 44Khz and not 41Khz? Digital audio must be 44Khz and 41Khz samples just won't work unless they are upconverted.

    You should be using the alsa plug plugin to do on the fly rate conversion to 48Khz.

    Following the following section of the MythTV wiki on configuring Alsa for digital sound could be useful. It includes an alsa config which creates four new devices, you would want to use digital-dmix which automatically rate converts to 48Khz, "mplayer -ao alsa:device=digital-dmix my.mp3" or something similar for mplayer.

    http://www.mythtv.org/wiki/index.php...rc.2C_Properly

    You would need to edit the config to change the device and card numbers, see the comments.

  3. #3
    Join Date
    Jul 2008
    Posts
    50

    Default

    gbee
    Thanks for your reply.
    Yes, the mp3 is 44100.
    Are you able to get sound with
    Code:
    speaker-test -c2 --device cards.pcm.iec958 --rate 44100
    speaker-test -c2 --device cards.pcm.iec958 --rate 48000
    ?
    Could you please share the following info:
    1) kernel, alsa versions
    2) alsa, xorg configs

    Thanks a bunch.
    Last edited by gsmd; 01-04-2009 at 03:46 AM.

  4. #4
    Join Date
    Jul 2008
    Posts
    50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •