Hello I'm new here.

I have a 15m HDMI-HDMI-cord (by Deltaco, claims to support 1080i) but I can't get the fglrx-driver to switch to 720p resolution (1280x720). I have to use aticonfig --force-monitor=tmds2i to even get a picture. The maximum resolution I get is 1024x768.

My best guess is that fglrx does not get the EDID information an thus defaults to maximum 1024x768. This could be because of the cord, 15m is pushing it, I know.

HOWEVER, here comes the kicker: when using the open source ati-driver everything works just fine! EDID information is received without problem. But this driver does not support accelerated OpenGL yet (I want to use Elisa for my HTPC). So my guess is that it's not because of the cord as I initially thought. I even bought a HDMI-DVI gender changer, but I would still not get any increased resolution/EDID-information.

My last cord was a 10m DVI-HDMI type from Eagle. When I'm using this cord, the fglrx-driver works fine.

Any ideas? Can I Force the fglrx-driver to always output a 720p-signal or force it to support a monitor even if the fglrx-driver does not detect it? I tried editing the xorg.conf in various ways without any luck. My current xorg.conf is a vanilla with an additional driver "fglrx" added.

My Xorg.0.log output: http://pastebin.com/f79fc701d

Extremely grateful for any hints or tips. I tried posting this elsewhere with zero replies.