Results 1 to 8 of 8

Thread: [Bug?] /usr/lib/libAMDXvBA.so is missing

  1. #1
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default [Bug?] /usr/lib/libAMDXvBA.so is missing

    Maybe this is only a Gentoo bug, not sure, but the fglrx installer (8.12) doesn't seem to create a /usr/lib[32/64]/libAMDXvBA.so symlink. There are only libAMDXvBA.so.1 and libAMDXvBA.so.1.0, but no libAMDXvBA.so. It's imposible to link against libAMDXvBA without an .so in place.

  2. #2
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Did I fire the sparkle of hope in you? I don't have a header, sorry. I'm just trying to do what this article says:

    http://www.phoronix.com/scan.php?pag...vmc_xvba&num=1

    That is, configure mplayer with "--enable-xvmc" and "--with-xvmclib=AMDXvBA".

  3. #3
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Did you create the symlink?

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Yes. I'm just reporting this here so someone can fix this upstream. It still doesn't work though due to undefined symbols (see http://www.phoronix.com/forums/showthread.php?t=14706).

  5. #5
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Maybe test it on a 32 bit install.

  6. #6
    Join Date
    Dec 2008
    Posts
    1,002

    Default

    Quote Originally Posted by RealNC View Post
    Did I fire the sparkle of hope in you? I don't have a header, sorry. I'm just trying to do what this article says:

    http://www.phoronix.com/scan.php?pag...vmc_xvba&num=1

    That is, configure mplayer with "--enable-xvmc" and "--with-xvmclib=AMDXvBA".
    Xvmc works out of the box here with catalyst 8.12 and mplayer from the intrepid repository, no need to compile anything.

    FYI, mplayer from intrepid is configured with: --enable-xvmc --with-xvmclib=XvMCW

  7. #7
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Well, I'm happy for you Still doesn't compile here.

    (This is the wrong thread, btw.)

  8. #8
    Join Date
    Dec 2008
    Posts
    1,002

    Default

    It would probably compile if you just configure it with --with-xvmclib=XvMCW. But if you insist on linking mplayer against libAMDXvBA.so just to get basic xvmc support see it your self...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •