If you use the default setup in lenny there should be no reason to upgrade. I have 2 machines here running lenny + ati cards, (4870 + 2600xt) and they both just work. 64 and a 32bit respectfully.

All I do to install the driver is ./ati-driver-installer-xxx.run with no arguments.