Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 64-bit, RadeonHD, an HDTV and a 4850 = no worky?

  1. #1

    Default 64-bit, RadeonHD, an HDTV and a 4850 = no worky?

    I recently tried out openSUSE (11.1, 64-bit) and found that the Live CDs gave me no display. I could install from the DVD but got a blank screen when it got to a point where I'd normally see the login screen. Starting with "x11failsafe" allowed me to get it working and from there I could install fglrx and got the display working.

    For various reasons I decided to hop back to Ubuntu. 8.10 works fine, haven't had any issues there, but I thought to try out the 9.04 alpha 2 that's currently available. I'm guessing this also uses RadeonHD by default because the behavior was exactly the same.

    I use an HDTV as my monitor - the same model Toshiba recently reviewed on Phoronix - and have it connected via DVI->HDMI cable to a Palit Sonic Radeon 4850. Is this expected behavior of the driver in its current state or should I at least have a functioning display?

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,417

    Default

    Do you know which version of the driver was being loaded each time (it would be near the front of the xorg log). I haven't heard of any recent 64-bit-specific problems but maybe something slipped in. If you could pastebin one or both X logs that would be a big help.

  3. #3

    Default

    1.2.3, as far as I know. That's the version in the Ubuntu Jaunty repository, at least.

    I'll see if I can get the X log off of the system. I put Ubuntu 8.10 back on it for now, but booting a SUSE Live CD ought to provide something useful. I'll test it out tomorrow and post back here.

  4. #4

    Default

    Apologies for the extra time this reply required. Booting with a SUSE Live CD, much to my dismay, didn't allow me access to a terminal with CTRL-ALT-F3 -not sure why- so I had to do a clean install of OpenSUSE 11.1 to get to it.

    The first time I booted the system wouldn't display the login screen, as previously described. So I restarted and added "x11failsafe" to the otherwise normal boot line.

    I can't post the whole xorg log file, says the post is too long. Hmm.

    Here are some excerpts that may be relevant. The first one shows that it isn't familiar with my particular board, which may be part of the problem?

    Code:
    (II) RADEONHD: version 1.2.3, built from dist of git branch master, commit ed532a70
    
    (II) Primary Device is: PCI 01@00:00:0
    (II) resource ranges after xf86ClaimFixedResources() call:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    (II) resource ranges after probing:
    	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
    	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
    	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
    	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
    	[4] 0	0	0x000a0000 - 0x000affff (0x10000) MS[B]
    	[5] 0	0	0x000b0000 - 0x000b7fff (0x8000) MS[B]
    	[6] 0	0	0x000b8000 - 0x000bffff (0x8000) MS[B]
    	[7] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
    	[8] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
    	[9] 0	0	0x000003b0 - 0x000003bb (0xc) IS[B]
    	[10] 0	0	0x000003c0 - 0x000003df (0x20) IS[B]
    (II) Setting vga for screen 0.
    (**) RADEONHD(0): Depth 24, (--) framebuffer bpp 32
    (**) RADEONHD(0): Selected ShadowFB.
    (II) RADEONHD(0): Unknown card detected: 0x9442:0x0000:0x0000.
    	If - and only if - your card does not work or does not work optimally
    	please contact radeonhd@opensuse.org to help rectify this.
    	Use the subject: 0x9442:0x0000:0x0000: <name of board>
    	and *please* describe the problems you are seeing
    	in your message.
    (--) RADEONHD(0): Detected an RV770 on an unidentified card
    (II) RADEONHD(0): Mapped IO @ 0xfe8e0000 to 0x7f736a577000 (size 0x00010000)
    (II) RADEONHD(0): PCIE Card Detected
    (II) RADEONHD(0): Getting BIOS copy from legacy VBIOS location
    (II) RADEONHD(0): ATOM BIOS Rom: 
    	SubsystemVendorID: 0x0000 SubsystemID: 0x0000
    	IOBaseAddress: 0xb000
    	Filename: 48501G68.22N
    	BIOS Bootup Message: 
    
    ATI RADEON HD4800 SERIES
    Last edited by deruberhanyok; 12-29-2008 at 10:49 PM.

  5. #5

    Default

    This other part was too long to include in the above post. One other excerpt, with what I'm pretty sure is the initialization of the display:

    Code:
    (II) RADEONHD(0): Analog TV Default Mode: 1
    (II) RADEONHD(0): Found default TV Mode NTSC
    (II) RADEONHD(0): The detected amount of videoram exceeds the PCI BAR aperture.
    (II) RADEONHD(0): Using only 262144kB of the total 524288kB.
    (--) RADEONHD(0): VideoRAM: 262144 kByte
    (II) RADEONHD(0): Framebuffer space used by Firmware (kb): 20
    (II) RADEONHD(0): Start of VRAM area used by Firmware: 0x7ffec
    (II) RADEONHD(0): AtomBIOS requests 20kB of VRAM scratch space
    (II) RADEONHD(0): AtomBIOS VRAM scratch base: 0x7ffec
    (WW) RADEONHD(0): rhdAtomAllocateFbScratch: FW FB scratch area not located at the end of VRAM. Scratch End: 0x84fec VRAM End: 0x10000000
    (II) RADEONHD(0): Cannot get VRAM scratch space. Allocating in main memory instead
    (II) RADEONHD(0): Default Engine Clock: 685000
    (II) RADEONHD(0): Default Memory Clock: 1000000
    (II) RADEONHD(0): Maximum Pixel ClockPLL Frequency Output: 1200000
    (II) RADEONHD(0): Minimum Pixel ClockPLL Frequency Output: 0
    (II) RADEONHD(0): Maximum Pixel ClockPLL Frequency Input: 16000
    (II) RADEONHD(0): Minimum Pixel ClockPLL Frequency Input: 6000
    (II) RADEONHD(0): Maximum Pixel Clock: 400000
    (II) RADEONHD(0): Reference Clock: 100000
    (II) RADEONHD(0): Direct rendering turned off by default. Use Option "DRI" to enable.
    (II) Loading sub module "i2c"
    (II) LoadModule: "i2c"
    (II) Module "i2c" already built-in
    (II) RADEONHD(0): Reference Clock: 100000
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask: 0x1f90
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask_Shift: 0x0
    (II) RADEONHD(0): GPIO_I2C_Data_Mask: 0x1f90
    (II) RADEONHD(0): GPIO_I2C_Data_Mask_Shift: 0x8
    (II) RADEONHD(0): I2C bus "RHD I2C line 0" initialized.
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask: 0x1f94
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask_Shift: 0x0
    (II) RADEONHD(0): GPIO_I2C_Data_Mask: 0x1f94
    (II) RADEONHD(0): GPIO_I2C_Data_Mask_Shift: 0x8
    (II) RADEONHD(0): I2C bus "RHD I2C line 1" initialized.
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask: 0x1f98
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask_Shift: 0x0
    (II) RADEONHD(0): GPIO_I2C_Data_Mask: 0x1f98
    (II) RADEONHD(0): GPIO_I2C_Data_Mask_Shift: 0x8
    (II) RADEONHD(0): I2C bus "RHD I2C line 2" initialized.
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask: 0x1f88
    (II) RADEONHD(0): GPIO_I2C_Clk_Mask_Shift: 0x0
    (II) RADEONHD(0): GPIO_I2C_Data_Mask: 0x1f88
    (II) RADEONHD(0): GPIO_I2C_Data_Mask_Shift: 0x8
    (II) RADEONHD(0): I2C bus "RHD I2C line 3" initialized.
    (II) Loading sub module "ddc"
    (II) LoadModule: "ddc"
    (II) Module "ddc" already built-in
    (II) RADEONHD(0): Detected VGA mode.
    (**) RADEONHD(0): Using AtomBIOS for Crtcs
    (**) RADEONHD(0): Using AtomBIOS for PLLs
    (II) RADEONHD(0): Minimum Pixel ClockPLL Frequency Output: 0
    (II) RADEONHD(0): Maximum Pixel ClockPLL Frequency Output: 1200000
    (II) RADEONHD(0): Maximum Pixel Clock: 400000
    (II) RADEONHD(0): Reference Clock: 100000
    (II) RADEONHD(0): rhdAtomSetPixelClockVersion returned version 3 for index 0xc
    (II) RADEONHD(0): rhdAtomSetPixelClockVersion returned version 3 for index 0xc
    (II) RADEONHD(0): FB: Allocated Cursor Image at offset 0x00000000 (size = 0x00004000)
    (II) RADEONHD(0): FB: Allocated Cursor Image at offset 0x00004000 (size = 0x00004000)
    (II) RADEONHD(0): Connector[0] {RHD_CONNECTOR_DVI, "DUAL_LINK_DVI_I DFP1 CRT2", RHD_DDC_2, RHD_HPD_0, { RHD_OUTPUT_UNIPHYA, RHD_OUTPUT_DACB } }
    (II) RADEONHD(0): Connector[1] {RHD_CONNECTOR_TV, "7PIN_DIN TV1 CV", RHD_DDC_0, RHD_HPD_NONE, { RHD_OUTPUT_DACB, RHD_OUTPUT_NONE } }
    (II) RADEONHD(0): Connector[2] {RHD_CONNECTOR_DVI, "DUAL_LINK_DVI_I CRT1 DFP2", RHD_DDC_3, RHD_HPD_1, { RHD_OUTPUT_KLDSKP_LVTMA, RHD_OUTPUT_DACA } }
    (**) RADEONHD(0): Using AtomBIOS for Outputs
    (II) RADEONHD(0): rhdAtomSelectCrtcSourceVersion returned version 2 for index 0x2a
    (--) RADEONHD(0): Attaching Output AtomOutputUniphyA to Connector DVI-I 1
    (**) RADEONHD(0): Using AtomBIOS for Outputs
    (II) RADEONHD(0): rhdAtomSelectCrtcSourceVersion returned version 2 for index 0x2a
    (--) RADEONHD(0): Attaching Output AtomOutputDACB to Connector DVI-I 1
    (--) RADEONHD(0): Attaching Output AtomOutputDACB to Connector TV 7PIN_DIN
    (**) RADEONHD(0): Using AtomBIOS for Outputs
    (==) RADEONHD(0): Setting AtomOutputKldskpLvtma to incoherent
    (II) RADEONHD(0): rhdAtomSelectCrtcSourceVersion returned version 2 for index 0x2a
    (--) RADEONHD(0): Attaching Output AtomOutputKldskpLvtma to Connector DVI-I 2
    (**) RADEONHD(0): Using AtomBIOS for Outputs
    (II) RADEONHD(0): rhdAtomSelectCrtcSourceVersion returned version 2 for index 0x2a
    (--) RADEONHD(0): Attaching Output AtomOutputDACA to Connector DVI-I 2
    (II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/digital for Output AtomOutputUniphyA
    (II) RADEONHD(0): RandR: Adding RRoutput DVI-I_1/analog for Output AtomOutputDACB
    (II) RADEONHD(0): RandR: Adding RRoutput TV_7PIN_DIN for Output AtomOutputDACB
    (II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/digital for Output AtomOutputKldskpLvtma
    (II) RADEONHD(0): RandR: Adding RRoutput DVI-I_2/analog for Output AtomOutputDACA
    (II) RADEONHD(0): Output DVI-I_1/digital using monitor section Monitor[0]
    (**) RADEONHD(0): Option "PreferredMode" "1280x1024"
    (II) RADEONHD(0): Output DVI-I_1/analog has no monitor section
    (II) RADEONHD(0): Output TV_7PIN_DIN has no monitor section
    (II) RADEONHD(0): Output DVI-I_2/digital using monitor section Monitor[0]
    (II) RADEONHD(0): Output DVI-I_2/analog has no monitor section
    (II) RADEONHD(0): Calling DAC_LoadDetection
    (II) RADEONHD(0): DAC_LoadDetection Successful
    (II) RADEONHD(0): I2C device "RHD I2C line 3:ddc2" registered at address 0xA0.
    (II) RADEONHD(0): EDID data for TSB-TV
    (II) RADEONHD(0): Manufacturer: TSB  Model: 206  Serial#: 16843009
    (II) RADEONHD(0): Year: 2008  Week: 255
    (II) RADEONHD(0): EDID Version: 1.3
    (II) RADEONHD(0): Digital Display Input
    (II) RADEONHD(0): Max Image Size [cm]: horiz.: 105  vert.: 59
    (II) RADEONHD(0): Gamma: 2.20
    (II) RADEONHD(0): No DPMS capabilities specified
    (II) RADEONHD(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
    (II) RADEONHD(0): First detailed timing is preferred mode
    (II) RADEONHD(0): redX: 0.625 redY: 0.340   greenX: 0.280 greenY: 0.595
    (II) RADEONHD(0): blueX: 0.155 blueY: 0.070   whiteX: 0.283 whiteY: 0.298
    (II) RADEONHD(0): Supported VESA Video Modes:
    (II) RADEONHD(0): 640x480@60Hz
    (II) RADEONHD(0): 640x480@72Hz
    (II) RADEONHD(0): 640x480@75Hz
    (II) RADEONHD(0): 800x600@60Hz
    (II) RADEONHD(0): 800x600@72Hz
    (II) RADEONHD(0): 800x600@75Hz
    (II) RADEONHD(0): 1024x768@60Hz
    (II) RADEONHD(0): 1024x768@70Hz
    (II) RADEONHD(0): 1024x768@75Hz
    (II) RADEONHD(0): Manufacturer's mask: 0
    (II) RADEONHD(0): Supported Future Video Modes:
    (II) RADEONHD(0): #0: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
    (II) RADEONHD(0): #1: hsize: 1360  vsize 765  refresh: 60  vid: 49291
    (II) RADEONHD(0): Supported additional Video Mode:
    (II) RADEONHD(0): clock: 148.5 MHz   Image Size:  708 x 398 mm
    (II) RADEONHD(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
    (II) RADEONHD(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
    (II) RADEONHD(0): Supported additional Video Mode:
    (II) RADEONHD(0): clock: 27.0 MHz   Image Size:  708 x 398 mm
    (II) RADEONHD(0): h_active: 720  h_sync: 736  h_sync_end 798 h_blank_end 858 h_border: 0
    (II) RADEONHD(0): v_active: 480  v_sync: 489  v_sync_end 495 v_blanking: 525 v_border: 0
    (II) RADEONHD(0): Monitor name: TSB-TV
    (II) RADEONHD(0): Ranges: V min: 23 V max: 76 Hz, H min: 15 H max: 68 kHz, PixClock max 150 MHz
    (II) RADEONHD(0): Number of EDID sections to follow: 1
    (II) RADEONHD(0): EDID (in hex):
    (II) RADEONHD(0): 	00ffffffffffff005262060201010101
    (II) RADEONHD(0): 	ff12010380693b780a0dc9a057479827
    (II) RADEONHD(0): 	12484c2dce0081808bc0010101010101
    (II) RADEONHD(0): 	010101010101023a801871382d40582c
    (II) RADEONHD(0): 	4500c48e2100001e8c0ad08a20e02d10
    (II) RADEONHD(0): 	103e9600c48e21000018000000fc0054
    (II) RADEONHD(0): 	53422d54560a202020202020000000fd
    (II) RADEONHD(0): 	00174c0f440f000a20202020202001cc
    (II) RADEONHD(0): Calling DAC_LoadDetection
    (II) RADEONHD(0): DAC_LoadDetection Successful
    (II) RADEONHD(0): Output DVI-I_1/digital disconnected
    (II) RADEONHD(0): Output DVI-I_1/analog disconnected
    (II) RADEONHD(0): Output TV_7PIN_DIN disconnected
    (II) RADEONHD(0): Output DVI-I_2/digital connected
    (II) RADEONHD(0): Output DVI-I_2/analog disconnected
    (II) RADEONHD(0): Using user preference for initial modes
    (II) RADEONHD(0): Output DVI-I_2/digital using initial mode 1280x1024
    (II) RADEONHD(0): RandR 1.2 support enabled
    (==) RADEONHD(0): RGB weight 888
    (==) RADEONHD(0): Default visual is TrueColor
    (==) RADEONHD(0): Using gamma correction (1.0, 1.0, 1.0)
    (II) RADEONHD(0): Using 3840x1200 Framebuffer with 3840 pitch
    (II) RADEONHD(0): FB: Allocated ScanoutBuffer at offset 0x00008000 (size = 0x01194000)
    (**) RADEONHD(0): Display dimensions: (708, 398) mm
    (**) RADEONHD(0): DPI set to (45, 65)
    Any ideas? I saw the line in the first excerpt about contacting the developers with the card's PCI ID, so I can do that if needed.

    How can I post the whole log? Or would it be better to e-mail that to the dev address if needed?
    Last edited by deruberhanyok; 12-29-2008 at 10:49 PM.

  6. #6

    Default

    Should I just mail the devs?

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,417

    Default

    Can you pastebin the entire log ? There isn't enough info there to see what is going on.

    http://www.pastebin.ca

  8. #8

  9. #9
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,417

    Default

    Thanks. Looks like the driver is starting up normally and setting to 1280x1024 resolution. The only obvious possible issues I saw was that the output is being set to incoherent (coherent / non-coherent is a timing tweak between the clock and data lines going to the display), I think this default was changed recently;

    I would try the coherent/non-coherent option first then send an email to the radeonhd mailing list including your pastebin'ed log.

    According to the man page I think you want to add :

    Option Coherent "UNIPHY_A=off"

    ... to your config file.

  10. #10

    Default

    Alright, I'll give that a try tonight and see what happens. If it works (or even if it doesn't) I'll post results here and send something to the mailing list as well.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •