Results 1 to 8 of 8

Thread: Is there a way to permanently disable the default underscanning?

Hybrid View

  1. #1

    Default Is there a way to permanently disable the default underscanning?

    My HDTV (Toshiba 32RV530U) allows 1:1 pixel mapping, yet my video card (a Radeon 4850) insists on underscanning by default.

    In windows this is pretty annoying, as it needs to be corrected for every resolution I use. But the drivers have a slider so it can at least be fixed fairly quickly. I've yet to run into a refresh rate / resolution combo that I haven't been able to correct.

    Since the Linux drivers don't yet have this slider I've had to use instructions found here to disable the underscan ("aticonfig --initial" and "aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0"). That works most of the time.

    Is there a way to make this setting permanent? Can I send a command to the card and say 'please stop doing this, now and for the rest of your lifespan?'

    Also, out of curiosity: what was the reason behind making them underscan by default, instead of just having the option there for TVs that required it? Do other cards in the 4000 series do this?

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    I think this is standard functionality across all of our drivers. Most HDTVs were being set to overscan by default so users were unable to even see the menu bar. The aticonfig --set-pcs command is supposed to be permanent AFAIK.

    There have been some reports that the command is not working with recent drivers; I have asked for the latest recommendations from our driver teams.

  3. #3

    Default

    Ah, alright, thanks for checking into that, bridgman. If the scaling slider were to make its way into the Linux Catalyst drivers (or radeonhd) it would effectively mootify (I think I just made that up) the issue. But I know there's a whole list of things you guys are working on, and it seems right now there's a bunch of display-related changes happening overall (DRI2, GEM, etc etc) so I won't press further.

    I noticed that it happens even during POST, so I'm guessing there's a default value specified in the BIOS somewhere? Perhaps a way to change that at the hardware level rather than in the drivers? Or is that beyond the scope of this forum?

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Yeah, the BIOS underscan is the main thing I am trying to understand right now. Didn't think we had underscan code there.

  5. #5

    Default

    I can confirm that I got underscan there (directly at system start, during post and such) with my hd3850 attached to a Sony 40W400 via dvi->hdmi (a great TV and it works really well as secondary screen on my Linux System). At the beginning I had probs making the switch to "no underscan mode" work with the command
    aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
    Though using the following four commands was working fine (not permanent, just per current session):
    aticonfig --set-dispattrib=tmds2i,positionX:0
    aticonfig --set-dispattrib=tmds2i,positionY:0
    aticonfig --set-dispattrib=tmds2i,sizeX:1920
    aticonfig --set-dispattrib=tmds2i,sizeY:1080
    I think it eventually worked after removing the old /etc/ati/amdpcsdb. But I am not 100% sure that this was the reason why it suddenly worked.

  6. #6

    Default

    I'm replying here rather than start a new thread as my question remains the same. Sort of a long-term bump.

    Is there a way to disable this in the card's BIOS?

    I don't know if a lot of people feel the same way, but having the card underscan like this is really, really irritating to me.

    [edit] - by the way, thank you guys for adding a scaling slider to catalyst 9.5!
    Last edited by deruberhanyok; 05-23-2009 at 05:27 PM.

  7. #7
    Join Date
    Mar 2009
    Posts
    14

    Default

    Quote Originally Posted by deruberhanyok View Post
    I don't know if a lot of people feel the same way, but having the card underscan like this is really, really irritating to me.
    And to me. This broken-by-default-with-no-way-to-change-it behaviour is ridiculous. It should be a jumper setting. Or a bit in the video BIOS. My monitor and my TV both overscan by default but have options to permanently disable it.

    I shouldn't have to fiddle with my operating systems to make the problem go away temporarily, until the next reboot, or driver update, or OS reinstall.

    And BIOS/UEFI setup remains broken in any case. My 1080p monitor displays it in 720p which means that one has to scroll around to get at all the options. This is extremely annoying! (I guess 720p is chosen over 1080p because 1080p downscaled to make room for the black borders might be too difficult to read.)

    What tools are available for reading/writing video BIOSes and what documentation exists?

    This problem needs to be fixed.

  8. #8
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    I don't know of a way to disable it in BIOS but there should be a way to have the driver always display full size.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •