Quote Originally Posted by bulletxt View Post
ok it seems you aren't getting my point. that skype thing was just an example. do you want a generic example?

software X depends on XYZ library > 2.1.1, but you have installed XYZ 2.0.1. Now go and tell your grandm to update XYZ to 2.1.1 from sources.

Is this a better example? if you don't understand this, it means you don't want to accept reality.
Well, it seems you don't get my point either, and i can tell you XP wasn't "just an example".

And actually if I want her to update from source it's not hard at all, I either provide her with a script, backport the library "prevu that_funy_library", or build the package in a chroot for her (pbuilder-dapper-i386 build that_funy_library-XubuntuX.dsc", assuming I/she can't wait. Else I just request a backport and let people do the job for me.

Basically, you'll always find a situation where X OS is "problematic", especially if you don't know the OS enough. Complaining about it when there's easy solutions and/or you could be helping solving the problem is hardly useful. Hoping that such an attitude is going to miraculously improve the situation only gets you stuck in an ages-old prejudice when other have moved on already.

The way it is, that's basically a non issue, and any package you think can't be installed because of foo library may already be packaged for your system on getdeb, medubuntu or any other click-and-work solution.