Results 1 to 4 of 4

Thread: Driver option to limit dedicated memory usage?

  1. #1
    Join Date
    Sep 2007
    Posts
    30

    Default Driver option to limit dedicated memory usage?

    Hi people.

    I have a very sad story that ends with my onboard video card ( X700 Mobility on an expensive laptop ) not working for any 3D 'stuff'. Here's a copy/paste of what I sent to the xorg list:

    - If I start X with DRI enabled with xf86-video-ati, I get a hard lockup - usually instantly, but sometimes after a couple of seconds. I get lots of messages in my X log about "[mi] EQ overflowing. The server is probably stuck in an infinite loop." and "[mi] mieqEnequeue: out-of-order valuator event; dropping".

    - If I start X with xf86-video-ati and DRI disabled ( 'Option DRI 0' in xorg.conf ), X startx fine and works for extended periods ( tested up to 1 day ).

    - If I start X with fglrx, and DRI enabled, it works fine. But if I start compiz or anything 3D ( including glxgears ), I get *massive* corruption. Bits of windows are echoed all over the place. Everything works 'fine' other than this. If I kill compiz, everything works normally as with xf86-video-ati and DRI disabled.

    The only positive news is that the textured video driver in xf86-video-ati works perfectly, and I believe this uses the 3D chip, so gives me some hope that it's a memory issue and not the 3D chip fried.

    I should also note that this is absolutely not a software / config issue. I've installed various versions of Gentoo, Sabayon and Ubuntu, and all exhibit the same behaviour.

    So ... the problem is a hardware one. I assume it's either the 3D chip or memory. If it's the 3D chip, there's not much I can do. But if it's memory, I should be able to blacklist part of the memory or something, right? I know that the open-source drivers ( used to / still do? ) allocate half available memory to 2D and half to 3D, and I'm hoping that this is the explanation for why 2D is working and not 3D ( though I suppose this is largely wishful thinking ).

    Is there any hope? Are there any driver options for xf86-video-ati, xf86-video-radeonhd or fglrx that would allow me to blacklist part of my video card memory?

    Thanks

    Dan

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,411

    Default

    This sounds familiar; did you post about this on IRC a while back ?

    This sounds like an AGP bus problem but I was pretty sure that Mobility X700's were PCIE. Do you happen to know which bus your laptop uses ?

  3. #3
    Join Date
    May 2008
    Location
    Germany/NRW
    Posts
    510

    Default

    You can add "VideoRam <Value in Bytes>" to your Device-Section.
    I have no idea though if this is read/respected by current drivers.

  4. #4
    Join Date
    Sep 2007
    Posts
    30

    Default

    Quote Originally Posted by bridgman View Post
    This sounds familiar; did you post about this on IRC a while back ?
    Hi Bridgman. Thanks for the response. And yes, I was asking for help on IRC about this a while back - it was a couple of months back now. I ended up doing a 4-hour git-bisect session, and to my horror I discovered that it wasn't a software issue at all ( and then to check I did about 4 different installs, and finally rebooted into Windows ... which has it's own problems ... it flashes the display on and off for a couple of minutes, and then announces something about acceleration being completely disabled and that things will go slow ).

    Quote Originally Posted by bridgman View Post
    This sounds like an AGP bus problem but I was pretty sure that Mobility X700's were PCIE. Do you happen to know which bus your laptop uses ?
    Yes it's PCIE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •