CPU: AMD Sempron Processor 2800+ stepping 02, SiS chipset
OS: up-to-date Debian/Lenny (32 bit!)
Kernel: 2.6.26-1-686 #1 SMP Mon Dec 15 18:15:07 UTC 2008 i686 GNU/Linux
X.Org X Server 1.4.2, Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-9)
Catalyst 9.1 from ATI web-site
Graphics Card: Club 3D ATI Radeon HD2400Pro 256MB AGP

When the X server is started with DRI enabled, the kernel panics with
[ 2609.994682] Clocksource tsc unstable (delta = 4686535799 ns)
[ 2610.003291] CPU 0: Machine Check Exception: 0000000000000004
[ 2610.008363] CPU 0: Bank 4: 3200000000070f0f
[ 2610.012574] Kernel panic - not syncing: CPU context corrupt

(I have captured this from the TTY port, the screen goes completey blank and the system freezes)

The messages I captured from the X server are:
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
compiled for 7.1.0,(II) Primary Dev(II) AMD ASIC control file status: R12 S1 B313 N313 T312
(--) Chipset Supported AMD Graphics Processor (0x94C4) found
(II) AMD Video driver is [8] -1 0 0xe012S[B]
[17] 0 0 (II) fglrx(0): Loading PCS database from /etc/ati/amdpcsdb
(II)(II) fglrx(0): Primary V_BIOS se(II) Module vbe: (II) fglrx(0): ATI Video BIOS revision 9 or later detected
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 10, (OK)
drmOpenByBusid: drmOpenMinor returns 10
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
(II) fglrx(0): Using adapter: 1:0.0.
(II) fglrx(0): [FB] MC range(MCFBBase = 0xd0000000, MCFBSize = 0x10000000)
(--) fglrx(0): Video RAM: 262144 kByte, Type: DDR2
(II) fglrx(0): AGP card detected
(WW) fglrx(0): board is an unknown third party board, chipset is supported

When I turn up the Xorg debug level, the last messages before the freeze are

(II) fglrx(0): Manufacturer's mask: 10
(II) fglrx(0): Supported Future Vi(WW) fglrx(0): More than one dis(II) fglrx(0): Primary Con
troller - DFP on secondary TMDS
(II) fglrx(0): Secondary Controller - CRT on secondary DAC
(II) fglrx(0): Internal Desktop Setting: 0x00000008
(==) fglrx(0): QBS disabled
(==) fglrx(0): FAST_SWAP disabled
(==) fglrx(0): PseudoColor visuals disabled
(==) fglrx(0): Using gamma correction (1.0, 1.0, 1.0)
(==) fglrx(0): Center Mode is disabled
(==) fglrx(0): TMDS coherent mode is enabled
(II) fglrx(0): Total of 41 modes found for primary display.
(--) fglrx(0): Virtual size is 1680x1050 (pitch 0)
(**) fglrx(0): *Mode "1680x1050": 146.2 MHz (scaled from 0.0 MHz), 65.3 kHz, 60.0 Hz
(II) fglrx(0): Modeline "1680x1050"x60.0 146.25 1680 1784 1960


I bought a Radeon HD3650 this summer, and could not get DRI to work with this graphics card and Catalyst 8.8, 8.9 and 8.10. I even tried the old 8.42.3 driver, fiddling with the AGP aperture and reducing the AGP speed.
At the time I filed two bug reports
(http://support.ati.com/ics/support/t...ket_id=1369143 and
http://support.ati.com/ics/support/t...ket_id=1368394) directly at ATI, but they said they could not help.

I then downgraded to an HD2400 board, but it showed the same symptoms.

I tried each new Catalyst version, and filed a bug report for Catalyst 8.12 at the Unofficial ATI Linux Driver Bugzilla, http://ati.cchtml.com/show_bug.cgi?id=1404.

(With the previous Catalyst versions, the X server died already in drmOpenDevice(), so there is at least a small improvement ;-)

For my xorg.conf that results in the freeze see

http://www.drivehq.com/file/df.aspx/...-FGLRX-minimal

I have started the X server from a tty line with logging turned on and captured the output until it hangs, see

http://www.drivehq.com/file/df.aspx/...-1-minimal.txt

For information about my system configuration, see the captured boot log

http://www.drivehq.com/file/df.aspx/...talyst8.12.txt

In the meantime I am running with the radeonhd driver which is reaonably fast but unfortunately does not support 3D yet for the HD24xx/26xx/36xx chipsets. (I have also tried the latest open-source ATI drivers from the X-org gitrepository, but they also don't support these chipsets yet).

Has someone an idea what I could try to get this sorted out?

Regards,

Oswald