Results 1 to 10 of 22

Thread: ATI Mobility Radeon HD 3650: crash on X startup

Threaded View

  1. #1
    Join Date
    Oct 2008
    Posts
    62

    Default ATI Mobility Radeon HD 3650: crash on X startup

    [Disclaimer: This is a crosspost from forums.opensuse.org. I did not receive any answer there.]

    I am trying to use the proprietary catalyst driver with my ATI Mobility Radeon HD 3650 chipset on an HP Elitebook 8530p on a newly installed openSUSE 11.1.

    Version 8.11 of the driver installs fine, X starts up fine, but it is running quite unstable (frequent crashes when playing video, switching consoles,...).

    But when installing a newer driver (8.12 or 9.1) the machine crashes on the startup of X (under Gnome and KDE 4.x, under GDM and KDM), leaving a blank screen and an unresponsive machine. I used the same procedure to install 8.11 and 8.12/9.1: Download driver, run, ati-config --initial (I tried with and without sax2 -r -m 0=fglrx).

    I also tried to replace /etc/ati/amdpcsdb with /etc/ati/amdpcsdb.default.

    Does somebody have any idea, on what I am doing wrong? Or did I find a bug in the driver itself?

    In the Xorg.0.log file I find (for 8.12) the following lines:
    Code:
    Backtrace:
    0: /usr/bin/X(xf86SigHandler+0x79) [0x80c0c19]
    1: [0xffffe400]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    /var/log/messages:
    Code:
    [fglrx:fireglAsyncioIntEnableMsgHandler] *ERROR* interrupt source ff000066 is not supported on this hardware (return code = 1)
    Full Xorg.0.log files:
    (8.12): http://pastebin.com/f3a672c79
    (9.1): http://pastebin.com/f4d75c047

    lspci -vvnn: http://pastebin.com/f4094dffc
    xorg.conf: http://pastebin.com/f344718b2

    ---
    The original message was posted on:
    http://forums.opensuse.org/hardware/...ml#post1936020
    Last edited by dgrafenhofer; 02-01-2009 at 02:27 PM. Reason: Added lspci output AND error in /var/log/messages AND xorg.conf

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •