Results 1 to 5 of 5

Thread: remove mode from xrandr

  1. #1
    Join Date
    Jun 2007
    Location
    Albuquerque NM USA
    Posts
    351

    Default remove mode from xrandr

    Running Ubuntu 8.10 with the FGLRX driver installed by the restricted driver manager (8.54.3).

    I was running a dual display configuration here until my Border Collie puppy decided that she wanted to eat one of the displays, pulled it off the desk and chewed it well and truly up. Fortunately, she pulled the power cord out of the socket as she did so (having previously discovered that she doesn't like the taste of electricity) but the display isn't all that it used to be.

    Somewhere along the way xrandr added a mode to handle the dual-display virtual screen area, and the system still starts in that mode, although the remaining display itself comes up in an appropriate resolution.

    The help says the command to remove a mode from xrandr is:

    xrandr --delmode <output> <name>

    or possibly xrandr --rmmode <name>

    I can't make these work, mostly because I'm not sure what it wants in the <name> parameter.

    Here's the top part of the output of xrandr -q:
    Code:
    Screen 0: minimum 320 x 200, current 3840 x 1200, maximum 3840 x 1200
    default connected 3840x1200+0+0 0mm x 0mm
       3840x1200      60.0* 
       1920x1200      60.0  
       1920x1080      60.0  
       1680x1050      60.0  
       1600x1200      60.0
    I would like to remove the 3840x1200 mode because I can't use it any more. Would appreciate some pointers on the proper systax (or the proper command if I'm using the wrong one).

  2. #2
    Join Date
    Oct 2007
    Posts
    44

    Default

    Maybe it's still configured for two screens in the control center. Have you checked there?

  3. #3
    Join Date
    Jun 2007
    Location
    Albuquerque NM USA
    Posts
    351

    Default

    I checked...it's correct for one display. There is a setting for "desired desktop area" but the largest setting available there is the (correct) 1920x1200. I tried resetting that anyway, but after restarting the Xserver it still came up in 3480x1200 mode.

    xrandr -s 1920x1200

    will resize the area, but I'd like to have that as the default and remove the undesired mode.

  4. #4
    Join Date
    Oct 2007
    Posts
    44

    Default

    hmm ..does ati-config --list-pairmode show that mode? Then the --remove-pairmode option might get rid of it.

    Or if all fails ..just remove all option lines from the device section of the xorg.conf that you haven't added yourself and delete /etc/ati/amdpcsdb while X isn't running.

  5. #5
    Join Date
    Jun 2007
    Location
    Albuquerque NM USA
    Posts
    351

    Default

    Deleting /etc/ati/amdpcsdb did the trick. Thank you.

    For the record: The part about X not running when you try to delete amdcpsdb is critical. If X is running when you delete the file, it just gets recreated in its present form.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •