Results 1 to 5 of 5

Thread: PTS 1.6 cannot run doom3 benchmark

  1. #1
    Join Date
    Feb 2009
    Posts
    3

    Default PTS 1.6 cannot run doom3 benchmark

    Hi

    I've been trying to run the doom3 benchmark, and have had a problem. I continuously get an error about "couldn't load default.cfg".
    Code:
    $ phoronix-test-suite benchmark doom3
    
    
    ====================================
    Test Configuration: Doom 3
    ====================================
    
    
    Resolution:
    
    1: 800 x 600
    2: 960 x 600
    3: 1024 x 768
    4: 1280 x 800
    5: 1280 x 960
    6: 1440 x 900
    7: 1280 x 1024
    8: 1400 x 1050
    9: 1680 x 1050
    10: 1600 x 1200
    11: 1920 x 1200
    
    Enter Your Choice: 7
    
    Quality:
    
    1: Low
    2: High
    3: Ultra
    
    Enter Your Choice: 1
    
    Would you like to save these test results (Y/n)? n
    
    ====================================
    Doom 3 (Run 1 of 3)
    ====================================
    
    DOOM 1.3.1.1304 linux-x86 Jan 16 2007 21:58:02
    found interface lo - loopback
    found interface br0 - 192.168.1.2/255.255.255.0
    found interface vnet0 - 192.168.122.1/255.255.255.0
    no 'base' directory in exe path /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/bin/Linux/x86, skipping
    ------ Initializing File System ------
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game01.pk4 with checksum 0x51c6981f
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game02.pk4 with checksum 0xf3ec6f7
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game03.pk4 with checksum 0x5d4230ea
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak005.pk4 with checksum 0x8ffc3621
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak006.pk4 with checksum 0x95b65ab
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak007.pk4 with checksum 0x666bdb3c
    Loaded pk4 /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak008.pk4 with checksum 0x23ae5993
    Current search path:
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3//.doom3/base
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak008.pk4 (3 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak007.pk4 (38 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak006.pk4 (48 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/pak005.pk4 (63 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game03.pk4 (2 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game02.pk4 (2 files)
    /home/wiresquire/.phoronix-test-suite/installed-tests/doom3/base/game01.pk4 (2 files)
    game DLL: 0x0 in pak: 0x0
    Addon pk4s:
    file system initialized.
    --------------------------------------
    Unknown command 'vid_restart'
    idRenderSystem::Shutdown()
    Sys_Error: Couldn't load default.cfg
    
    (excluded the rest as it's just repeated for the other 2 runs)
    
    ######################################
    Doom 3:
    Resolution: 1280 x 1024 - Quality: Low
    
    
    Average: 0.00 Frames Per Second
    ######################################
    I googled a bit for this error, and the most common suggestions were:
    - update graphics drivers. I'm running the latest nvidia 180.29 drivers. Other tests (lightsmark, et) are working fine.
    - that the pak files hadn't been copied from a windows install. But the PTS downloaded these, and there's several in the base directory, so I can't tell if this is relevant.

    I'm running the tests as user (not root), though don't expect that would be a problem. Permissions look fine.

    Some other info from PTS:
    Code:
    $ phoronix-test-suite list-installed-tests
    
    =====================================
    Phoronix Test Suite - Installed Tests
    =====================================
    
    doom3              - Doom 3                        
    et                 - Enemy Territory               
    lightsmark         - Lightsmark                    
    quake4             - Quake 4                       
    
    $ phoronix-test-suite system-info
    
    
    ====================================
    Phoronix Test Suite v1.6.0 (TYDAL)
    System Information
    ====================================
    
    Hardware:
    Processor: Intel Core 2 Duo CPU T7700 @ 2.40GHz (Total Cores: 2), Motherboard: Dell MXG071, Chipset: Intel Mobile PM965/GM965/GL960 + ICH8M-E, System Memory: 3954MB, Disk: 2 x 160GB ST9160823AS, Graphics: GeForce 8700M GT 512MB (625/800MHz), Screen Resolution: 1920x1200
    
    Software:
    OS: Ubuntu 8.04, Kernel: 2.6.24-23-generic (x86_64), Desktop: GNOME 2.22.3, Display Server: X.Org Server 1.4.0.90, OpenGL: 3.0.0 NVIDIA 180.29, Compiler: GCC 4.2.4, File-System: ext3
    
    $ phoronix-test-suite diagnostics
    
    ====================================
    Phoronix Test Suite v1.6.0 (TYDAL)
    Diagnostics Dump
    ====================================
    
    PTS_VERSION = 1.6.0
    PTS_CODENAME = TYDAL
    PTS_TYPE = DESKTOP
    S_TEST_OPTIONS_MENU_GROUP_NAME = Entry/Name
    S_TEST_OPTIONS_MENU_GROUP_VALUE = Entry/Value
    S_RESULTS_RESULTS_GROUP_IDENTIFIER = Group/Entry/Identifier
    S_RESULTS_RESULTS_GROUP_VALUE = Group/Entry/Value
    S_RESULTS_RESULTS_GROUP_RAW = Group/Entry/RawString
    DEFAULT_VIDEO_RAM_CAPACITY = 128
    TYPE_TEST = TEST
    TYPE_OS_TEST = OS_TEST
    TYPE_TEST_SUITE = TEST_SUITE
    TYPE_LOCAL_TEST = LOCAL_TEST
    TYPE_LOCAL_BASE_TEST = LOCAL_TEST
    TYPE_OS_LOCAL_TEST = OS_LOCAL_TEST
    TYPE_LOCAL_TEST_SUITE = LOCAL_TEST_SUITE
    TYPE_SCTP_TEST = LOCAL_SCTP_TEST
    TYPE_BASE_TEST = BASE_TEST
    TYPE_VIRT_SUITE_SUBSYSTEM = VIRT_SUITE_SUBSYSTEM
    TYPE_VIRT_SUITE_ALL = VIRT_SUITE_ALL
    PTS_MODULE_UNLOAD = PTS_MODULE_UNLOAD
    PTS_QUIT = PTS_QUIT
    PTS_DIR = /usr/share/phoronix-test-suite/
    PTS_USER_DIR = /home/wiresquire/.phoronix-test-suite/
    XML_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-xml/
    SCRIPT_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-scripts/
    ETC_DIR = /usr/share/phoronix-test-suite/pts/etc/
    MODULE_DIR = /usr/share/phoronix-test-suite/pts-core/modules/
    RESULTS_VIEWER_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/
    TEST_LIBRARIES_DIR = /usr/share/phoronix-test-suite/pts-core/test-libraries/
    STATIC_DIR = /usr/share/phoronix-test-suite/pts-core/static/
    FONT_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/fonts/
    XML_PROFILE_DIR = /usr/share/phoronix-test-suite/pts/test-profiles/
    XML_PROFILE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-profiles/
    XML_SUITE_DIR = /usr/share/phoronix-test-suite/pts/test-suites/
    TEST_RESOURCE_DIR = /usr/share/phoronix-test-suite/pts/test-resources/
    TEST_RESOURCE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-resources/
    XML_PROFILE_LOCAL_DIR = /home/wiresquire/.phoronix-test-suite/test-profiles/
    XML_PROFILE_LOCAL_CTP_BASE_DIR = /home/wiresquire/.phoronix-test-suite/test-profiles/base/
    XML_SUITE_LOCAL_DIR = /home/wiresquire/.phoronix-test-suite/test-suites/
    TEST_RESOURCE_LOCAL_DIR = /home/wiresquire/.phoronix-test-suite/test-resources/
    TEST_RESOURCE_LOCAL_CTP_BASE_DIR = /home/wiresquire/.phoronix-test-suite/test-resources/base/
    PTS_TEMP_DIR = /tmp/phoronix-test-suite/
    PHP_BIN = php5
    PTS_INIT_TIME = 1234401622
    OPERATING_SYSTEM = Linux
    OS_PREFIX = linux_
    TEST_ENV_DIR = /home/wiresquire/.phoronix-test-suite/installed-tests/
    SAVE_RESULTS_DIR = /home/wiresquire/.phoronix-test-suite/test-results/
    SCTP_DIR = /home/wiresquire/.phoronix-test-suite/sctp/
    PTS_DOWNLOAD_CACHE_DIR = /home/wiresquire/.phoronix-test-suite/download-cache/
    
    End-User Run-Time Variables:
    VIDEO_RESOLUTION = 1920x1200
    VIDEO_CARD = GeForce 8700M GT 512MB
    VIDEO_DRIVER = 3.0.0 NVIDIA 180.29
    OPERATING_SYSTEM = Ubuntu 8.04
    PROCESSOR = Intel Core 2 Duo CPU T7700 @ 2.40GHz
    MOTHERBOARD = Dell MXG071
    CHIPSET = Intel Mobile PM965/GM965/GL960 + ICH8M-E
    KERNEL_VERSION = 2.6.24-23-generic
    COMPILER = GCC 4.2.4
    HOSTNAME = m1730
    
    Environmental Variables (accessible via test scripts):
    PTS_TYPE = DESKTOP
    PTS_VERSION = 1.6.0
    PTS_CODENAME = TYDAL
    PTS_DIR = /usr/share/phoronix-test-suite/
    FONT_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/fonts/
    PHP_BIN = php5
    NUM_CPU_CORES = 2
    NUM_CPU_JOBS = 4
    SYS_MEMORY = 3954
    VIDEO_MEMORY = 512
    VIDEO_WIDTH = 1920
    VIDEO_HEIGHT = 1200
    VIDEO_MONITOR_COUNT = 1
    VIDEO_MONITOR_LAYOUT = CENTER
    VIDEO_MONITOR_SIZES = 1920x1200
    OPERATING_SYSTEM = ubuntu
    OS_VERSION = 8.04
    OS_ARCH = x86_64
    OS_TYPE = Linux
    THIS_RUN_TIME = 1234401622
    All of this seems to be correct.
    Can anyone help get this doom3 benchmark to work?

    TIA
    ws

  2. #2

    Default

    Did you copy your Doom 3 game files from the disc? Doom 3 requires the retail game files in order to work.

  3. #3
    Join Date
    Feb 2009
    Posts
    3

    Default

    So you're saying I need to buy the game to run the phoronix test suite benchmark for doom3? I didn't see that in the docs anywhere?

    ws

  4. #4

    Default

    Quote Originally Posted by wiresquire View Post
    So you're saying I need to buy the game to run the phoronix test suite benchmark for doom3? I didn't see that in the docs anywhere?

    ws
    Correct. I should make it more clear in the docs as well. It's like that for Doom 3, ET:QW (aside from etqw-demo), and Quake 4.

  5. #5
    Join Date
    Feb 2009
    Posts
    3

    Default

    OK - thanks for the fast replies.

    Happy testing
    ws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •