Results 1 to 5 of 5

Thread: Debian Lenny ATI HD 3450 AGP Ati proprietary drivers

  1. #1
    Join Date
    Feb 2009
    Posts
    1

    Default Debian Lenny ATI HD 3450 AGP Ati proprietary drivers

    Hello everybody
    I'm new to this forum so I apologize if I miss something important...
    I have a Debian Lenny installed on P4 2.6 GHZ 512 Mb RAM and now
    I have bought an ATI HD 3450 AGP and 'lspci' tells me:
    "01:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE AGP [Radeon HD 3450]"
    Now I have it working with the radeonhd 1.2.4 driver and mesa libs but unfortunately
    it doesn't seem to support 3D acceleration...
    from Xorg.log:
    I had to install the latest 1.2.4 version because of my card chipset ID, which
    wasn't recognized as an RV620 card with previous versions (i.e. 1.2.1)
    from Xorg.log:
    (II) PCI: 01:00:0: chip 1002,95c6 card 1043,0028 rev 00 class 03,00,00 hdr 80
    It seems clear that at the moment there is no alternative: I have to use proprietary drivers but
    with ATI CAtalyst driver from debian distribution and with the one from AMD site
    (https://a248.e.akamai.net/f/674/9206...x86.x86_64.run)
    as well after making xorg.conf with aticonfg and start Gnome Desktop Environment and everything seems to be fine but when I try to execute glx utils (i.e. glxgears) or try to watch a videofile the xserver freezes and my keyboard doesn't respond and all I have left is to push reset button.
    If anyone has any idea or solution please post!

    Thank you

  2. #2

    Default

    The packaging scripts for Catalyst drivers 9.1 and 9.2 seem to be broken on Debian Lenny, and as of 9.2, Debian Etch as well.

    The quick fix we found for Mepis 8 is to use the SGFXI script from SMXI with the force command.

    Installation and configuration on Debian Pure should be identical to Mepis 8.

    1 : start from ground zero. You want all of the previous driver information and install files to be gone, and you want to be on the VESA driver. If you have to, reinstall while keeping your /home directory.

    2 : open up your terminal and switch to root

    3 : copy this command into the terminal : cd /usr/local/bin && wget -Nc smxi.org/smxi.zip && unzip smxi.zip

    you should get a download and unzip message.

    4 : enter the command : telinit 3

    This should kill X and put you at the command prompt.

    5 : login as root

    If you haven't done it since you installed, now is a good time to do an apt-get update

    6 : type the command : sgfxi -f

    7 : hit enter at all the prompts.


    When you finish, reboot or start X, and the driver should be loaded properly.

  3. #3
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    212

    Default

    Quote Originally Posted by Saist View Post
    4 : enter the command : telinit 3

    This should kill X and put you at the command prompt.

    5 : login as root
    The default runlevel of Debian is 2. 3 will still have a gui enabled.

    From root if you issue the command "/etc/init.d/gdm stop", that will kill X for you.

  4. #4
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Or:

    Reset xorg.conf to a well known state:

    rm /etc/X11/xorg.conf*
    dpkg-reconfigure -phigh xserver-xorg

    Then execute my script - will kill X and start X automatically:

    http://kanotix.com/files/install-fglrx-debian.sh

    If the driver is working with your card, then my script will work. As side effect it also enables dkms which is usefull when a new kernel is installed.

  5. #5

    Default

    (wishes Phoronix had a thanks button for posts like Kano's)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •