Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Radeon X1650: How to enable Compiz

  1. #1
    Join Date
    Jan 2009
    Posts
    25

    Question Radeon X1650: How to enable Compiz

    Hi guys. I wanted Compiz running in my desktop, but I didn't want to use privative drivers. So, after reading these forums a bit, I've got a Radeon X1650.

    I've changed the Xorg driver to "ati", and added some other options to xorg.conf file in order to enable diret rendering and friends. Now the desktop seems to be rendered faster, but Compiz doesn't want to work.

    I have Fedora 9, so I go to menu > System > Preferences > Visualizacion y comportamiento > Desktop effects, and I click on "Enable Desktop Effects" (that should mean "enable Compiz"). After some seconds of thinking, a response is shown: "Desktop effects could not be enabled"

    Probably I'm missing some options in xorg.conf file. Do you know which ones?

    [Continues in next comment]

  2. #2
    Join Date
    Jan 2009
    Posts
    25

    Question

    This is my xorg.conf file:

    Code:
    # Xorg configuration created by system-config-display
    
    Section "ServerLayout"
    	Identifier     "single head configuration"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
            # Option         "AIGLX"     "True"
    
    EndSection
    
    Section "InputDevice"
    # keyboard added by rhpxl
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "es"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	ModelName    "LCD Panel 1280x1024"
    	Option	    "DPMS"
    
            HorizSync    30.0 - 83.0
            VertRefresh  56.0 - 76.0
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "ati"
            # Option      "AccelMethod"           "XAA"
            Option      "AccelMethod"           "EXA"
    
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    My lspci for the card:

    Code:
    # lspci | grep -i radeon
    03:00.0 VGA compatible controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)
    03:00.1 Display controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)

    [Continues on next comment]

  3. #3
    Join Date
    Jan 2009
    Posts
    25

    Question

    Well, I wanted to post in this comment my last xorg log (Xorg.0.log), but it's too big for the forum engine. If you need some part of the file, please tell me.

    Thank you for your help, and for your hard work on free software drivers.

  4. #4
    Join Date
    May 2007
    Posts
    352

    Default

    Never start compiz that way on Fedora :-) It doesn't use the ccp plugin by default, which means that you can't actually use ccsm to configure compiz.

    I would recommend installing compiz-manager (available via yum). Then bring up a terminal and run 'compiz-manager &'. Show us the output.

    Also, please show us the output of 'glxinfo | grep -i renderer'.

    Adam

  5. #5
    Join Date
    Jan 2009
    Posts
    25

    Default

    Thank you, adamk.

    There are the outputs, run as normal user:

    Code:
    $ compiz-manager 
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 03:00.0 0300: 1002:71c7 (rev 9e) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1280x1024) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: not present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    Starting gtk-window-decorator
    /usr/bin/compiz (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
    /usr/bin/compiz (core) - Fatal: No manageable screens found on display :0.0
    
    ^C
    Code:
    $ glxinfo | grep -i renderer
    OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX+/3DNow!+/SSE2 TCL
    After the first one (compiz-manager), no window is openned, so I have to press control-C to recover control.

    In the second one (glxinfo), MESA seems to be an old version (1006-08-15 ?), so I've listed the mesa RPMs:

    Code:
    $ rpm -qa | grep -i mesa
    mesa-libGLw-6.5.1-5.fc9.i386
    mesa-libGLw-devel-6.5.1-5.fc9.i386
    mesa-libGLU-7.1-0.37.fc9.i386
    mesa-libGL-7.1-0.37.fc9.i386
    mesa-dri-drivers-7.1-0.37.fc9.i386
    mesa-libGL-devel-7.1-0.37.fc9.i386
    mesa-libGLU-devel-7.1-0.37.fc9.i386
    Apparently all MESA packages are related to Fedora 9, so I can't understand how the glxinfo says 2006-08-15. Maybe some config file is old?

  6. #6
    Join Date
    May 2007
    Posts
    352

    Default

    Don't worry about the date on the Mesa render string. That's actually normal. The developers are bit lazy about updating that :-)

    Your drivers are fine... The real issue is that you have another compositing manager running already, and it's refusing to hand control over to compiz. Make sure that gconf-editor --> apps/metacity/general/compositing_manager is disabled, and that you are not using xcompmgr. Then try starting compiz again with compiz-manager.

    Adam

  7. #7
    Join Date
    Jan 2009
    Posts
    25

    Smile

    adamk, you are greeeeeaaaaaaaaaaat!!

    The "compositing_manager" option at gconf-editor was enabled, so disabled it, and X server got frozen, so I rebooted the computer. Then, I tested "compiz-manager" again and... Compiz works!

    Now Fedora's "Enable Desktop Effects" tool also works, and makes Compiz permanent (no more "compiz-manager" command required after log-in).

    Thank you very much. Now I'm going to explore all infinite Compiz options

  8. #8
    Join Date
    Sep 2007
    Location
    Connecticut,USA
    Posts
    953

    Default

    Quote Originally Posted by phoroni View Post
    adamk, you are greeeeeaaaaaaaaaaat!!

    The "compositing_manager" option at gconf-editor was enabled, so disabled it, and X server got frozen, so I rebooted the computer. Then, I tested "compiz-manager" again and... Compiz works!

    Now Fedora's "Enable Desktop Effects" tool also works, and makes Compiz permanent (no more "compiz-manager" command required after log-in).

    Thank you very much. Now I'm going to explore all infinite Compiz options
    Wonder if it is possible for compiz to ask to disable the offending compositing manager if it finds one already enabled? If user chooses Yes, then the compositing manager is disabled to allow compiz-manager to start up. Otherwise why not just exit gracefully?

  9. #9
    Join Date
    May 2007
    Posts
    352

    Default

    It does ask the compositing manager to hand over control. Metacity is stupid, and refuses :-)

    Adam

  10. #10
    Join Date
    Jan 2009
    Posts
    25

    Default

    Hi guys (again).

    Just to tell you that Compiz was ok in Fedora 9, but upgraded to Fedora 10, and I had to disable Compiz, because the desktop got slower (window management, firefox scroll, mplayer, etc). After disabling Compiz, speed is normal again, but I'm missing Compiz effects.

    I didn't change any config, I only upgraded Fedora from 9 to 10. Do you know if this version has any problem with Compiz?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •