I have an asus "M2A-VM HDMI".

I got a gentoo on that mobo, and got a tv as output with hdmi, using fglrx.

Sometimes the screen is blue (as "no signal") at startup. The "blue status" survives the reboot, so i have to poweroff the pc and restart it, then it works.

I have kdm running at startup with autologin to an user, and I give commands usually with ssh from another pc.

The screen is an "HD Ready" TV, so the resolution inside xorg.conf is set to 1280x720.

No configuration changes between "blue status" and "normal work". Nor the log (as it seems)

Today it stopped completely to work, only blue screen. I tried to update the ati-driver (gentoo's fglrx package), the kernel (from 2.6.25 to 2.6.27) and tried even radeonhd and radeon. No luck.

A strange problem happened when I tried to revert to pre-update status.
This happens when the computer is switched off for 10 minutes circa.
The monitor shows on the osd that it's receiving a black 720p signal for a short time, then it returns on the console. seems X starts, then there is a message on the log saying
"(II) fglrx(0): Shutdown CMMQS"
then (or before, can't tell) kdm goes in timeout and kills the attempt of X to startup.
Further attempts (even after a reboot) go to the "blue screen" status.

Is there anyone who can understand what it's happening?

Unfortunately I overwritten the xorg.conf and logs of when it worked, but I can provide logs of the actual status.