Results 1 to 6 of 6

Thread: rv350 freezes without usb (fglrx 8.582)

Threaded View

  1. #1
    Join Date
    Oct 2007

    Default rv350 freezes without usb (fglrx 8.582)

    I have a notebook with a Radeon Mobility 9700.
    I'm running Ubuntu 8.10 and installed the new Catalyst 9.2 driver.

    I'm glad it supports r300 cards again...
    ...though I have some issues.

    As long as I have a USB mouse plugged in the system runs quiet stable. Booting without or unplugging leads to a complete system freeze within seconds.
    Standby and suspend will freeze system too. Problems with switching to console, switching users, new x sessions.

    I can't find anything unusual in the logs...
    ...there is an error and some not implemented
    $ cat /var/log/Xorg.0.log | grep "(WW)\|(EE)\|(NI)\|(??)"
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    (WW) Falling back to old probe method for fglrx
    (WW) This ATI Proprietary Linux Driver does not guarantee support of video driver ABI higher than 2.0
    (WW) Video driver ABI version of the X server is 4.1
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (EE) fglrx(0): Unknown EDID version 0
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled
    (NI) fglrx(0): ASIC Family ID/Name:46/M10 
    (NI) fglrx(0): ASIC Rev ID/Name:4/Not RV6xx family Device 
    (NI) fglrx(0): ASIC Device ID/Name:0X4E50/Not RV6xx family Device 
    (NI) fglrx(0): CPLIB is initialized.
    (WW) fglrx(0): Option "VendorName" is not used
    (WW) fglrx(0): Option "ModelName" is not used
    (WW) AIGLX: 3D driver claims to not support visual 0x23
    (WW) AIGLX: 3D driver claims to not support visual 0x72
    but there is no difference between booting with or without usb mouse.
    Unplugging leads to a last entry in syslog
    Feb 21 13:41:56 gizmo kernel: [ 2254.240095] usb 1-1: USB disconnect, address 3
    but nothing more.

    This behavior is also known with the open source driver radeon, there are quiet a lot of bug reports on the net, for eample:
    And very often it has to do with mobility radeon 9700 or similar cards. Also the same problems with fglrx driver are mentioned.
    As far as I understood there seems to be problems between AGP V3 (supported by card) and AGP V2 (supported by bord and therefor forced AGP Mode x4).
    I don't know if this is a kernel issue just triggered by graphic drivers or graphic card issue or a hardware incompatibility,
    but the solution/workaround with radeon driver was to force AGP Mode x1.

    Using radeon driver the last months this solution worked for me with similar symptoms.

    I tried to force AGP Mode x1 with fglrx
    Option	"AGPMask"	"0x00000006"
    without success.
    (WW) fglrx(0): Option "AGPMask" is not used
    How can I get AGP Mode x1 with fglrx?
    Has someone any ideas what the real reason for this problem could be?
    Or is there maybe another already known solution?

    If you need more detailed logs or configurations just say and I'll post them...

    Last edited by Ren Höek; 02-21-2009 at 11:04 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts