Page 18 of 19 FirstFirst ... 816171819 LastLast
Results 171 to 180 of 186

Thread: AMD solve the Wine Problem with Cat/Fglrx 9-4alpfa

  1. #171
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by poofyyoda View Post
    I haven't had breakages on any game in wine since the upgrade.
    Did you patch your wine with this?
    http://bugs.winehq.org/show_bug.cgi?id=13335

    If not. What wine version do you use?

  2. #172
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    Quote Originally Posted by tball View Post
    Did you patch your wine with this?
    http://bugs.winehq.org/show_bug.cgi?id=13335

    If not. What wine version do you use?

    No patch, just wine 1.1.16, I'm trying 1.1.17 now.

  3. #173
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by poofyyoda View Post
    No patch, just wine 1.1.16, I'm trying 1.1.17 now.
    Hmm what games have you tried?

    What works for me:
    Homeworld 2, revolt.

    What does not:
    Counter-strike, day of defeat and Rune.


    All my native ones run beautiful.

  4. #174
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    Using Radeon HD4650, Wine 1.1.17


    Quote Originally Posted by tball View Post
    Hmm what games have you tried?
    Works:
    CNC3, Homeworld2, Battlezone2, EAW, Age of Mythology


    Doesn't (never worked before either):
    System shock2(unplayable - texture distortions, slow), crysis, cnc renegade(big slowdowns)

    New:
    Alt+F4 in Jedi Academy = X restart

  5. #175
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by poofyyoda View Post
    Using Radeon HD4650, Wine 1.1.17




    Works:
    CNC3, Homeworld2, Battlezone2, EAW, Age of Mythology


    Doesn't (never worked before either):
    System shock2(unplayable - texture distortions, slow), crysis, cnc renegade(big slowdowns)

    New:
    Alt+F4 in Jedi Academy = X restart
    What distro are you running? Are you able to try counter-strike?

  6. #176
    Join Date
    Jun 2008
    Location
    New Zealand
    Posts
    68

    Default

    Quote Originally Posted by tball View Post
    What distro are you running? Are you able to try counter-strike?
    Ubuntu 8.10

    I do have CS: condition zero, which I copied from school a few years ago,,
    I'll try it out soon

    edit: sorry, crc error -- cheap backup cds
    Last edited by poofyyoda; 03-16-2009 at 05:54 PM.

  7. #177
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by poofyyoda View Post
    Ubuntu 8.10

    I do have CS: condition zero, which I copied from school a few years ago,,
    I'll try it out soon

    edit: sorry, crc error -- cheap backup cds
    thx for trying

  8. #178
    Join Date
    Mar 2009
    Posts
    68

    Default

    I've just upgraded my Debian kernal to 2.6.29 and the ati-driver-installer-8.60_RC1-x86.x86_64.run; fails to install. Dang!

    Error msg follows, in the hope it may do some good :-)

    <snip>
    (II) Module vbe: vendor="X.Org Foundation"
    compiled for 1.4.2, module version = 1.1.0
    ABI class: X.Org Video Driver, version 2.0
    (II) fglrx(0): VESA BIOS detected
    (II) fglrx(0): VESA VBE Version 3.0
    (II) fglrx(0): VESA VBE Total Mem: 16384 kB
    (II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
    (II) fglrx(0): VESA VBE OEM Software Rev: 11.3
    (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc.
    (II) fglrx(0): VESA VBE OEM Product: RV770
    (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
    (II) fglrx(0): ATI Video BIOS revision 9 or later detected
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: Searching for BusID PCI:1:0:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card1
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card2
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card3
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card4
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card5
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card6
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card7
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card8
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card9
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card10
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card11
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card12
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card13
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    drmOpenDevice: node name is /dev/dri/card14
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: open result is -1, (No such device or address)
    drmOpenDevice: Open failed
    drmOpenByBusid: drmOpenMinor returns -6
    (WW) fglrx(0): Failed to open DRM connection
    (--) fglrx(0): Video RAM: 524288 kByte, Type: GDDR5
    (EE) fglrx(0): [FB] Can not get FB MC address range.
    (II) fglrx(0): PCIE card detected
    (--) fglrx(0): Using per-process page tables (PPPT) as GART.
    (II) fglrx(0): board/chipset is supported by this driver (original ATI board)
    (II) Loading sub module "ddc"
    (II) LoadModule: "ddc"(II) Module "ddc" already built-in
    (II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000080, disabled=0x00000000
    (II) fglrx(0): Connected Display1: DFP on secondary TMDS [tmds2i]
    (II) fglrx(0): Display1 EDID data ---------------------------
    (II) fglrx(0): Manufacturer: DEL Model: 4035 Serial#: 876033100
    (II) fglrx(0): Year: 2008 Week: 24
    (II) fglrx(0): EDID Version: 1.3
    (II) fglrx(0): Digital Display Input
    (II) fglrx(0): Max H-Image Size [cm]: horiz.: 65 vert.: 41
    (II) fglrx(0): Gamma: 2.20
    (II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
    (II) fglrx(0): First detailed timing is preferred mode
    (II) fglrx(0): redX: 0.678 redY: 0.309 greenX: 0.210 greenY: 0.692
    (II) fglrx(0): blueX: 0.146 blueY: 0.055 whiteX: 0.313 whiteY: 0.329
    (II) fglrx(0): End of Display1 EDID data --------------------
    (WW) fglrx(0): Only one display is connnected,so single mode is enabled

    (II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 65536
    (==) fglrx(0): UseFastTLS=0
    (==) fglrx(0): BlockSignalsOnLock=1
    (II) fglrx(0): Direct rendering disabled
    (--) Depth 24 pixmap format is 32 bpp
    (II) do I need RAC? No, I don't.
    (II) resource ranges after preInit:

    (II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
    (WW) fglrx(0): could not detect X server version (query_status=-1)
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed! *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO) *
    (WW) fglrx(0): * no 3D acceleration available *
    (WW) fglrx(0): ********************************************* *
    (II) fglrx(0): FBADPhys: 0x0 FBMappedSize: 0x10000000
    (==) fglrx(0): Write-combining range (0xc0000000,0x10000000)
    (II) fglrx(0): FBMM initialized for area (0,0)-(2560,8191)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(2560,1600) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 2560 x 6591
    (==) fglrx(0): Backing store disabled
    (II) Loading extension FGLRXEXTENSION
    (II) Loading extension ATITVOUT
    (**) fglrx(0): DPMS enabled
    (WW) fglrx(0): Textured Video not supported without DRI enabled.
    (WW) fglrx(0): Video Overlay not supported on AVIVO based graphics cards. For XVideo support use Option "TexturedVideo".
    (II) LoadModule: "glesx"
    (II) Loading /usr/lib/xorg/modules//glesx.so
    (II) Module glesx: vendor="X.Org Foundation"
    compiled for 7.1.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension GLESX
    (II) fglrx(0): GLESX enableFlags = 74
    (II) fglrx(0): Acceleration enabled
    (II) LoadModule: "amdxmm"
    (II) Loading /usr/lib/xorg/modules//amdxmm.so
    (II) Module amdxmm: vendor="X.Org Foundation"
    compiled for 7.1.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
    (EE) fglrx(0): XMM failed to open CMMQS connection.
    (II) fglrx(0): XMM failed to initialize!
    (II) fglrx(0): Enable composite support successfully
    (WW) fglrx(0): Option "VendorName" is not used
    (WW) fglrx(0): Option "ModelName" is not used
    ing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    (II) AIGLX: Screen 0 is not DRI capable
    [glesx] __glESXExtensionInit: No GL ES2.0 capable screen found!
    (EE) fglrx(0): PPLIB: PPLIB is not initialized!.
    (EE) fglrx(0): PPLIB: swlPPLibNotifyEventToPPLib() failed!
    (EE) fglrx(0): ulEventType = 0000000c, ulEventData = 00000001
    <snip>

    HTH Bridgeman.

    May I suggest, you have some sort of a sys.chkr app, to help you get the right sort of info to yourgoodselves 2 debug?

    *BFN*

    GreekGeek :-)

  9. #179
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,403

    Default

    For a kernel-related issue like this the most useful messages are usually in the dmesg output.

  10. #180
    Join Date
    Mar 2009
    Posts
    68

    Default

    Hi Bridgeman,

    oh, I did not grok what kind of an error twas.

    I've gone back to 2.6.26 + fglrx for now.

    I will recreate and grab the dmseg thing then & post.

    GreekGeek :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •