Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Noise in whites of s-video output

  1. #1
    Join Date
    Mar 2009
    Posts
    2

    Default Noise in whites of s-video output

    I have an ATI Radeon 9500 Pro (R300) video card in a PC that I am trying to setup to play movies and maybe some games on a standard definition NTSC TV.

    I am running the radeon driver under a Kubuntu Jaunty alpha release. I upgraded to Jaunty from Intrepid today hoping that a new radeon driver or Xorg might solve my problem, but it didn't help.

    The problem I am experiencing is noise in the whites on my screen. It's not related to any specific app. Anywhere there is white, there is noise.

    Is there anything I can do to fix this?

  2. #2
    Join Date
    Dec 2006
    Posts
    112

    Default

    Quote Originally Posted by dfrey View Post
    Is there anything I can do to fix this?
    For movies, you can lower the brightness by about 10% (on your computer, not your tv).

  3. #3
    Join Date
    Mar 2009
    Posts
    2

    Default

    I also have this problem. Is there any way (other than reducing brightness in Mplayer) to fix this? Are there any apps which can control brighness values for TV-out?
    I do not have this problem with fglrx driver but would rather use radeon driver.

  4. #4
    Join Date
    Jul 2007
    Posts
    403

    Default

    Probably the driver is not correctly clipping the output brightness level to the proper level for NTSC. This would be relatively simple to fix, but it requires someone who knows the driver code and has a bit of time (neither of which, alas, applies to me.)

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,434

    Default

    Are you using overlay or textured video ? Whichever you are using, can you try the other method ?

  6. #6
    Join Date
    Dec 2007
    Posts
    2,360

    Default

    This is a known issue with tv-out on older chips:
    http://bugs.freedesktop.org/show_bug.cgi?id=13872

    probably something with the colorspace conversion in the tv encoder setup.

  7. #7
    Join Date
    Dec 2006
    Posts
    112

    Default

    Quote Originally Posted by bridgman View Post
    Are you using overlay or textured video ? Whichever you are using, can you try the other method ?
    The noise is there with both. In fact,it is there with every kind of X output. And unfortunately, Textured Video still has no brightness control, so my workaround doesn't even work with that.

  8. #8
    Join Date
    Mar 2009
    Posts
    31

    Default

    I use
    Code:
    xvattr -a XV_BRIGHTNESS -v -30
    (or the graphical equivalent) to get around this. Unfortunately, it seems to reset itself each time a new overlay is started. If anyone knows how to make this setting stick it would be helpful, though it still wouldn't fix the noise for things like flash.

  9. #9
    Join Date
    Dec 2007
    Posts
    2,360

    Default

    This should be fixed now in xf86-video-ati git master:
    http://cgit.freedesktop.org/xorg/dri...50979f099a17a8

  10. #10
    Join Date
    Dec 2006
    Posts
    112

    Default

    Quote Originally Posted by agd5f View Post
    This should be fixed now in xf86-video-ati git master:
    http://cgit.freedesktop.org/xorg/dri...50979f099a17a8
    Yes, the noise is gone. Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •