Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Poor performance with 8.6 on Ubuntu Jaunty with Radeon Mobility HD 3470

  1. #11
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    Quote Originally Posted by peppo View Post
    The package version is 2:8.600-0ubuntu1, OpenGL version string: 2.1.8575 and amdcccle reports 8.60.40

    bridgman: no, no DRM errors or anything similar in Xorg.0.log... the only message after monitor probing is:

    swlDalGetDisplayIndex:ERROR: The number of Active Displays is 0
    [ 5136.852433] (II) fglrx(0): atiddxDisplayScreenLoadPalette: numColors: 256

    When you speak about drm, you're referring to the free drivers? I'm keen to get fglrx working properly, as I have gathered this is the driver that would give best performance?
    There is a "drm" (aka kernel driver) component to fglrx as well; we use as much of the DRI framework as possible.

    Quote Originally Posted by peppo View Post
    And I feel I should ask... I've not used anything but GNU/Linux on this machine, but is the hardware capable of driving a compositing desktop? I figure it should be, since it came with some version of Vista, where, in the few minutes I ran it before installing Jaunty, it seemed to perform OK.
    It should be fine; I have a 3450 in my home system and it handles compositing just fine, but some people are showing up with humongous monitors these days and I'm not sure how it would perform on a 3000x2000 display, for example. Probably would be fine as well, just not sure. I was just trying to think of all the possibilities.

    Can you pastebin your log and dmesg output ?

    Quote Originally Posted by peppo View Post
    So... can the Mobility HD 3470 handle basic compositing tasks? My guess would be absolutely, but these drivers are either very very slow or there is some other issue that I have to figure out!
    Yeah, should be fine, it sounds like you have little or no acceleration for some reason, no idea why but maybe clues in logs etc...

    Quote Originally Posted by peppo View Post
    Edit: I should clarify I was using fglrx here. I've now also tried xf86-video-ati 6.12.1 and latest drm and 2D acceleration is piss poor to non existant, and xvideo does NOT work... ugh.
    If you don't have Xv then the driver and/or drm probably wasn't installed right. Are you sure you got drm from the 6xx-7xx support branch ?

  2. #12
    Join Date
    Jan 2008
    Posts
    7

    Default 9.4 Still work well on my machine ...

    Indeed 9.2 was faster ( ~5500 FPS with glxgears ) - now I have only 2000 - 2100 FPS with glxgears.

    ..but visually you can't observe the difference - the same for games, ETQW-Demo, Doom3-Demo and Quake4-Demo - all goes gold.

    About hardware

    GPU = Radeon HD 2600 Pro 512Mb RAM on PCI Express
    CPU = Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz with 6Mb L2 cache
    RAM = 2Gb

  3. #13
    Join Date
    Dec 2007
    Posts
    143

    Default

    Hi,

    Firstly ensure you update all the Jaunty packages as they are changing daily.

    sudo apt-get update
    sudo apt-get upgrade

    or use Update Manager or Synaptic

    Try this, through Synaptic completely uninstall FGLRX. Open a terminal and remove /etc/X11/xorg.conf

    run sudo dpkg-reconfigue -phigh xserver-xorg

    Then edit the new xorg.conf so that the Device section looks like this


    Section "Device"
    Identifier "Configured Video Device"
    Driver "ati"
    Option "AccelMethod" "exa"
    Option "DRI" "on"
    EndSection

    Then restart. This should give you good 2d and xv, but no 3d or compiz.

    Open a terminal and run xvinfo to ensure it is all working.

    Once this is verified as working, give fglrx another shot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •