Results 1 to 2 of 2

Thread: Legacy SW Issues with Intel Driver (White displays as black on screen)

  1. #1
    Join Date
    Mar 2009
    Posts
    2

    Default Legacy SW Issues with Intel Driver (White displays as black on screen)

    Hi,

    I've been trying to get a couple of x-terminals setup for a customer. The software they are running requires 8-bit color depth, however the drivers provided with Fedora Core 8 display anything that is supposed to be white as black. After applying all of the updates to bring FC8 up to date, the only changes to config files made are:

    /etc/X11/xorg.conf
    setting the 8-bit color depth as the default depth/depth
    setting the dpms monitor option
    turning the backingstore videocard option on
    setting the fontpath to the remote server

    and

    /etc/gdm/custom.conf

    0:Terminal -query <host>

    Everything else is "as-is"

    Another thing: switching to another VT and then back to X causes the areas which are supposed to be white to be white, with the exception of "stroke" around some text and the cursor.

    The machines are all Dell Optiplex 360 PCs with Intel G33 integrated graphics.

    Anyone have any ideas? I've tried disabling acceleration, turning on Dac6Bit, enabling legacy3d, and nothing has worked

    Thanks in advance
    Last edited by DougK; 03-31-2009 at 05:36 PM.

  2. #2
    Join Date
    Mar 2009
    Posts
    2

    Default

    when looking through the xorg.conf manpages, I came across the Visual entry. When I set it to TrueColor or StaticColor, the display "looks" right (Elements that should be white are white) but it is in grayscale mode. DirectColor makes the color all messed up, but in color at any rate.

    I don't know if this will help or not, but I thought I would throw it out there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •