Page 14 of 16 FirstFirst ... 41213141516 LastLast
Results 131 to 140 of 154

Thread: AMD Catalyst 9.3 Brings OpenGL Composite Support

  1. #131
    Join Date
    Mar 2009
    Posts
    211

    Default

    Well, I hope that bridgman or some other ATI guys reads this, but I just upgraded to catalyst 9.3 today and turned compiz/beryl back on in Ubuntu 8.10, which worked out OK.

    However, I then left my notebook sitting long enough for it to suspend, and it froze at the password dialog box to log in. CTRL-ALT-BACKSPACE wouldn't kill X11, and other key combos including blindly attempting entering the pw failed to produce any results, so I was forced to poweroff. (I was unable to ssh in to see if the machine was still up as my desktops are down ATM until I have time to check them over.)

    Prior to this, I had thought that something I added or something with fixing the hdd laptop killer bug in 8.10 fixed the resume from suspend problem. It would now seem that turning compiz/beryl OFF is what fixed it.

    hw is MSI GT725-074US + x86-64 Ubuntu 8.10

    X3 Reunion under wine is also turning up black textures all over the place(some things render OK, others are just big black things) and main menu text does not render, if anyone cares. (Trying to see if there's any additional workarounds, as adding some wine Direct3D specific entries helped it a little, as in originally the lower left corner of the display was a big black rectangle.)
    (wine 1.1.18 + 2.6.27-11 kernel + Cat 9.2/3 + X3R v2.5)

    (X2 linux native rendered fine under 9.2, plus some simpler (non-shader requiring)windows games run under wine rendered fine.)

  2. #132
    Join Date
    Apr 2009
    Posts
    6

    Default

    Kind of the same trouble here, random hard freezes requiring shutdown...
    Tested extensively HD, Ram, and downgrading solved the problem eventually.

    HD4850 on Slackware 12.2, catalyst official package.

    Switched back to 8.12 since it was the last one I used regularly, after an unsuccessful attempt with 9.2 (same freezes).

    Makes me regret to have bought from ATI once again (...) since I burnt my previous card trying to fit it with the Musashi Scythe in my crippled SP35P2 barebone...
    Whatever, I'll wait for the next one to get a nice GoogleEarth output.
    It looked promising.

    Any ideas on where these freezes might come from ?

    Cheers.

  3. #133
    Join Date
    Mar 2009
    Posts
    211

    Default

    I'm willing to bet now that it's some sort of weird interaction between compositing and the catalyst drivers...

    Oh yeah, the black textures in X3R seem to be the stations not being textured, maybe ships too, but I didn't even bother trying long enough to try to find one. (Googling the net to see if anyone ever came up with a q&d fix for it. nVidia cards are reportedly working, so it really does sound like an ATI driver problem. X3R has a gold rating with 1.1.18 in appdb. Also added the windows media players plus directx9 + updates just to get where I'm at now. nVidia users must do the same as well, but they get textures...)

  4. #134
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by cutterjohn View Post
    Well, I hope that bridgman or some other ATI guys reads this, but I just upgraded to catalyst 9.3 today and turned compiz/beryl back on in Ubuntu 8.10, which worked out OK.

    However, I then left my notebook sitting long enough for it to suspend, and it froze at the password dialog box to log in. CTRL-ALT-BACKSPACE wouldn't kill X11, and other key combos including blindly attempting entering the pw failed to produce any results, so I was forced to poweroff. (I was unable to ssh in to see if the machine was still up as my desktops are down ATM until I have time to check them over.)

    Prior to this, I had thought that something I added or something with fixing the hdd laptop killer bug in 8.10 fixed the resume from suspend problem. It would now seem that turning compiz/beryl OFF is what fixed it.

    hw is MSI GT725-074US + x86-64 Ubuntu 8.10

    X3 Reunion under wine is also turning up black textures all over the place(some things render OK, others are just big black things) and main menu text does not render, if anyone cares. (Trying to see if there's any additional workarounds, as adding some wine Direct3D specific entries helped it a little, as in originally the lower left corner of the display was a big black rectangle.)
    (wine 1.1.18 + 2.6.27-11 kernel + Cat 9.2/3 + X3R v2.5)

    (X2 linux native rendered fine under 9.2, plus some simpler (non-shader requiring)windows games run under wine rendered fine.)
    Well, I got the very same problem with suspend. At least now I know I'm not the only one :-) HD 3650, intrepid

  5. #135
    Join Date
    Aug 2008
    Posts
    5

    Default

    Are these compatible with Jaunty? I have an ATI Xpress X1270 on my laptop, and when I try to install, I get this message:

    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================

    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.28-11-generic; make sure that the version is being
    correctly set by --iscurrentdistro

    Removing temporary directory: fglrx-install.hThgGR
    Right now im using de Open Source drivers, and they are excelent, but when it comes to 3D games or Google Earth, well it sucks.

  6. #136
    Join Date
    Mar 2008
    Posts
    14

    Default

    Over a month and no one has any idea why composited opengl is not working on some hardware? Im using a 9800XT and this driver is complete gargage. No compositing, opengl apps crash upon opening, poor video playback.. a working driver as the last supported release for legacy hardware would have been great.

  7. #137
    Join Date
    Jun 2008
    Posts
    197

    Default

    ATi drivers suck man, just get used to it. Window or Linux they're just absolute bullshit.

    On a card like yours you should get decent support with the open source driver. Otherwise just learn from your mistake and avoid ATi hardware.
    http://www.x.org/wiki/RadeonFeature

  8. #138
    Join Date
    Aug 2008
    Posts
    5

    Default

    Thanks man, FGLRX 9.3 doesnt support XORG 1.6 (the one on jaunty) and 9.4 doesnt support my card, so, as I want any 3d support (world of goo, Google earth, Half-life) Im going back to Ubuntu Hardy or Intrepid, or to Fedora 10.
    The Open Source drivers are quite impressive for being open source. I gotta say, ATI sucks.

  9. #139
    Join Date
    Mar 2009
    Location
    NYC, New Haven
    Posts
    3

    Default

    I thought since the ATI 9.3 installer had the option for Jaunty, and since the packages built and installed properly, that the driver would work.

    First I got an unaccelerated desktop because I forgot to run aticonfig --initial after installing the packages with dpkg.

    Then after reboot, I got an error saying that the fglrx.so driver didn't support my device.

    I have an ATI Radeon Mobility X1400 and ATI/AMD recommend the 9.3 driver for my model since it does composite 3D and is the last proprietary driver for my model since my model belongs to the R300 series. (rather problematic...I wish I could use 9.4 and an X2300 as is found on the refresh of my laptop, although I think that GPU is slower)

    I guess this explains why Ubuntu hasn't released 9.3 (8.53X whereas 9.4 is 8.600) through its restricted drivers manager.

  10. #140

    Default

    Quote Originally Posted by h3xis View Post
    Same with me. I'm running compiz on Debian Squeeze with kernel 2.6.28.7 and I see no noticeable difference. glxgears still stays in place when I drag the window.
    Same here with Ubuntu 9.04. GL windows flicker and dont keep up when moving the window. Using Catalyst 9.5 and HD 3200 card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •