Results 1 to 4 of 4

Thread: how to enable tv-out with xrandr using fglrx drivers?

  1. #1
    Join Date
    Apr 2008
    Posts
    127

    Default how to enable tv-out with xrandr using fglrx drivers?

    I wanted to try to setup my dual-head configuration using xrandr, instead of aticonfig (using the 9.3 fglrx driver). So I reconfigured using:

    Code:
    aticonfig --set-pcs-str="DDX,EnableRandr12,TRUE"
    As I understood, this is necessary to enable Randr 1.2.
    Thereafter I made a backup of my xorg.conf, removed and did:

    Code:
    aticonfig --initial --adapter=0 -f
    To force a clean xorg.conf.
    Now I had my monitor working and by default my tv shows a cloned image.

    So, I tried to setup my tv-out, but I get the following error message:

    Code:
    xrandr --addmode S-video 800x600
    xrandr: cannot find output "S-video"
    When I query xrandr I get the following:
    Code:
    xrandr -q
    Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1024
    default connected 1280x1024+0+0 0mm x 0mm
       1280x1024      75.0*    60.0  
       1280x960       60.0  
       1280x768       60.0  
       1280x720       60.0  
       1152x864       75.0     60.0  
       1024x768       75.0     70.0     60.0  
       800x600        75.0     72.0     60.0  
       720x576        50.0  
       720x480        60.0  
       640x480        75.0     72.0     60.0  
       640x432        60.0  
       640x400        75.0     60.0  
       640x350        70.0  
       512x384        75.0     60.0  
       400x300        75.0     60.0  
       320x240        75.0     60.0  
       320x200        75.0     60.0
    Is there anything I'm doing wrong? My tv is connected via a composite/s-video output on my HD3450. My motherboard contains an HD3200 as well, there is no monitor connected to the HD3200 but I am using hybrid crossfire and that is working fine.

  2. #2
    Join Date
    Apr 2008
    Posts
    127

    Default

    Anybody ever tried this with the closed source Ati driver (fglrx)? Is there anybody for whom this does work?

    Code:
    xrandr --addmode S-video 800x600
    xrandr: cannot find output "S-video"

  3. #3
    Join Date
    Apr 2008
    Posts
    127

    Default

    Can anybody confirm whether xrandr 1.2 should be working with the official Ati driver and tv-out? Please let me know if you have this working, or if you know whether it should be working or not (so I know if I should stop looking or not...).

  4. #4
    Join Date
    Apr 2008
    Posts
    127

    Default

    It seems to work again with fglrx 9.4:

    Code:
    xrandr 
    Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 1280 x 1280
    DFP2 disconnected (normal left inverted right x axis y axis)
    CRT1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
       1280x1024      60.0 +   75.0* 
       1280x960       60.0  
       1152x864       75.0     60.0  
       1280x768       59.9  
       1280x720       60.0  
       1024x768       75.0     70.1     60.0  
       800x600        72.2     75.0     70.0     60.3  
       720x480        60.0  
       640x480        75.0     72.8     60.0  
       640x432        60.0  
       640x400        75.1     59.9  
       640x350        70.1  
       512x384        60.0     74.9  
       400x300        75.0     60.7  
       320x240        75.6     60.0  
       320x200        75.5     60.1  
    CRT2 disconnected (normal left inverted right x axis y axis)
    TV connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
       1024x768       25.0 +
       800x600        25.0  
       720x576        25.0  
       720x480        25.0  
       640x480        25.0  
       640x432        25.0  
       640x400        25.0  
       512x384        25.0  
       400x300        25.0  
       320x240        25.0  
       320x200        25.0  
    COMPONENT_VIDEO disconnected (normal left inverted right x axis y axis)
      1024x768 (0xac)   43.0MHz
            h: width  1024 start 2320 end 2336 total 2730 skew    0 clock   15.7KHz
            v: height  768 start  483 end  485 total  525           clock   30.0Hz
    Now only I have to find out how to setup two separate desktops with xrandr (can move the mouse from one to another, but can't drag windows from one to another).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •