Results 1 to 3 of 3

Thread: PTS behind a company firewall

  1. #1
    Join Date
    Apr 2009
    Location
    Augsburg, Germany
    Posts
    19

    Question PTS behind a company firewall

    Hi there,

    I started testing PTS some days ago and this morning I tried PTS 1.8 on a system with Fedora 10. Currently I'm doing "install-all" and I notice a few problems:

    1. PTS seems to use wget and curl to do the downloading. So if I'm forced to use a proxy to connect to the internet I need to setup the environment variables and adjust the config files like wgetrc. This should be documented in the install instructions.

    2. I'm suffering from a very restrictive policy of my employer regarding the access to "not work related sites", that means that some of the software that PTS is trying to download and install is resulting in HTTP response codese 401 and 403 and the download is blocked. Is there a sort of "installation report" at the end that lists unsuccessful packages and maybe how important they are for the overall PTS functionality?

    Thanks for your attention.

    Rainer

  2. #2

    Default

    Hi Rainer,

    When it comes to downloading test files, the Phoronix Test Suite will use either curl or wget. It shouldn't be using both. It first checks to see if curl is in the $PATH and if not it will check for wget. Internally with the PHP file_get_contents() call it may be using the curl library, but that's not part of the test downloading process. If you have the curl library for PHP + curl itself installed, it should never touch wget.

    If any package can't be downloaded, that particular test will not be installed. The rest of the tests in the suite though should work just fine. If you have any other way you would like this information presented, I can see about changing its way.

    Michael

  3. #3
    Join Date
    Apr 2009
    Location
    Augsburg, Germany
    Posts
    19

    Default

    Ok, just for the records so that others don't stumble in the same trap.

    I've now setup a "download cache" on my lab server that has the IP 192.168.2.1. The proxy is at http://172.25.159.4:81
    So I need a curl configuriation that
    - doesn't use the proxy when accessing the download cache
    - uses the proxy when connecting to resources on the internet

    For curl this can be achieved by the 2 environment variables:
    ALL_PROXY="http://172.25.159.4:81"
    NO_PROXY="192.168.2.1"

    But beware of a flaw in the curl documentation: There are also the "lower case environment variables" like no_proxy which are set by e.g. the Gnome proxy settings. And curl is ignoring "NO_PROXY" (uppercase) if there is a "no_proxy" (lowercase) environment variable. So if you setup your proxies with the Gnome configuration panel check that no_proxy has the IP of your host to ignore, curl doesn't understand to ignore networks like 192.168.2.0/24.

    Hope that helps for everybody with a similar problem.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •