Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 98

Thread: AMD Catalyst 9.4 Finally Brings X Server 1.6 Support

  1. #11
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,575

    Default

    I'd rather not get into that, if you don't mind

  2. #12
    Join Date
    Mar 2009
    Location
    Poland
    Posts
    21

    Default

    I have kde 3.5.10, xserver 1.6.1 and compiz 8.x. Resize and maximalize windows is very slow. Who can help me? Best regards. :-)

  3. #13
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    213

    Default

    Hmm.. with 8.* I saw steady improvement with fglrx.
    Now with the 9.* series, I see steady regressions.

    9.3 introduced graphical glitches to savage 2, with 9.4 I can't even start s2:
    X Error of failed request: BadValue (integer parameter out of range for operation)
    Major opcode of failed request: 147 (XFree86-DRI)
    Minor opcode of failed request: 8 ()
    Value in failed request: 0x2200009
    Serial number of failed request: 81
    Current serial number in output stream: 107

    9.3 Mythtv playback was great, 9.4 playback is unwatchable due to stuttering. This happens with both SD and HD playback, though HD playback with mplayer is fine. :/

    card: 4870, reckon I'm done with it.

  4. #14
    Join Date
    Dec 2007
    Location
    /dev/hell
    Posts
    297

    Default

    nice: it crashes my kernel

  5. #15
    Join Date
    Nov 2007
    Posts
    65

    Default

    Could someone please post a link to the 32-bit driver? Can't seem to find it on the AMD website.

    EDIT: I realized there's one file for 32/64-bit
    Last edited by zhark; 04-17-2009 at 03:34 PM.

  6. #16
    Join Date
    Mar 2009
    Location
    Poland
    Posts
    21

    Default

    When will be 3d support for r600 in open source drivers ?! I`m still waiting

  7. #17
    Join Date
    Jun 2008
    Posts
    40

    Default

    Quote Originally Posted by bridgman View Post
    I'd rather not get into that, if you don't mind
    Sure.. i understand.. so, IT IS possible, eheheheh.

    hmmm weekend coming...

    best regards

  8. #18
    Join Date
    Mar 2009
    Posts
    51

    Default

    Hi, here kensai, the Arch Linux developer, who loves AMD,

    Well, I compiled this new driver and will make it available to the users of Arch Linux in an unsupported way still, this driver does not compile on kernel 2.6.29, I had to patch it for it to do, so there you go guys didn't I told you AMD wouldn't fix this, and bridgman told me to wait for the final, yeah right, here final does not support kernel 2.6.29 yet.

    But as typical of AMD, maybe kernel 2.2.29 support will be added by the time 2.6.30 comes.

  9. #19
    Join Date
    Mar 2009
    Location
    Poland
    Posts
    21

    Default

    Quote Originally Posted by kensai View Post
    Hi, here kensai, the Arch Linux developer, who loves AMD,

    Well, I compiled this new driver and will make it available to the users of Arch Linux in an unsupported way still, this driver does not compile on kernel 2.6.29, I had to patch it for it to do, so there you go guys didn't I told you AMD wouldn't fix this, and bridgman told me to wait for the final, yeah right, here final does not support kernel 2.6.29 yet.

    But as typical of AMD, maybe kernel 2.2.29 support will be added by the time 2.6.30 comes.
    I use arch linux and I used this patch for kernel 2.6.29. But on xserver 1.6.x resize and maximalize windows is very slow with compiz.
    It`s very flustrating.!!!!!!!!!!!!!!!!!!!!

  10. #20
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,575

    Default

    Hi Kensai; I think we're talking about two different things. You said that 9.4 would be the exact same driver that Ubuntu shipped, I said wait for the 9.4 final. I read back through the thread some more and it looks like you were mostly thinking about 2.6.29 support.

    I might have misunderstood your point since you said "it would be exactly the same although we might add 2.6.29 support"; we didn't add 2.6.29 support but among other things, we completed Redirected Direct Rendering support between the Ubuntu early driver and the final 9.4.
    Last edited by bridgman; 04-17-2009 at 04:06 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •