Thanks to bridgman in another thread, he suggested that I use the radeon driver rather than the radeonhd driver.

This is a step forward, as now I get some 2D acceleration, but I've still got a couple of problems that perhaps people have seen before and might be able to help me with.

Firstly, I'm getting very slow scrolling and window moving speed. If I have mythtv or vlc running, then the video stalls while I'm scrolling or moving a window. I think all of the relevant options are enabled, but I'm not sure. Here's my log: http://pastebin.com/m5592a2c1

Secondly, now I can get Xrandr working, sort of. If I try and configure it so that it starts up in the correct mode using options in Xorg.conf, my right hand monitor (1600x1200, rotated left) then all that happens is that the right hand screen is corrupted and nothing can get dragged there, even though the mouse disappears off the right edge of the primary monitor.

However, it works when I issue the following commands:

xrandr --output DVI-0 --auto --rotate left --right-of DVI-1

But after I've extended the monitor, and start mythtv, the aspect ratio is wrong (it's squished horizontally). I assume that this is because the screen size in X has been changed. Also I assume it's normal for XVideo not to work on the rotated second screen :-)

Here's my xorg.conf http://pastebin.com/m5cf7730e

I know that the options controlling the Right-Of and Rotation are commented out, but imagine that they're not commented out :-)

Any thoughts anyone?