This means that you have problems with the comilation of the next library. I do not remember the compilation order but it might be i915_dri.so. Please post your error when you do make. I belive that somebody can help you here. I am not a specialist in this.