Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47

Thread: Xpress 200M problems... again

  1. #21
    Join Date
    Nov 2007
    Posts
    25

    Default

    This means that you have problems with the comilation of the next library. I do not remember the compilation order but it might be i915_dri.so. Please post your error when you do make. I belive that somebody can help you here. I am not a specialist in this.

  2. #22
    Join Date
    Apr 2009
    Posts
    12

    Default

    Many times:

    ...leaving directory.
    [error 1]

    I'll try again...

  3. #23
    Join Date
    Nov 2007
    Posts
    25

    Default

    Quote Originally Posted by Bobber76 View Post
    Many times:

    ...leaving directory.
    [error 1]

    I'll try again...
    Tthe error will be just before these messages

  4. #24
    Join Date
    Apr 2009
    Posts
    12

    Default

    Here's the end of 'make':

    intel_screen.c: In function ‘intel_init_bufmgr’:
    intel_screen.c:617: error: ‘I915_PARAM_NUM_FENCES_AVAIL’ undeclared (first use in this function)
    intel_screen.c:617: error: (Each undeclared identifier is reported only once
    intel_screen.c:617: error: for each function it appears in.)
    make[5]: *** [intel_screen.o] Error 1
    make[5]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers/dri/i915'
    make[4]: *** [subdirs] Error 1
    make[4]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers/dri'
    make[3]: *** [default] Error 1
    make[3]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa/drivers'
    make[2]: *** [driver_subdirs] Error 2
    make[2]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src/mesa'
    make[1]: *** [subdirs] Error 1
    make[1]: Leaving directory `/home/bobber/Asztal/mesa-radeon-rewrite/src'
    make: *** [default] Error 1

  5. #25
    Join Date
    Nov 2007
    Posts
    25

    Default Good luck

    You can try to compile mesa only for ati:
    ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300

  6. #26
    Join Date
    Dec 2007
    Posts
    2,276

    Default

    Quote Originally Posted by sergus View Post
    You can try to compile mesa only for ati:
    ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300
    You can also disable gallium:
    ./autogen.sh --prefix=/usr --with-dri-drivers=radeon,r200,r300 --disable-gallium

  7. #27
    Join Date
    Apr 2009
    Posts
    12

    Default

    Thanks to both of you!

    That was worked for me. Now I have the same FPS under jaunty, as with fglrx+Intrepid, and now I have no lockups! Thanks!

  8. #28
    Join Date
    May 2009
    Posts
    1

    Default

    Hi there

    I've installed this mesa-radeon-rewrite, but now
    glxgears:
    drmRadeonCmdBuffer: -22

  9. #29
    Join Date
    May 2009
    Posts
    9

    Default

    Quote Originally Posted by hugoea View Post
    Hi there

    I've installed this mesa-radeon-rewrite, but now
    glxgears:
    drmRadeonCmdBuffer: -22
    The same is for me .

  10. #30
    Join Date
    Apr 2009
    Posts
    6

    Default

    Quote Originally Posted by rayunix View Post
    The same is for me .
    See http://bugs.freedesktop.org/show_bug.cgi?id=21776

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •