Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 58

Thread: Intel Linux Driver Kills The Netbook Experience

  1. #41
    Join Date
    Nov 2007
    Posts
    25

    Default

    Quote Originally Posted by bridgman View Post
    I hadn't realized the R300 regression (in Mesa, I think) was showing up in Jaunty. I'll ask around tomorrow to see what the options are for getting it fixed.
    Thanks bridgman. This is indeed Mesa regression. You can find more details here: https://bugs.launchpad.net/ubuntu/+s...ti/+bug/347569.
    There is a preliminary solution here: http://www.nabble.com/R300-regression-td23108996.html, but it lockups the system in some cases.

  2. #42
    Join Date
    Apr 2009
    Posts
    3

    Default

    Just upgrade the kernel to 2.6.30rc3,and use the EXA mode, the regression now is gone.

  3. #43
    Join Date
    Dec 2008
    Location
    Creve Coeur, Missouri
    Posts
    405

    Default

    Quote Originally Posted by fcatrin View Post
    I've been following the history of this bug. I have two machines, a desktop and a laptop, both with Intel hardware but different chipset. My laptop with a 945 video has this issue, so netbooks are not the only affected by this bug.

    The fix for the perfomance regression was applied some weeks ago but some users reported freezing issues so they reverted it back[1]. I've received an email just now about the backported patch.[2]

    It's not a Ubuntu specific bug, other distros would be affected if they include the same kernel/intel driver combination

    [1]https://bugs.launchpad.net/ubuntu/+source/linux/+bug/349314/comments/48
    [2]https://bugs.launchpad.net/ubuntu/+source/linux/+bug/349314/comments/49
    When I upgraded to jaunty the driver performance was much better. I had not upgraded in a few weeks and when I did the performance went down the drain.

    I upgraded to kernel 2.6.30 and xorg 2.7 and performance was faster than ever before (faster than feisty and earlier.) I also noticed however that flash plays RRRRRREEEEEAAAAAAALLLLLLYYYYYY slow now, but if all you want is 3d games...

    Also with the updates to 2.6.30 and 2.7, everything is much faster in EXA (and less crash vunerable.)

  4. #44
    Join Date
    Sep 2008
    Posts
    89

    Default

    Oh yeah, 'just' upgrade the kernel.

    So for those of us who can't 'just' upgrade the kernel this release is going to be broken until 9.10? Sigh.

  5. #45
    Join Date
    Mar 2009
    Location
    in front of my box :p
    Posts
    840

    Default

    I don't know but basically it should be possible even outsides Gentoo to do a Kernel update. I'm not sure what the packages are called in your packet manager but look for them. Otherwise it should also be a possible thing to use plain vanilla sources from kernel.org and compile them. Besides I guess as soon Ubuntu or whatever you stick with engineering team notices about all that or get enough complaints they will backport code and bring out a fix that will come to you by your standard recommended updates/security fixes. Install, reboot (unless you have a relocatable Kernel) and there you are. No need to wait for the next whole distribution upgrade.

  6. #46
    Join Date
    Sep 2007
    Posts
    13

    Default

    Anyone read my message in this thread?

    I posted a link to ubuntuforums with everything about resolving the intel problem/pregression on jaunty default installation.

    There is an official page for downloading kernel compiled packages using ubuntu configuration from vanilla kernel sources. It is just install kernel-linux package and the headers one and there you go.

    Right now, it's installing a bunch of .deb packages, change the xorg.conf file to UXA (you can stick to exa if you want, but i can tell you, right now, using 2.6.30rc3 kernel or rc2, i didn't have any crashes).

    So, installing new kernels on ubuntu right now is really easy to do, using those packages. Before you had to download the ubuntu configuration for the kernel, download the sources, and use the manual compilation, or any utility for the job (all of this matter can be found on the ubuntu wiki).

    Try it, it is worth the time.
    Last edited by Eversmann; 04-23-2009 at 12:19 PM.

  7. #47
    Join Date
    Jan 2009
    Posts
    515

    Default

    What should I do?

    I have convinced my girlfriend to use linux, and she is normally very happy with it. Though since I installed the kde 4.2.2 packages onto her gnome desktop, everything has become a bit unstable. Thats freezing/hanging firefox and spontaneously reboot etc.

    She doesn't know anything about fixing linux, and doesn't really care. It just has to work, and apparently it has become my responsibility :P

    What should I do if thiese conditions has to be met?:
    - She probably wants kde 4.2.2 again. She likes it alot.
    - She want it to be stable rather than new features.
    - I don't want to install intrepid with kde 4.2.2 again, as it doesn't went well the last time.


    Janty was a fine candidate, but it sounds like Jaunty has some intel driver bugs (her laptop is intel based).

    What should I do?

    EDIT:
    It doesn't have to be Ubuntu, but has to be debian packagement based.

  8. #48
    Join Date
    Sep 2007
    Posts
    13

    Default

    You can just backup her home folder, download the latest final kubuntu 9.04 image, install all the needed programs and then recover the backup.

    You should be working again just fine and with the latest kde 4.2 packages.

  9. #49
    Join Date
    Jan 2009
    Posts
    515

    Default

    Quote Originally Posted by Eversmann View Post
    You can just backup her home folder, download the latest final kubuntu 9.04 image, install all the needed programs and then recover the backup.

    You should be working again just fine and with the latest kde 4.2 packages.
    Yeah but what about the slow rather unstable intel drivers?

  10. #50
    Join Date
    Jan 2009
    Posts
    515

    Default

    @Michael

    Couldn't you make a benchmark comparing a default ubuntu installation with an ubuntu installation modified with thiese packages?
    http://ubuntuforums.org/showthread.php?t=1130582

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •