Results 1 to 6 of 6

Thread: Radeon no acceleration on 2nd X server?

  1. #1
    Join Date
    Dec 2008
    Posts
    1,002

    Default Radeon no acceleration on 2nd X server?

    Hi, I justed tried to use the Fast User Switch Applet in Gnome and I noticed there's no acceleration at all on the 2nd X Server. Is this a bug, or is it not implemented yet?

    Xorg.20.log:
    Code:
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 10, (OK)
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 10, (OK)
    drmOpenByBusid: Searching for BusID pci:0000:01:05.0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 10, (OK)
    drmOpenByBusid: drmOpenMinor returns 10
    drmOpenByBusid: drmGetBusid reports pci:0000:01:05.0
    (II) [drm] DRM interface version 1.0
    (EE) [drm] Could not set DRM device bus ID.
    (EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.
    I'm running latest radeon git on a HD 3200 and tried both the drm from Jaunty and the r6xx-r7xx-3d branch from agd5f's repo.

  2. #2
    Join Date
    May 2007
    Posts
    352

    Default

    It is not implemented.

    Adam

  3. #3
    Join Date
    Dec 2008
    Posts
    1,002

    Default

    Quote Originally Posted by adamk View Post
    It is not implemented.

    Adam
    I see. I googled a bit and it appears that this is not the fault of radeon but a limitation of DRI. This is really sad because radeon requires DRI for 2D acceleration on my card and without it scrolling with Firefox is a disaster .

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,572

    Default

    AFAIK adding drm (kernel driver) code to support multiple X servers is on the list, it's just not likely to reach the top of the list until things like kernel memory management and kernel modesetting are finished. Try taking out the AccelMethod option in your conf file.

    Ignore my earlier comments about changing your conf file to use shadowfb; I mixed your thread up with one about runing multiseat.

    Wouldn't hurt to pastebin the log for your second X server anyways; the driver may not be falling back to shadowfb because the drivers were set up for developing and testing the 2d/xv acceleration. If it's not running shadowfb, we should be able to tweak the code to run shadowfb which should help a lot.
    Last edited by bridgman; 04-24-2009 at 11:30 PM.

  5. #5
    Join Date
    Dec 2008
    Posts
    1,002

    Default

    Quote Originally Posted by bridgman View Post
    Wouldn't hurt to pastebin the log for your second X server anyways; the driver may not be falling back to shadowfb because the drivers were set up for developing and testing the 2d/xv acceleration. If it's not running shadowfb, we should be able to tweak the code to run shadowfb which should help a lot.
    Yeah, it's not falling back to shadowfb. Here's the log:

    http://pastebin.ca/1402539

  6. #6
    Join Date
    May 2007
    Posts
    319

    Default

    already works in F11 codebase.

    needs memory manager to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •