I bought a new Samsung 2343BWZ monitor; one of the new 16:9 form factor monitors with a native resolution of 2048 * 1152.

I plugged it in and reboot my machine, and I get no display. What is the most likely cause?

Sapphire 4670 card (RV730XT)
Fedora 9
kernel 2.6.27.21-78.2.41.fc9.x86_64
xorg-x11-drv-ati-6.8.0-19.fc9.x86_64
xorg-x11-drv-radeonhd-1.2.4-1.1.20081212git.fc9.x86_64
xorg-x11-server-Xorg-1.5.2-6.fc9.x86_64
xorg-x11-server-common-1.5.2-6.fc9.x86_64

I tried the "radeon" driver, and I tried the "radeonhd" driver.
I used a DVI-D single link cable.

If I calculated properly, this should only take a single link DVI cable. Is that correct? cuz that's what ships with the monitor.

Does either the radeon or radeonhd driver support this resolution? Would newer versions of the driver help?

From Xorg.0.log:
(II) RADEONHD(0): EDID data for SyncMaster
(II) RADEONHD(0): Manufacturer: SAM Model: 41f Serial#: 1297691187
(II) RADEONHD(0): Year: 2009 Week: 11
(II) RADEONHD(0): EDID Version: 1.3
(II) RADEONHD(0): Digital Display Input
(II) RADEONHD(0): Max Image Size [cm]: horiz.: 51 vert.: 29
(II) RADEONHD(0): Gamma: 2.20
(II) RADEONHD(0): DPMS capabilities: Off
(II) RADEONHD(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) RADEONHD(0): First detailed timing is preferred mode
(II) RADEONHD(0): redX: 0.640 redY: 0.330 greenX: 0.300 greenY: 0.600
(II) RADEONHD(0): blueX: 0.150 blueY: 0.060 whiteX: 0.312 whiteY: 0.329
(II) RADEONHD(0): Supported VESA Video Modes:
(II) RADEONHD(0): 640x480@60Hz
(II) RADEONHD(0): 800x600@56Hz
(II) RADEONHD(0): 800x600@60Hz
(II) RADEONHD(0): 1024x768@60Hz
(II) RADEONHD(0): Manufacturer's mask: 0
(II) RADEONHD(0): Supported Future Video Modes:
(II) RADEONHD(0): #0: hsize: 1280 vsize 1024 refresh: 60 vid: 32897
(II) RADEONHD(0): #1: hsize: 1280 vsize 960 refresh: 60 vid: 16513
(II) RADEONHD(0): #2: hsize: 1280 vsize 800 refresh: 60 vid: 129
(II) RADEONHD(0): #3: hsize: 1440 vsize 900 refresh: 60 vid: 149
(II) RADEONHD(0): #4: hsize: 1680 vsize 1050 refresh: 60 vid: 179
(II) RADEONHD(0): Supported additional Video Mode:
(II) RADEONHD(0): clock: 156.8 MHz Image Size: 510 x 287 mm
(II) RADEONHD(0): h_active: 2048 h_sync: 2096 h_sync_end 2128 h_blank_end 2208 h_border: 0
(II) RADEONHD(0): v_active: 1152 v_sync: 1155 v_sync_end 1160 v_blanking: 1185 v_border: 0
(II) RADEONHD(0): Ranges: V min: 56 V max: 60 Hz, H min: 30 H max: 81 kHz, PixClock max 160 MHz
(II) RADEONHD(0): Monitor name: SyncMaster
(II) RADEONHD(0): Serial No: H9NS301393
(II) RADEONHD(0): EDID (in hex):
(II) RADEONHD(0): 00ffffffffffff004c2d1f043332594d
(II) RADEONHD(0): 0b13010380331d782aee91a3544c9926
(II) RADEONHD(0): 0f50542308008180814081009500b300
(II) RADEONHD(0): 0101010101013b3d00a0808021403020
(II) RADEONHD(0): 3500fe1f1100001a000000fd00383c1e
(II) RADEONHD(0): 5110000a202020202020000000fc0053
(II) RADEONHD(0): 796e634d61737465720a2020000000ff
(II) RADEONHD(0): 0048394e533330313339330a202000ee
(II) RADEONHD(0): Calling DAC_LoadDetection
(II) RADEONHD(0): DAC_LoadDetection Successful
(II) RADEONHD(0): Output VGA_1 disconnected
(II) RADEONHD(0): Output DVI-D_1 disconnected
(II) RADEONHD(0): Output DVI-I_2/digital connected
(II) RADEONHD(0): Output DVI-I_2/analog disconnected
(II) RADEONHD(0): Using exact sizes for initial modes
(II) RADEONHD(0): Output DVI-I_2/digital using initial mode 2048x1152
(II) RADEONHD(0): RandR 1.2 support enabled
(==) RADEONHD(0): RGB weight 888
(==) RADEONHD(0): Default visual is TrueColor
(==) RADEONHD(0): Using gamma correction (1.0, 1.0, 1.0)
(II) RADEONHD(0): Using 2048x2048 Framebuffer with 2048 pitch
(II) RADEONHD(0): FB: Allocated ScanoutBuffer at offset 0x00008000 (size = 0x01000000)
(==) RADEONHD(0): DPI set to (96, 96)
...

I don't see any "EE" lines that are relevant. What should I be looking for?