Results 1 to 1 of 1

Thread: Compiz, OpenGL and Vsync

  1. #1
    Join Date
    Jun 2008
    Posts
    6

    Default Compiz, OpenGL and Vsync

    Hi all,

    Today I updated to the 9.3 release series of drivers. While I am aware that they are a little outdated they are the newest which the Gentoo package maintainers choose to make available.

    I read that they finally had support for OpenGL compositing, fantastic. So I fired up compiz and started glxgears. The flicker was gone, however vsync was no where to be found -- getting well over 4000FPS on my 4850HD.
    Code:
    Running synchronized to the vertical refresh.  The framerate should be
    approximately 1/22612 the monitor refresh rate.
    23555 frames in 5.0 seconds = 4709.929 FPS
    24255 frames in 5.0 seconds = 4850.880 FPS
    24531 frames in 5.0 seconds = 4906.095 FPS
    24518 frames in 5.0 seconds = 4903.489 FPS
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
          after 41 requests (41 known processed) with 0 events remaining.
    Furthermore, although in compiz manager I have checked the 'sync to vblank' box, compiz itself does not seem to use it. This is especially visible with the desktop cube.

    So my question is how can I force vsync everywhere on my desktop. In AMDCCCLE I have vsync set to "On unless application specifies otherwise" on account that having having it "Always on" disables it.

    When running under Metacity glxgears gets the correct FPS of 60.

    How can I fix this, or is vsync with a compositing window manager currently unsupported.

    Regards, Freddie.
    Last edited by EvilGuru; 04-23-2009 at 11:43 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •