Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: fglrx 9.4 unsupported handware?

  1. #1
    Join Date
    Jan 2009
    Posts
    11

    Unhappy fglrx 9.4 unsupported handware?

    I can build the kernel module for 9.4 but it won't load
    (memory allocation error: trying to allocate 0 bytes).

    waverley:~$ lspci -v | grep -C 1 ATI

    01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [Mobility FireGL V5250] (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device 20a4

    Is this hardware supposed to be supported, or has it been dropped
    in 9.4? (Earlier fglrx releases worked for me, to varying extents.)
    Last edited by cottrell; 04-23-2009 at 02:51 PM.

  2. #2
    Join Date
    Apr 2009
    Posts
    3

    Default

    Having a Lenovo T60p, I experience the same problem. I found some websites stating that the Mobility FireGL V5250 is based on an X1700 while the most recent release notes contain only >= X2300 chips.

    Can anybody from AMD confirm this?

    I cannot believe that AMD drops support for a machine that is less than 2.5 years old and not even written off(!). Even worse: It is not as if I could easily replace the graphics card in the laptop.

    Dominic

  3. #3
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    You do not need to use U 9.04 or something similar But maybe just patch the id back into the fglrxko_pci_ids.h. This file is self explaining usually, you just add the id you see with

    lspci -nn|grep 0300

    ...[1002:xxxx]

    Also you should backup the /etc/ati/control file from 9-3 release to overwrite the new one.

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,280

    Default

    Quote Originally Posted by DominicB View Post
    Having a Lenovo T60p, I experience the same problem. I found some websites stating that the Mobility FireGL V5250 is based on an X1700 while the most recent release notes contain only >= X2300 chips.

    Can anybody from AMD confirm this?

    I cannot believe that AMD drops support for a machine that is less than 2.5 years old and not even written off(!). Even worse: It is not as if I could easily replace the graphics card in the laptop.

    Dominic
    We didn't drop support, but we are shifting support from fglrx to the open drivers. The main driver tree is now supporting from r600 up, for all OSes not just Linux.

  5. #5
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    Well you definitely dropped support because the fglrx driver was far from perfect which was the last one. The oss driver can only be used for better xv support but for games you can forget it. Current fglrx still crashes vdrift which is in pts...

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,280

    Default

    Ahh, isn't English a wonderfully ambiguous language. AFAICS the previous poster was using "dropped" to mean "eliminated", but you're using "dropped" to mean "reduced".

    The open drivers also have better 2D performance and general useability today; it's really just gaming where more work is needed as you say.

  7. #7
    Join Date
    Apr 2009
    Posts
    3

    Default

    Thanks for the clarifications. I was not aware that the open source drivers have become usable by now (2d performance, 2 monitor (extension + cloning) are important to me). I shall investigate this.

  8. #8
    Join Date
    Oct 2007
    Posts
    4

    Default

    Hey Kano I was wondering if you would be so kind as to shed some light on your method? This is the file locales I get with 9.3 installed.

    graffix@satellite-II:/$ locate fglrxko_pci_ids.h
    /usr/src/fglrx-8.593/fglrxko_pci_ids.h
    /var/lib/dkms/fglrx/8.593/build/fglrxko_pci_ids.h
    /var/lib/dkms/fglrx/8.593/build/2.6.x/fglrxko_pci_ids.h
    graffix@satellite-II:/$

    Which one do I need to edit in the pci ids to or all of them?

    Then I assume I grab the control file from /etc/ati ver 9.3, then copy over my 9.4 install.

    Could bridgman or anyone else on the devel team shed any light on how this would work with an x1200? It's not that big of a deal, but I would like to upgrade to juanty someday, and I don't want to have to wait for the open source drivers to catch up...

  9. #9
    Join Date
    Aug 2007
    Posts
    6,598

    Default

    The last 2 are just links to the first one, basically you could reuse the file from 9-3 too and replace it on the 9-4 install.

  10. #10
    Join Date
    Oct 2007
    Posts
    4

    Default

    Thanks Kano! I think i'll backup some stuff and try jaunty now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •