Results 1 to 7 of 7

Thread: Intel's 2.7 Graphics Driver Still Has Problems

  1. #1
    Join Date
    Jan 2007
    Posts
    14,645

    Default Intel's 2.7 Graphics Driver Still Has Problems

    Phoronix: Intel's 2.7 Graphics Driver Still Has Problems

    Last night Intel pushed out the xf86-video-intel 2.7.0 driver, but still it does not correct some of the performance regressions that have been occurring within the Intel Linux graphics stack for the past few months. While there are UXA improvements in the 2.7 driver, the performance is still bad. Continuing on from our benchmarks yesterday where we looked at the greedy migration heuristics performance and early Linux 2.6.30 benchmarks, we have tested out the xf86-video-intel 2.7.0 driver with the Linux 2.6.30-rc2 kernel...

    http://www.phoronix.com/vr.php?view=NzIxMQ

  2. #2
    Join Date
    Jun 2006
    Location
    Austria
    Posts
    115

    Default

    I'd like to see the same series of tests run on the primary development target for the intel driver: G965 (GMA X3000) and later. Any chance for that to happen?

  3. #3
    Join Date
    Sep 2006
    Posts
    714

    Default

    There is a fuck-up with how OpenGL games and applications are accounted for by the Linux cpu clock control stuff.

    That is unless you go and manually set your CPU to run at full speed then performance for games will be crippled. The cpu schudaler is not accounting for graphics

    For example on my Inpsiron 1420n with GMA X3100 graphics and Fedora 11 beta I am running 'ManiaDrive'. With the default 'ondemand' I get between 40 and 90 FPS. With both cores set to 2.0ghz I get 120-150 fps.

    The difference is night and day.

  4. #4
    Join Date
    Oct 2008
    Location
    Poland
    Posts
    182

    Default

    Table on page http://global.phoronix-test-suite.co...74-10432-20657 doesn't display correctly in Opera.

    Why are you using some div-hell:
    Code:
    <div class="pts_column_four1" style="width: 11.5%;">EXA</div><div class="pts_column_four1" style="width: 11.5%;">EXA Greedy</div><div class="pts_column_four1" style="width: 11.5%;">UXA</div><div class="pts_column_four1" style="width: 11.5%;">xf86-video-intel 2.4</div><div class="pts_column_four1" style="width: 11.5%;">EXAOptimizeMigration Off</div><div class="pts_column_four1" style="width: 11.5%;">Linux 2.6.30 EXA</div><div class="pts_column_four1" style="width: 11.5%;">2.6.30 + 2.7 + EXA</div><div class="pts_column_four1" style="width: 11.5%;">2.6.30 + 2.7 + UXA</div><div class="pts_profile_information" style="width: 11.5%;"><strong>Processor:</strong> Intel Atom CPU N270 @ 1.60GHz (Total Cores:</strong> 2)<br /><strong>Motherboard:</strong> Dell Inspiron 910<br /><strong>Chipset:</strong> Intel Mobile 945GME Express Hub + ICH7-M<br /><strong>System Memory:</strong> 993MB<br /><strong>Disk:</strong> 8GB STEC PATA 8GB<br /><strong>Graphics:</strong> Intel Mobile 945GME Express IGP (rev 03)</div><div class="pts_profile_information_alt" style="width: 11.5%;"><strong>Processor:</strong> Intel Atom CPU N270 @ 1.60GHz (Total Cores:</strong> 2)<br /><strong>Motherboard:</strong> Dell Inspiron 910<br /><strong>Chipset:</strong> Intel Mobile 945GME Express Hub + ICH7-M<br /><strong>System Memory:</strong> 993MB<br /><strong>Disk:</strong> 8GB STEC PATA 8GB<br /><strong>Graphics:</strong> Intel Mobile 945GME Express IGP (rev 03)</div><div class="pts_profile_information" style="width: 11.5%;"><strong>Processor:</strong> Intel Atom CPU N270 @ 1.60GHz (Total Cores:</strong> 2)<br /><strong>Motherboard:</strong> Dell Inspiron 910<br /><strong>Chipset:</strong> Intel Mobile 945GME Express
    just to imitate normal HTML table element?

  5. #5
    Join Date
    Sep 2006
    Posts
    714

    Default

    For proof:

    here is my Fedora 11 desktop running Compiz:
    http://sanguis.bluddclot.com/share/maniadrive.png

    Running a between 50-70 fps with that scene.

    Here is the same exact scene, with no change or restart or anything at all. I just left it running and clicked on the cpu scaler applets to adjust the cpu speed:
    http://sanguis.bluddclot.com/share/maniadrive2.png

    Between 150-190 fps with that scene.

    Now you can planly see that while the game is running it is not taking advantage of the CPU since the cores are running at the normal 'idle' speeds of 800mhz.

    The other problem I've been having is this...
    https://bugzilla.redhat.com/show_bug.cgi?id=494047

    The oops is gone, but there is some sort of memory leak. I don't know exactly what is going wrong.

    This is with:
    ~$ uname -r
    2.6.29.1-68.fc11.x86_64


    ~$ rpm -qf /usr/lib64/xorg/modules/drivers/intel_drv.so
    xorg-x11-drv-intel-2.6.99.902-2.fc11.x86_64

    ~$ rpm -qf /usr/lib64/dri/i965_dri.so
    mesa-dri-drivers-7.5-0.9.fc11.x86_64

  6. #6
    Join Date
    Jan 2009
    Location
    UK
    Posts
    331

    Default

    Just noticed Debian has 2.7 and installed it. It's actually fixed the only real complaint I had about 2.6.3.

  7. #7
    Join Date
    Apr 2009
    Posts
    17

    Default

    Quote Originally Posted by Ant P. View Post
    Just noticed Debian has 2.7 and installed it. It's actually fixed the only real complaint I had about 2.6.3.
    How is your 3D performance with 2.7? I'm running Debian Sid and it's been abysmal since last August.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •