Results 1 to 7 of 7

Thread: S3 Texture Compression in OSS 3D Drivers?

  1. #1
    Join Date
    Jun 2008
    Posts
    86

    Default S3 Texture Compression in OSS 3D Drivers?

    About a year ago, I bought the game On the Rain-Slick Precipice of Darkness since it looked fun and there was a Linux version released simultaneously with the Mac and Windows versions. I enjoyed the first episode so much that I immediately bought the second episode as soon as it came out. Unfortunately for me, however, in the time between episode 1 and 2, I had upgraded my PC and had switched from a 6600 GT running the closed Nvidia drivers to a G43 chipset running the open Intel drivers. Since the games require S3 texture compression, which the Nvidia drivers support but the Intel drivers do not (due to patent restrictions), the game would no longer run.

    After a bit of searching on the Internet, I found out that S3TC support could be obtained by compiling a library for it, but it's no longer maintained and doesn't seem to work. After compiling and installing it, the driver reports supporting GL_EXT_texture_compression_s3tc, allowing the game to run, but every 3D scene inside the game is completely black, which seems to me like the textures aren't actually being decompressed.

    What I'd like to know is if this behavior is limited to Intel hardware (I had heard ATi and Nvidia have it built into the hardware, avoiding any licensing issues, but Intel implemented it software to cut costs), or does it affect everything using an OSS driver? Will the external library be maintained again in the future? (there's a gallium-s3tc branch, apparently). I've tried searching online for discussions about this, but the only ones I've found are from 2003 or earlier, and a lot has changed since then.

    I had planned to upgrade to an ATi card in the future to support their open-source efforts, but if I have to run the binary driver just to play my games, I might as well just go back to Nvidia, since their binary driver is more stable and supports Wine. :/

  2. #2
    Join Date
    Nov 2008
    Posts
    30

    Default

    Isn't it only the US that has software patents? I thought Europe didn't, though I could be wrong.

  3. #3
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    I have played episode two on my G45 with no problems. But trying it now, with Mesa 7.4, it is indeed all black.

    You should probably file a bug:
    http://intellinuxgraphics.org/how_to_report_bug.html

  4. #4
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default

    I do by the way have the S3TC library installed now. But I can't remember if I did when I played through the game.

    It's possible that I simply set force_s3tc_enable to true in drirc.

  5. #5
    Join Date
    Jun 2008
    Posts
    86

    Default

    Quote Originally Posted by whizse View Post
    I have played episode two on my G45 with no problems. But trying it now, with Mesa 7.4, it is indeed all black.

    You should probably file a bug:
    http://intellinuxgraphics.org/how_to_report_bug.html
    Hmmm, if that's the case, maybe it's related to this bug. It's another case of 3D working in Mesa 7.3 but then becomeing entirely black in 7.4. I'm going to follow it and see what happens.

  6. #6
    Join Date
    Oct 2008
    Location
    Sweden
    Posts
    983

    Default



    Mesa is in really bad shape for us Intel users. Doom 3 is broken, UT2004 is broken, even Sacred must be played with graphics quality set to the lowest setting for it to work without hitches.

  7. #7
    Join Date
    Nov 2008
    Posts
    30

    Default

    I wish Intel/Tungsten would stop buggering about changing things in the driver and just get it to work right for once.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •