Page 8 of 10 FirstFirst ... 678910 LastLast
Results 71 to 80 of 91

Thread: AMD 8.35.5 Driver -- Hello Catalyst Control Center Linux Edition!

  1. #71

    Default

    Quote Originally Posted by sonicboom View Post
    I installed this fine (I think) but when I click AMD Catalyst Control Center, the icon does its bouncy thing next to my mouse for 30 seconds then just disappears and nothing happens. Any idea what's going on here? Maybe a reinstall?
    Can you run amdcccle from terminal and post the output of that?

  2. #72
    Join Date
    Apr 2007
    Posts
    3

    Default

    thanks for the quick reply, I edited my post just now because after I reset my xorg.conf file, it was fine. AMD CCC opens. I'm actually having some other problems now but I'll make a thread on it in a bit

  3. #73
    Join Date
    Apr 2007
    Posts
    3

    Default

    ok, now I messed something up again, I can't get the program to open (same problem I mentioned before). I will post what it says in the terminal after running amdcccle as suggested by Michael:

    *** glibc detected *** amdcccle: munmap_chunk(): invalid pointer: 0xffe09a15 ***
    ======= Backtrace: =========
    /lib/libc.so.6(cfree+0x1bb)[0x46e6281b]
    amdcccle[0x85a5317]
    amdcccle(AtiXUPcs_GetVal+0x68)[0x85a5178]
    amdcccle(AtiXUDisp_InitContext+0x85)[0x85a3645]
    amdcccle(AtiXUPriv_InitContext+0x4f)[0x85a26df]
    amdcccle(__AtiXUtil_Open+0x9b)[0x85a154b]
    amdcccle(main+0x106)[0x81449b6]
    /lib/libc.so.6(__libc_start_main+0xdc)[0x46e0ef2c]
    amdcccle[0x8142d21]
    ======= Memory map: ========
    08048000-0869e000 r-xp 00000000 fd:00 4543210 /usr/bin/amdcccle
    0869e000-08754000 rwxp 00656000 fd:00 4543210 /usr/bin/amdcccle
    08754000-08796000 rwxp 08754000 00:00 0 [heap]
    46ddc000-46df5000 r-xp 00000000 fd:00 521730 /lib/ld-2.5.so
    46df5000-46df6000 r-xp 00018000 fd:00 521730 /lib/ld-2.5.so
    46df6000-46df7000 rwxp 00019000 fd:00 521730 /lib/ld-2.5.so
    46df9000-46f30000 r-xp 00000000 fd:00 521744 /lib/libc-2.5.so
    46f30000-46f32000 r-xp 00137000 fd:00 521744 /lib/libc-2.5.so
    46f32000-46f33000 rwxp 00139000 fd:00 521744 /lib/libc-2.5.so
    46f33000-46f36000 rwxp 46f33000 00:00 0
    46f38000-46f5d000 r-xp 00000000 fd:00 521751 /lib/libm-2.5.so
    46f5d000-46f5e000 r-xp 00024000 fd:00 521751 /lib/libm-2.5.so
    46f5e000-46f5f000 rwxp 00025000 fd:00 521751 /lib/libm-2.5.so
    46f61000-46f63000 r-xp 00000000 fd:00 521759 /lib/libdl-2.5.so
    46f63000-46f64000 r-xp 00001000 fd:00 521759 /lib/libdl-2.5.so
    46f64000-46f65000 rwxp 00002000 fd:00 521759 /lib/libdl-2.5.so
    46f67000-46f7a000 r-xp 00000000 fd:00 521794 /lib/libpthread-2.5.so
    46f7a000-46f7b000 r-xp 00012000 fd:00 521794 /lib/libpthread-2.5.so
    46f7b000-46f7c000 rwxp 00013000 fd:00 521794 /lib/libpthread-2.5.so
    46f7c000-46f7e000 rwxp 46f7c000 00:00 0
    46f80000-46fa7000 r-xp 00000000 fd:00 4537021 /usr/lib/libfontconfig.so.1.1.0
    46fa7000-46faf000 rwxp 00027000 fd:00 4537021 /usr/lib/libfontconfig.so.1.1.0
    46fb1000-46fb6000 r-xp 00000000 fd:00 4537463 /usr/lib/libXdmcp.so.6.0.0
    46fb6000-46fb7000 rwxp 00004000 fd:00 4537463 /usr/lib/libXdmcp.so.6.0.0
    46fb9000-46fbb000 r-xp 00000000 fd:00 4537034 /usr/lib/libXau.so.6.0.0
    46fbb000-46fbc000 rwxp 00001000 fd:00 4537034 /usr/lib/libXau.so.6.0.0
    46fbe000-470bc000 r-xp 00000000 fd:00 4538161 /usr/lib/libX11.so.6.2.0
    470bc000-470c0000 rwxp 000fd000 fd:00 4538161 /usr/lib/libX11.so.6.2.0
    470c7000-470ca000 r-xp 00000000 fd:00 4538165 /usr/lib/libXrandr.so.2.0.0
    470ca000-470cb000 rwxp 00002000 fd:00 4538165 /usr/lib/libXrandr.so.2.0.0
    470cd000-470d8000 r-xp 00000000 fd:00 521775 /lib/libgcc_s-4.1.1-20070105.so.1
    470d8000-470d9000 rwxp 0000a000 fd:00 521775 /lib/libgcc_s-4.1.1-20070105.so.1
    470db000-470ea000 r-xp 00000000 fd:00 4538167 /usr/lib/libXext.so.6.4.0
    470ea000-470eb000 rwxp 0000e000 fd:00 4538167 /usr/lib/libXext.so.6.4.0
    47202000-47221000 r-xp 00000000 fd:00 521757 /lib/libexpat.so.0.5.0
    47221000-47223000 rwxp 0001e000 fd:00 521757 /lib/libexpat.so.0.5.0
    47225000-4722e000 r-xp 00000000 fd:00 4538171 /usr/lib/libXcursor.so.1.0.2
    4722e000-4722f000 rwxp 00008000 fd:00 4538171 /usr/lib/libXcursor.so.1.0.2
    47231000-472ae000 r-xp 00000000 fd:00 4538177 /usr/lib/libfreetype.so.6.3.10
    472ae000-472b1000 rwxp 0007d000 fd:00 4538177 /usr/lib/libfreetype.so.6.3.10
    472b3000-472b7000 r-xp 00000000 fd:00 4538175 /usr/lib/libXfixes.so.3.1.0
    472b7000-472b8000 rwxp 00003000 fd:00 4538175 /usr/lib/libXfixes.so.3.1.0
    472ba000-472c2000 r-xp 00000000 fd:00 4538162 /usr/lib/libXrender.so.1.3.0
    472c2000-472c3000 rwxp 00007000 fd:00 4538162 /usr/lib/libXrender.so.1.3.0
    472da000-472e1000 r-xp 00000000 fd:00 4541916 /usr/lib/libXi.so.6.0.0
    472e1000-472e2000 rwxp 00006000 fd:00 4541916 /usr/lib/libXi.so.6.0.0
    472ef000-472f7000 r-xp 00000000 fd:00 4536832 /usr/lib/libSM.so.6.0.0
    472f7000-472f8000 rwxp 00007000 fd:00 4536832 /usr/lib/libSM.so.6.0.0
    47c3a000-47c51000 r-xp 00000000 fd:00 4541900 /usr/lib/libICE.so.6.3.0
    47c51000-47c52000 rwxp 00016000 fd:00 4541900 /usr/lib/libICE.so.6.3.0
    47c52000-47c54000 rwxp 47c52000 00:00 0
    f7c74000-f7c7a000 r-xs 00000000 fd:00 1012082 /var/cache/fontconfig/b79f3aaa7d385a141ab53ec885cc22a8-x86.cache-2
    f7c7a000-f7c86000 r-xs 00000000 fd:00 1012075 /var/cache/fontconfig/73a61b34dd8ca4d8a159807604ab432f-x86.cache-2
    f7c86000-f7e86000 r-xp 00000000 fd:00 4552825 /usr/lib/locale/locale-archive
    f7e86000-f7e89000 rwxp f7e86000 00:00 0
    f7e89000-f7f38000 r-xp 00000000 fd:00 4541295 /usr/lib/libstdc++.so.5.0.7
    f7f38000-f7f3d000 rwxp 000ae000 fd:00 4541295 /usr/lib/libstdc++.so.5.0.7
    f7f3d000-f7f42000 rwxp f7f3d000 00:00 0
    f7f42000-f7fda000 r-xp 00000000 fd:00 847817 /usr/lib/xorg/libGL.so.1.2
    f7fda000-f7fdf000 rwxp 00098000 fd:00 847817 /usr/lib/xorg/libGL.so.1.2
    f7fdf000-f7fe4000 rwxp f7fdf000 00:00 0
    f7fe6000-f7fe8000 r-xs 00000000 fd:00 1012083 /var/cache/fontconfig/87f5e051180a7a75f16eb6fe7dbd3749-x86.cache-2
    f7fe8000-f7fee000 r-xs 00000000 fd:00 1012081 /var/cache/fontconfig/7ddba6133ef499da58de5e8c586d3b75-x86.cache-2
    f7fee000-f7ff0000 r-xs 00000000 fd:00 1012079 /var/cache/fontconfig/e3ead4b767b8819993a6fa3ae306afa9-x86.cache-2
    f7ff0000-f7ff8000 r-xs 00000000 fd:00 1012078 /var/cache/fontconfig/e19de935dec46bbf3ed114ee4965548a-x86.cache-2
    f7ff8000-f7ffd000 r-xs 00000000 fd:00 1012077 /var/cache/fontconfig/beeeeb3dfe132a8a0633a017c99ce0c0-x86.cache-2
    f7ffd000-f7ffe000 rwxp f7ffd000 00:00 0
    ffe03000-ffe0a000 rwxp ffe03000 00:00 0 [stack]
    ffffe000-fffff000 r-xp ffffe000 00:00 0 [vdso]
    Aborted

  4. #74

    Default

    Quote Originally Posted by sonicboom View Post
    ok, now I messed something up again, I can't get the program to open (same problem I mentioned before). I will post what it says in the terminal after running amdcccle as suggested by Michael:
    Unfortunately it doesn't look like there is anything you can do on your end as the problem resides with amdcccle, which is still undergoing some work. I have forwarded your crash output onto AMD -- hopefully the problem will be fixed for you in this month's driver.

  5. #75
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    2

    Default

    I have installed the 8.35 drivers and very surprised that I have got most things OK. I upgraded to latest kernel and got ipw3945 working first go. Now my issue with the drivers is that the xorg.conf file generated is incomplete. Below is my current file. I will look at copying some things in from the backup copies.
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection
    What are the main bits to add? glxinfo reports that I am using Mesa (uck).

  6. #76

    Default

    Add

    Section "Extensions"
    Option "Composite" "Disable"
    Option "AIGLX" "Disable"
    EndSection

  7. #77
    Join Date
    Apr 2007
    Location
    Sydney, Australia
    Posts
    2

    Default

    Thanks for that. I hadn't seen the AIGLX disable before. I got acceleration happening by copying in some of the backed up xorg's. I have also installed XGL and got it running however, I can't get Beryl to run. It complains about XFree86 DRI missing. My current Xorg now looks like this;
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "dbe"
    Load "fbdevhw"
    Load "record"
    Load "freetype"
    Load "type1"
    # Load "synaptics"
    Load "glx"
    Load "DRI"
    Load "extmod"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "vesa"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Disable"
    Option "AIGLX" "Disable"
    EndSection
    The error when trying to load beryl is;
    Xlib: extension "XFree86-DRI" missing on display ":1.0.

  8. #78
    Join Date
    Apr 2007
    Posts
    1

    Default

    Quote Originally Posted by scuac View Post
    I am trying to build the 8.35.5 package for a Fedora Core 5
    machine, and something is odd. I use the following command:

    Code:
    sh ./ati-driver-installer-8.35.5-x86.x86_64.run --buildpkg Fedora/FC5
    and it goes on showing a lot of stuff I won't repeat here, but at
    the end it fails with this message:

    Code:
    error: Installed (but unpackaged) file(s) found:
       /usr/bin/fireglcontrolpanel
    
    
    RPM build errors:
        Installed (but unpackaged) file(s) found:
       /usr/bin/fireglcontrolpanel
    Removing temporary directory: fglrx-install.wX3805
    I thought this newest version didn't include fireglcontrolpanel
    anymore. What is going on??
    I checked /usr/bin/ and there is no fireglcontrolpanel there.
    Any ideas?

    I found a workaround to the issue above incase anyone is interested.

    After executing this:

    Code:
    sh ./ati-driver-installer-8.35.5-x86.x86_64.run --buildpkg Fedora/FC5
    ctrl+z the process after it says it has extracted the pkg. Then cd to the /tmp ATI directory and find . -name "fireglcontrolpanel" and delete it . This should exist in a usr/bin directory.

    After that just fg the process and it will build the rpms successfully.

  9. #79

    Default I have solved it!

    Quote Originally Posted by scuac View Post
    I am trying to build the 8.35.5 package for a Fedora Core 5
    machine, and something is odd. I use the following command:

    Code:
    sh ./ati-driver-installer-8.35.5-x86.x86_64.run --buildpkg Fedora/FC5
    and it goes on showing a lot of stuff I won't repeat here, but at
    the end it fails with this message:

    Code:
    error: Installed (but unpackaged) file(s) found:
       /usr/bin/fireglcontrolpanel
    
    
    RPM build errors:
        Installed (but unpackaged) file(s) found:
       /usr/bin/fireglcontrolpanel
    Removing temporary directory: fglrx-install.wX3805
    I thought this newest version didn't include fireglcontrolpanel
    anymore. What is going on??
    I checked /usr/bin/ and there is no fireglcontrolpanel there.
    Any ideas?


    hi,guy,I suffered from the problem ,too. and now, I have solved it. I found that a script named check-files in the "/usr/lib/rpm/" directory will be excuted when the error appears, so I edited the script and deleted the contents except the first line.then,I run the command
    sh ./ati-driver-installer-8.35.5-x86.x86_64.run --buildpkg Fedora/FC5
    Everything is going well,and finally,it generate sevral rpm files.
    I think there must be something wrong when the check-files was excuted,may be it's a bug !
    Last edited by somethingels; 05-06-2007 at 03:30 AM.

  10. #80
    Join Date
    May 2007
    Posts
    16

    Default

    Quote Originally Posted by Michael View Post
    Unfortunately it doesn't look like there is anything you can do on your end as the problem resides with amdcccle, which is still undergoing some work. I have forwarded your crash output onto AMD -- hopefully the problem will be fixed for you in this month's driver.
    I've been trying get the fglrx driver running on my custom 2.6.21 and after all the googling and breaking my head, I'm still unable to get it going.

    To begin with, I intalled the driver using yum and it goes fine, but the only problem is that I cannot use my custom 2.6.21 kernel. I then cleaned it up to reinstall for my custom kernel. For this I got the driver from ATI and tried two approaches both of which failed in the same place(aticonfig: munmap_chunk()), which is same as above
    1. Using ATI's install GUI
    2. I built the RPM and try to install them.

    Here are the logs -
    http://www.google.com/notebook/publi...GMIgoQj7mtt6gi

    Any update on this problem? Any suggestions? Any pointers ?

    Any help greatly appreciated.

    Thanks,
    KM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •