Results 1 to 6 of 6

Thread: Radeon 9550 + xf86-video-ati = Crash

  1. #1
    Join Date
    May 2009
    Posts
    9

    Default Radeon 9550 + xf86-video-ati = Crash

    I just installed the open source drivers (tried from the pacman repo (using Arch Linux) and the one from the GIT repo) and it runs really nice, almost as good as the FGLRX driver (which is a HUGE improvement since I last tried it last year). However, whenever I run a 3d application, after a little while (lighter programs like StepMania take a few minutes, fully 3d intensive programs is within 20 seconds or so), my entire desktop hangs to the point I can't move the mouse or input anything with the keyboard and I am forced to shut down the computer via the power button.

    Sometimes the screen goes black and the monitor loses signal, sometimes it leaves the display frozen on the screen. Either way, I can't use my mouse/keyboard and everything just halts.

    Any ideas? This doesn't happen with the FGLRX drivers or in Windows XP. I don't really want to use the FGLRX drivers, I'm pretty satisfied with the open source one (besides this problem, obviously). Any help would be greatly appreciated.

    Btw, I'm using a Radeon 9550 AGP 8x 256mb (running it as 4x in the xorg config file since my mobo doesnt support any higher than 4x)

    Here is my Xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "ServerFlags"
    	Option	"DontZap"	"False"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/misc"
    	FontPath     "/usr/share/fonts/100dpi:unscaled"
    	FontPath     "/usr/share/fonts/75dpi:unscaled"
    	FontPath     "/usr/share/fonts/TTF"
    	FontPath     "/usr/share/fonts/Type1"
    EndSection
    
    Section "Module"
    	#Load  "dri2"
    	Load  "record"
    	Load  "extmod"
    	Load  "dbe"
    	Load  "glx"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Synaps"
    	ModelName    "LCD Monitor"
    	HorizSync    30.0 - 130.0
    	VertRefresh  50.0 - 100.0
    	Option	    "DPMS"	"True"
    EndSection
    
    Section "Device"
            Option     "AGPMode"	"4"
            Option     "ColorTiling"	"True"
    	Identifier  "Card0"
    	Driver      "radeon"
    	VendorName  "ATI Technologies Inc"
    	BoardName   "RV350 AS [Radeon 9550]"
    	BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	DefaultDepth 24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Modes "1280x1024" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    Last edited by Exershio; 05-12-2009 at 11:23 PM.

  2. #2
    Join Date
    Jan 2009
    Posts
    117

    Default

    This sounds very much same problem that I run into using Ubuntu.

    Solution was updating video-ati, mesa (7.4 branch) and drm (including kernel modules) to the latest git version.

    More details are in bug report

  3. #3
    Join Date
    May 2009
    Posts
    9

    Default

    Quote Originally Posted by suokko View Post
    This sounds very much same problem that I run into using Ubuntu.

    Solution was updating video-ati, mesa (7.4 branch) and drm (including kernel modules) to the latest git version.

    More details are in bug report
    I installed libdrm-git and libmesa-git from ArchLinux's AUR, and it dropped my frame rate to unplayable levels.

    My glxgears was about 1700fps before I installed the GIT libdrm/libgl and now it's 150fps. I had this problem before I installed the GIT versions, but I fixed it before by commenting out load "dri2" in the Module section. Now that I installed the GIT libdrm/libgl my FPS sucks again, only thing is, I still have load "dri2" commented out.

  4. #4
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    You can usually remove the complete Module section for recent Xorg releases. It would even start without xorg.conf.

  5. #5
    Join Date
    Dec 2007
    Posts
    2,320

    Default

    Quote Originally Posted by Exershio View Post
    I installed libdrm-git and libmesa-git from ArchLinux's AUR, and it dropped my frame rate to unplayable levels.

    My glxgears was about 1700fps before I installed the GIT libdrm/libgl and now it's 150fps. I had this problem before I installed the GIT versions, but I fixed it before by commenting out load "dri2" in the Module section. Now that I installed the GIT libdrm/libgl my FPS sucks again, only thing is, I still have load "dri2" commented out.
    Are you sure you are even getting hw rendering? Run glxinfo and check the renderer string.

  6. #6
    Join Date
    May 2009
    Posts
    9

    Default

    Yeah it's not doing HW rendering anymore I don't think:
    OpenGL vendor string: Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string: 2.1 Mesa 7.6-devel

    It didn't say that before I upgraded

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •