Page 5 of 5 FirstFirst ... 345
Results 41 to 47 of 47

Thread: radeonhd r6xx-7xx EXA performance patch

  1. #41
    Join Date
    May 2009
    Location
    Exodus hair
    Posts
    76

    Default

    Quote Originally Posted by Obscene_CNN View Post
    zika,

    okay.

    First make sure you can build and install the sources as shown here

    http://www.x.org/wiki/radeonhd

    Next make sure you have acceleration working.

    Next, download the patch from this location and save it as the filename 'patch' in your xf86-video-radeonhd directory.

    http://pastebin.com/ff1e8c3c

    now you have 2 options.

    From the xf86-video-radeonhd directory type the command
    dos2unix -n patch fixed.patch

    Or

    From the xf86-video-radeonhd directory type the command
    sed 's/.$//' patch > fixed.patch


    finally from the xf86-video-radeonhd issue the command
    patch -p1 < fixed.patch


    I hope this helps

    Edit:
    Note you can remove the patch with this command if it causes trouble
    patch -p1 -R < fixed.patch
    Thank You. The problem is that I've installed radeon{,hd} and drm in some another way, through ppa's and, lately, with easy-drm-modules-installer, so I do not have xf86-video-radeonhd directory ... I will investigate the situation more, I'm up-to date to tormod, pendretti, xorg-crack and radeon-rewrite (with both radeon{,hd}) ...
    Thank You,again ...

  2. #42
    Join Date
    Feb 2007
    Posts
    83

    Default

    gtkperf doesn't seem very consistent, I ran the test a few times at x1000 with your latest patch. These are the results
    1 Total time: 103.18
    2 Total time: 104.41
    3 Total time: 105.26
    4 Total time: 99.90

    On the fourth run I moved the mouse cursor between the screens (dualhead)

    Same with x100 if I move the mouse cursor to the other monitor there's a 1 second diffrence between the results.

  3. #43
    Join Date
    Aug 2007
    Posts
    6,634

    Default

    You should set your cpu to performance mode, otherwise you bench speedstep/powernow...

  4. #44
    Join Date
    Feb 2007
    Posts
    83

    Default

    I got coolnquite disabled in the BIOS.

    cat /proc/cpuinfo says 2800.242 MHz

  5. #45
    Join Date
    May 2009
    Location
    Richland, WA
    Posts
    134

    Default

    As I have stated before I'm not a fan of gtkperf.

    I get my most consistent results when running gkrellm along side it for some strange reason.

    also to see what freq your cpu is working at at the moment you need to

    cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq

  6. #46
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    638

    Default

    Quote Originally Posted by bridgman View Post
    Yangman added power saving options to radeonhd as well : http://lists.opensuse.org/radeonhd/2.../msg00163.html

    EDIT - from IRC discussion this might be 5xx only, not sure. Will try to confirm.
    that's great news !

    thanks bridgman & kudos to Yang Zhao / Yangman

    @Obscene_CNN:

    thanks for making the (already fast) radeonhd even faster !
    Last edited by kernelOfTruth; 06-05-2009 at 06:41 PM.

  7. #47
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,463

    Default

    I think Matthias just posted a patch to the radeonhd list which turns on clock gating for 5xx/rs6xx parts, which should give some additional power savings. I stress *should* because nobody has had a chance to actually verify power reduction yet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •