Results 1 to 10 of 10

Thread: Problem with Open Source (ATI) drivers on Xpress 200M

  1. #1
    Join Date
    May 2009
    Posts
    2

    Default Problem with Open Source (ATI) drivers on Xpress 200M

    Hello.
    I have been trying to install the Open Source Drivers for my Xpress 200m (following the instructions foud on https://help.ubuntu.com/community/RadeonDriver ). The problem is that when i restart my computer after modifying the xorg.conf file, Ubuntu tells me there was an error parsing the config file and offers me to go back to the default graphic config.

    This is how the xorg.conf file looks like after modifying it:
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
            Identifier      "Radeon Xpress 200M"
            Driver          "ati"
            BusID           "PCI:1:0:0"
            Option          "XAANoOffscreenPixmaps"
    EndSection
    
    Section "Monitor"
            Identifier      "Generic Monitor"
            Option          "DPMS"
            HorizSync       28-72
            VertRefresh     43-60
    EndSection
    
    Section "Screen"
            Identifier      "Default Screen"
            Device          "Radeon Xpress 200M"
            Monitor         "Generic Monitor"
            DefaultDepth    24
            SubSection "Display"
                    Depth           24
                    Modes           "1440x900" "1024x768"
            EndSubSection
    EndSection
    
    Section "DRI"
            Mode 0666
    EndSection
            
    Section "Extensions"
            Option "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Mar 2009
    Location
    Hellas
    Posts
    1,106

    Default

    That's whole the xorg.conf file?

  3. #3
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    It is even a bit much, usually U config files are even smaller.

  4. #4
    Join Date
    Dec 2007
    Posts
    2,402

    Default

    It should work fine without a config file at all.

  5. #5
    Join Date
    Mar 2009
    Location
    Hellas
    Posts
    1,106

    Default

    And where are the fonts paths, keyboard, mouse etc...? :s

  6. #6
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    New ubuntu stores it in hal rules.

  7. #7
    Join Date
    Mar 2009
    Location
    Hellas
    Posts
    1,106

    Default

    Interesting... and that's good or bad?

  8. #8
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Well X configured using hal use is very interesting, like on the fly configuring for virtualbox or wacom tablets.

  9. #9
    Join Date
    May 2009
    Posts
    2

    Default

    The main problem seems to be fixed, i didnt touch anything, it just worked all of the suden.
    Now i have another problem; i try to run Warsow (the game), and it just shows me a black screen, and changes my res to 800x600. Also, the Cedega system tests tools tell me that the 3D aceleration isnt working properly =/

    will installing the radeonhd drivers fix the problem? =/

  10. #10
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,541

    Default

    Does Warsow or Cedega generate a log with more info ? You'd be looking for some kind of OpenGL-related message.

    For a 3D problem switching to radeonhd probably won't make a difference - the 3D code is in the Mesa driver.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •