Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Wow, the current radeon works exceptionally well!

  1. #1
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Thumbs up Wow, the current radeon works exceptionally well!

    I'm really surprised, enough that I felt compelled to post about it with a how-to.

    I'm running Jaunty 64bit on a Thinkpad T60, which has a Core 2 Duo T7200 (2.0Ghz), 2GB DDR2, and ATI Mobility X1400 128mb (R500).

    I made a few specific updates that have COMPLETELY changed the game, and the system runs better than I have ever seen it before... quick desktop performance, fluid scrolling, low GPU temp, low CPU utilization, and totally flicker-free Xv accelerated video under SMplayer/mplayer, even in Compiz. Flicker free even when scaling the window dynamically in the Compiz "scale" window switcher (similar to Expose in OSX). Suspend/resume work without any problems. I'm also getting ~2000 FPS in glxgears!


    Here's what I did:


    1. Ensure all normal Jaunty updates are done/current, including backports.
    This guide assumes that you are already using the latest radeon build from the Jaunty repos and that everything is working normally.


    2. Update manually to newer kernel.
    The current Jaunty kernel is 2.6.28-11. This is ok, but there have been a number of updates in the newer 2.6.29 branch that are highly relevant to video. The next distro release, Karmic Koala, is on the 2.6.30 branch, so upgrading to a 2.6.29 kernel is an "intermediate" step between Jaunty and Karmic.

    Ubuntu pre-packaged (.deb) kernel upgrades can be downloaded directly from the Ubuntu kernel team site here: http://kernel.ubuntu.com/~kernel-ppa/mainline/

    The most recent build of the .29 branch (as of this post) is 2.6.29.4. The two packages needed to do a manual upgrade are the "image" package and the "headers" package. Download the correct linux-image package for your architecture, ending in _i386 for 32bit, or _amd64 for 64bit. Download the linux-headers package ending in _all , rather than the architecture-specific one.

    Install both packages manually, and reboot.

    NOTE: Manual kernel upgrade *MAY* break your system or disable certain devices if you have kernel modules compiled/loaded for specific devices. Many wireless drivers are like this. IF THE UPGRADED KERNEL BREAKS SOMETHING IMPORTANT, SIMPLY BOOT THE PREVIOUS KERNEL FROM THE GRUB BOOT MENU. No harm, no foul. You can uninstall the new kernel through Synaptic if it didn't work for you.

    2nd NOTE: The Jaunty repos will not automatically provide security upgrades/updates for the new kernel. You will need to check the site periodically to see if there have been new kernel packages released in the .29 branch.


    3. Add the Ubuntu-X team (stable) repository for automatic updates to latest stable radeon/drm/etc.
    The Ubuntu X-SWAT repo is fantastic for new/stable upstream packages of various video drivers, including all of the the open source X video drivers (radeon, radeonhd, nv, intel, etc.), as well as new/stable Ubuntu packages of the proprietary fglrx and nvidia drivers. Updated DRM packages and a few input drivers are also in there.

    Since upstream ongoing driver developments and releases (even stable releases) are rarely backported once an Ubuntu distro is released, this is the next best thing!

    Ubuntu-X team site: https://launchpad.net/~ubuntu-x-swat
    The Ubuntu X-Swat PPA: https://launchpad.net/~ubuntu-x-swat...ive/x-updates/

    Add the Jaunty sources and the authentication key to your system, and you can use the Update Manager to upgrade to the newest stable builds.

    NOTE: Current builds (as of this post) are radeon 6.12.2 and drm 2.4.9-1.


    4. Add the SMPlayer and MPlayer repos that are recommended by the SMPlayer devs for Ubuntu. These are for much newer builds that support explicit (detected) Xv Textured Video outputs.
    The SMPlayer download page is here: http://smplayer.sourceforge.net/down...php?tr_lang=en

    Note the Ubuntu package repos listed for SMPlayer and MPlayer, by rvm. Go here and add the sources and authentication key for each:

    SMPlayer: https://launchpad.net/~rvm/+archive/smplayer
    MPlayer: https://launchpad.net/~rvm/+archive/mplayer

    Once the repos are added, install or upgrade SMPlayer and MPlayer. Then configure SMPlayer for the correct video and audio outputs for your system.

    NOTE: Current builds (as of this post) are SMPlayer 0.6.7-1 and MPlayer 1.0rc3-pre1.


    5. Enjoy!




    HD-quality video works great, but I found lower-res (SD) video to be a bit soft when scaled to full-screen, so I added a 3x3 unsharp filter to the MPlayer options within SMPlayer, which helped immensely. Refer to the docs on that one if you want to try it, or post in this thread and I can help.

    I hope this assists someone... it worked perfectly for me but your experience may not be as ideal. I have not tried the driver and drm updates on the current .28 kernel, so I don't know if they work well that way or not. Post up and let me know what happens!

    Thanks,

    Porter
    Last edited by Porter; 05-27-2009 at 01:45 PM.

  2. #2
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Quote Originally Posted by Porter View Post
    HD-quality video works great, but I found lower-res (SD) video to be a bit soft when scaled to full-screen, so I added a 3x3 unsharp filter to the MPlayer options within SMPlayer, which helped immensely. Refer to the docs on that one if you want to try it, or post in this thread and I can help.
    The default filtering for r3xx-r5xx is bicubic. Some people find this too soft. You can disable it (to use linear filtering) by changing the Xv attribute XV_BICUBIC to 0, e.g.,
    xvattr -a XV_BICUBIC -v 0

  3. #3
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by Porter View Post
    HD-quality video works great, but I found lower-res (SD) video to be a bit soft when scaled to full-screen, so I added a 3x3 unsharp filter to the MPlayer options within SMPlayer, which helped immensely. Refer to the docs on that one if you want to try it, or post in this thread and I can help.
    On r500 there is an xv attribute for bicubic filtering, which defaults to 2 (auto) - which means size > 2x gets bicubic filtering rather than bilinear.

    You can use xvattr to force it off if bicubic looks too soft for you.

    Edit - beaten to it again :-)

  4. #4
    Join Date
    Oct 2007
    Location
    Roanoke, VA
    Posts
    228

    Default

    Turning off bicubic filtering did change things a bit! Definitely sharper. I did some experimenting, and it seems like it actually looks best with bicubic on and a mild unsharp mask filter on. Better than bicubic off (with or without a filter), actually. Obviously this depends heavily on the source material.

  5. #5
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by Porter View Post
    Turning off bicubic filtering did change things a bit! Definitely sharper. I did some experimenting, and it seems like it actually looks best with bicubic on and a mild unsharp mask filter on. Better than bicubic off (with or without a filter), actually. Obviously this depends heavily on the source material.
    I guess that combination would be nice - with unsharp affecting perception and bicubic doing a nice smooth scale.

    http://en.wikipedia.org/wiki/Acutance

  6. #6
    Join Date
    Apr 2009
    Posts
    2

    Default

    Hi
    I do agree that the radeon driver provide good performance.
    However I only get 1800fps on glxgears - IBM T60 1,8ghz x1400 mobility.
    I am have to use kernel 2.6.29 because witj 2.6.28 and 2.6.30 I get x-freezes all the time, I really really hope this will be fixed in the future because I dont wont to be stuck with jaunty forever :-)


    What I still find very to be annoying is that I get strange, non consistent pixel corruption after resuming from standby.
    By "not consistent" I mean once I resume I have corruption in some areas or whole windows, resizing windows sometimes helps, but when I go back to standby and resume again everything is gone and all is fine....very very strange.
    I am using x-squat drivers currently, when I use tormods newer git drivers this corruption issue is a lot more severe and working with the notebook is impossible.

    And powersaving could be a little better ;-) .. but I know u guys are working on that. Btw a tool to check video clock would be awesome - to see if the dynamic clock actually works :-)

    cya

  7. #7
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default

    yeah, radeon works awesome!

    but i would like to see scaling options like in catalyt on windows (on linux catalyst does not work at all, so i could not test), so that i can use the full screen of my tft tv, connected over hdmi. the picture on the screen is too big, so i cannot see the whole picture.

    Thanks!

  8. #8
    Join Date
    Jun 2007
    Posts
    260

    Default

    Does the versions of Mesa and Radeon in Ubuntu X-Swat fix the performance regression that I had with the X200?

    Because for some reason 3D is messed up these days with the radeon-rewrite.

  9. #9
    Join Date
    Jan 2009
    Location
    UK
    Posts
    331

    Default

    Quote Originally Posted by juhuuu View Post
    Btw a tool to check video clock would be awesome - to see if the dynamic clock actually works :-)
    `rovclock -i`?

  10. #10
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,100

    Default

    What's the current state of rovclock? Last time I used it, it did not support anything newer than r3xx.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •