I am currently rebulding my media center, and in doing that i'm trying to streamline everything as much as i can.

I have gotten my ubuntu down to a 4second boot time to terminal. Which, considering this isn't SSD, i'm fairly content with.*

But when i add Xorg(no, not gdm, i've really stripped this machine down to the bare esentials) to the init script, suddenly my boot time jumps to 12 seconds.

That is, kernel and all init sans X is 4 seconds.

Xorg to an xterm(just that) is 8 seconds.

NOTE: once xorg has been launched, opengl, etc, works fine.

Have anyone else encountered this problem? anyone have a solution?

With the opensource radeon driver i have an xterm in 1.8seconds, so it doesn't appear to be a general Xorg problem, but rather a catalyst problem.

Another minor issue that i have, and have seen around the net. The xorg.log file is filled with the following warning:

(WW) AIGLX: 3D driver claims to not support visual <hex>

I've tried setting it to off(since i don't need it), but the message is still there. Anyone have a solution.


AAAAnnndd.. the last minor issue(which i suspect is related to the first).. Whenever i run xrandr Xorg spikes to 100% for about one second, and i get a

(II) Quirked EDID physical size to 0x0 cm

line in my xorg.log.

Any help would be very much appreciated.